Road Runner email over WiFi problemGeneral


Last Updated:

  1. Eric2

    Eric2 Well-Known Member This Topic's Starter

    Joined:
    Dec 30, 2009
    Messages:
    211
    Likes Received:
    6
    I have a problem sending e-mail over a WiFi network. ISP is Time Warner Road Runner. POP/SMTP accounts. I can receive, but not send.

    No problem sending/receiving e-mail over Verizon 3G network.

    No problem sending/receiving G-mail or using browser over WiFi network.

    Checked ports with ISP, and they are correct, according to them. (Port 25 for outgoing, and 110 for incoming.)

    All WiFi networks I've tried this on so far give the same symptoms.

    HTC says there is nothing wrong with the phone. ISP says there is nothing wrong on their end. (I suspect the ISP is the problem based on what I'm seeing.)

    Anyone else have this problem? Anyone have a solution?

    Thanks!
     

    Advertisement
  2. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    Some ISPs will have policy filters that are meant to prevent spammers from using the ISP's servers to originate (spam) e-mail: they will gladly accept mail (SMTP) from any IP that is on their own network, but have more restrictive policies for IP addresses outside their own network.

    This is more likely to be the case if the ISP doesn't require authentication for SMTP submission - do the Time Warner setup instructions not require authentication?

    Here's another question: do you have a WiFi unit that is connected to your ISP that you get the same (or different) results when you use it? (I think you indicated that was the case, but when I parse your post really carefully, I'm not 100% sure that is what you are saying.).

    If I were a betting man, I would suspect your ISP, as it is somewhat unlikely that the Eris' e-mail app does any special handling based on which interface is used to route packets. Does the Eris' mail app give you anything besides a generic error message when the sending fails?

    I sent e-mail to my own account using both the mobile net and my (home) WiFi - the only thing that I can observe from looking at the mail headers for those two different paths are that the Eris' mail app reports to the SMTP server it's own IP address - in the case of the Mobile Network, that is a public IP address, and the same as the IP address from which the mail appears to arrive from at the SMTP server - in the case of my WiFi connection, the Internal (LAN) IP address shows up in addition to the public address of my router's external IP. That means that your ISP's SMTP server can detect whether or not there is any NAT taking place.

    Even if you can prove that it is your ISP that is rejecting the e-mail, you will be unlikely to "change their minds" about their security policy. Seems to me that the only other thing you could try is to see if their SMTP servers will accept authenticated mail - it is likely that their mail acceptances policies will be a little more relaxed if you are providing credentials. Having said that, if you plan on doing this from random coffee shops, you should do it only if your ISP allows you to submit e-mail with TLS or SSL sockets.

    HTH

    eu1
     
  3. Eric2

    Eric2 Well-Known Member This Topic's Starter

    Joined:
    Dec 30, 2009
    Messages:
    211
    Likes Received:
    6
    HTH,

    Thank you for your reply. You clearly seem to know a great deal about networks. I do not, so I hope you will bear with me.

    As to your first question, Time Warner tells me that they do not require SSL or TLS, if that is what you mean by authentication requirements. (Although I thought those were security settings?) If that's not what you mean, can you please explain so I can ask them about it?

    To your second question, (I think), I do run other devices through my home WiFi network. I run several laptops through it with no problems at all. That is, I can send (and receive) e-mail from them. My sons have also connected to the internet through my WiFi connection without any problems.

    If I try sending Road Runner e-mail through a different WiFi network, I get the same results. It says there is a settings error, and takes me to the account setup screen.

    When I talked to the tech at Time Warner, he did not offer any particular reasons why my mobile device shouldn't be able to send e-mail through my (or any other) WiFi network. If there were some restrictions, one would think they would tell them that. I'm very surprised he wouldn't just come out and tell me what you just did. Maybe he didn't know? He seemed to indicate that it should work OK, and that there must be some problem with the phone or Verizon. At least that is the impression I got from him.

    I don't mind calling them back. If you would be so kind, can you suggest some pointed questions I can direct at them to help resolve this issue?

    Thanks again for your time,
    Eric
     
  4. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    Eric2,

    Sorry for the request for further information, but I asked for a very precise clarification:

    Can you send e-mail from the Eris through your home WiFi which is directly connected to your ISP? (You said you could "from other devices", but that doesn't necessarily mean you can not do it from the Eris. Maybe that is what you meant, but I am trying to be certain.).

    Please clarify - and I will follow up.

    eu1
     
  5. Eric2

    Eric2 Well-Known Member This Topic's Starter

    Joined:
    Dec 30, 2009
    Messages:
    211
    Likes Received:
    6
    eu1,

    No problem. Appreciate the help. Here's the issue: I can not send e-mail from my Eris through my home WiFi network, which is directly connected to my ISP (Road Runner). Again, I can receive e-mail from my Eris via WiFi, but not send. The e-mail accounts in question are with my ISP.

    By "other devices", I primarily meant laptops. Although I think my kids have also sent out "Wii mail" through the Wii video game over my home WiFi network.

    I also can not send e-mail from my Eris through any other WiFi network that I have tried. I get the same error. Again, receiving is no problem.

    Browser and g-mail sent/received from my Eris over any WiFi network, works fine.

    Any other info I can provide that might help with the diagnosis, let me know!

    Eric
     
  6. erisuser1

    erisuser1 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,644
    Likes Received:
    759
    Eric,

    Thanks for the clarification - that seems to suggest something else besides IP address (ingress) filtering rules at your ISP (although that might still apply for random WiFi hotspots.)

    I know how I would pursue this at my own place - I would "sniff" the traffic between the Wireless router and the ISP. SMTP and ESMTP are incredibly simple protocols, and the initial handshaking between the sending machine and the mail (SMTP) server is done entirely in 7-bit ASCII, so you can actually "read" the conversation between the two machines from another machine if the IP traffic is not inside an SSL or TLS tunnel. Generally, if the mail (SMTP) server doesn't like something, it will issue an error message, and you can directly read that if that is the case. Unfortunately, all those details are buried underneath the HTC Sense UI, so it isn't apparent which side of the conversation is having the problem - or if there is an obscure networking problem.

    In my case, that "sniffing" trick is easy to do, because I have a DSL modem with an Ethernet interface, so I can jam a dumb hub in between the WiFi router and the DSL modem, connect a laptop with Wireshark installed on it, and sniff away! But, if your WiFi router is also the same box with a cable or DSL modem for the WAN interface, that isn't going to work - and anyway, you would need an Ethernet "hub" instead of a switch, and I'm not sure those things are even sold any longer.

    There are other ways of attempting this, but they require a lot more networking savvy - putting a two-interface router between the WiFi client and router (linux box or Windows box with ICS), or temporarily setting your WiFi router to use no encryption at all, and sniffing packets "off the air" (most likely by using a linux machine with a wireless card).

    I doubt you want to become a networking geek, or make a career out of solving this problem, though.

    Maybe the thing to do is just to punt and set up automatic forwarding of your email from TW/RR to your Gmail account (or, if TW/RR won't do automatic forwarding, set up your Gmail account to grab the mail from TW/RR for you).

    I went through a similar exercise about 5 years ago with Gmail - I was working out of town, and my home ISP had a really horrible webmail interface, and no TLS/SSL security options for sending/retrieving of mail securely through public or WiFi networks... and Gmail allowed me to do all of those things and more, including keeping the option of using machines to archive my mail (via IMAP or POP3) if I wanted to avoid webmail for one reason or another.

    Five years later I have still have misgivings about letting Google harvest profiling information out of my e-mail, but the cloud-computing aspect of it certainly has simplified the amount of effort I spend managing mail.

    If you can get TW/RR to help, they can only diagnose the problem if the person you talk to has access to mail server logs, and you know the IP address of your DSL/Cable WAN interface. I'm skeptical that they will give you that kind of help, or that you will actually be able to reach a 2nd or 3rd- tier support person that has those kinds of network privileges.

    There is a possibility that HTC might be interested to help, given the symptoms you describe - but they would need a TW/RR account to do that; are you comfortable giving strangers your e-mail user ID and password? (You could change the password before and after the exercise).

    Sorry that I'm stumped for better ideas - if i think of better debugging ideas, I'll post them in this thread.


    eu1
     
  7. Eric2

    Eric2 Well-Known Member This Topic's Starter

    Joined:
    Dec 30, 2009
    Messages:
    211
    Likes Received:
    6
    eu1,

    Thanks again. Sadly, I don't understand much of what you have posted. BUT I have forwarded a link to this thread to my ISP, and perhaps it will get them to look into some of the possibilities you raised. Perhaps!

    It would be great if HTC also did as you suggested, but I don't hold much hope there. As far as giving them my e-mail account information, no, I definitely wouldn't feel comfortable doing that, even if I were to change the password temporarily. But maybe they can work with Road Runner and/or Verizon on it. And then again, probably not, especially if mine is the only complaint.

    As I mentioned, I did file an official complaint with Verizon, so perhaps that will also garner some more attention from HTC. To be honest, the last tech I spoke to at HTC seemed more interested in defending the phone, than being interested in solving my problem. Basically, his position was, it's not the phone, so we're done here.

    Regards,
    Eric
     
  8. JimmyRayBob

    JimmyRayBob Well-Known Member

    Joined:
    Nov 23, 2009
    Messages:
    315
    Likes Received:
    52
    OK - this may be complete off-base, but you never know what might help.

    I have Charter high-speed internet at home. I also have POP3 mail.

    With Charter, for the incoming mail server, i use pop3.mycompany.com

    But when using the outgoing mail server, it MUST be smtp.charter.net

    When i am on the 3G network, i use smtp.mycompany.com

    In other words, if i want to send an e-mail when i'm at home, i have to turn off the wifi and use the 3G network. Not a good solution, but it works. In fact, i've been skipping the wifi entirely at home.

    I hope this helps (but i doubt it) :)
     
  9. mosuli

    mosuli New Member

    Joined:
    Jan 21, 2010
    Messages:
    2
    Likes Received:
    1
    Hi eric,
    I was just having the same exact issue. I looked at my setting and under outgoing setting, I had require sign in selected. I deselected this option and my messages flew out. I don't know if this will effect my 3g yet. I don't have the eris so i do not know if you have the same setting, but this was on a moto droid.
    good luck.
     
    dut36 likes this.
  10. Eric2

    Eric2 Well-Known Member This Topic's Starter

    Joined:
    Dec 30, 2009
    Messages:
    211
    Likes Received:
    6
    Excellent!!! Tried it out, and that takes care of it on my Eris, too. I REALLY appreciate it. Many thanks, mosuli.

    Eric
     
  11. Eric2

    Eric2 Well-Known Member This Topic's Starter

    Joined:
    Dec 30, 2009
    Messages:
    211
    Likes Received:
    6
    OK...so not so good a solution. When I tried to send e-mail out over 3G this morning, it wouldn't work. So I had to change it back. What a pain that would be to have to switch it back and forth like that! So I guess they need a separate setting for WiFi and 3G. That would be a good solution, but I won't hold my breath.
     
  12. mc48

    mc48 Well-Known Member

    Joined:
    Jan 17, 2010
    Messages:
    480
    Likes Received:
    36
    I have TWC also and haven't been able to send emails from my Eris, just receive them, on 3G and I don't think on wifi from home either. I finally just gave up and use my gmail when i need to. you said:

    Maybe the thing to do is just to punt and set up automatic forwarding of your email from TW/RR to your Gmail account (or, if TW/RR won't do automatic forwarding, set up your Gmail account to grab the mail from TW/RR for you).

    how do you go about having the RR emails automatically forward to my gmail account?
     
  13. elboggo

    elboggo Active Member

    Joined:
    Jan 7, 2010
    Messages:
    33
    Likes Received:
    0
    I also noticed that my company's WIFI service, doesn't allow me to send email, but if I turned off WIFI I could.

    Thanks very much for providing this discussion in the forum, I never would have thought of trying that!

    Also, is it possible that the company is blocking pop3 outgoing? I am pretty sure that one of my other companies completely blocked pop3 for security reasons.
     
  14. sdstevep

    sdstevep New Member

    Joined:
    Jun 15, 2010
    Messages:
    2
    Likes Received:
    0
    I had a problem with sending over WiFi with an HTC Eris with my own domain email provider, and found this thread. It helped me remember a solution from the past, and this worked for my Eris.

    Some ISP's block email from any other than their own accounts - like, you can send email with your Cox account when logged in through Cox, but not while on the internet by any other means. They do that to block spammers. Of course, you're not a spammer, and every spammer knows these tricks anyway. But I digress.

    The way around it is to use a port for outgoing mail other than the default of 25.

    When I had a paid yahoo account, I could send using the Yahoo server through Cox on port 587. Right now I'm using port 3535 with a GoDaddy hosted email account. Another possibility I know of is port 80.

    Right now I have AT&T DSL, and I'm using port 3535 with my GoDaddy hosted email. I don't think just any random port will work, but try those.

    In Outlook 2003, go to
    tools > options > email accounts > View or change existing email accounts

    keep picking stuff until you get to the screen with a bunch of pop3 settings, fill those in, and then click the More Settings button (in the bottom right of the window in Outlook 2003)
    In the window that opens, click on the Advanced tab
    There you'll see "Outgoing Server (SMTP):"
    in the box to the right of that, type in your alternate port number.

    Try 80, 3535, maybe 587

    Below are detailed instructions I got from Yahoo which give some command prompt methods of testing that are a lot faster than changing Outlook settings every time.

    --------------------
    1. Select the Start menu button, then click Run.

    2. Type "cmd" or "command" without the quotation marks and press Enter.

    3. Type "telnet pop.mail.yahoo.com 110" and press Enter. If you are successful, you should now see "+OK hello from popgate" against a black screen. If you do not see this, close the window and start over or check your internet or network connection.

    4. From this screen, type "user xxx" (where xxx is your Yahoo! ID) and press Enter. You should be prompted with "+OK password required."

    5. Type "pass yyy" (where yyy is your case-sensitive password) and press Enter. If this is successful, you should receive a prompt with "+OK maildrop ready," followed by mailbox details. If this was not successful, you will receive "-ERR Error logging in. Please visit http://mail.yahoo.com/".

    6. Type "quit" and press Enter to sign off the POP server.

    7. Type "exit" and press Enter to return to Windows.

    If you were not able to achieve POP authentication during the first try, wait a few minutes and try again. After several tries, you should be able to tell if your ID and password will allow you to achieve POP authentication.

    Next, please perform the following test to confirm if you are able to communicate with the Yahoo! Mail Plus SMTP server:

    Select the Start menu, click Run, then type the following command:

    telnet://smtp.mail.yahoo.com:25 (of course, put your applicable email server in there in place of the yahoo one)

    Alternatively, you may also return to the command prompt using the POP telnet test instructions earlier (above), but instead type the command syntax "telnet smtp.mail.yahoo.com 25", then press Enter.

    If the port is not blocked, you should receive a response similar to "220 smtpxxx.mail.yahoo.com ESMTP" (where "xxx" is the server number you connected to). If you do not receive this specific response or if you receive a different response, your ISP, networking equipment, or security software may be blocking or scanning outgoing mail servers.

    NOTE: Please also try port 587 in place of 25. It is pertinent that you try the alternate port, as some ISPs will block port 25 by default.
     

Share This Page

Loading...