[ROM] [05.01.11] Velocity V1.1 | LG Ally | Android 2.2.1 Froyo | Super Fast | Stable


Last Updated:

  1. gb4fan

    gb4fan Well-Known Member

    Joined:
    Jan 18, 2011
    Messages:
    149
    Likes Received:
    7
    ok i have the zip file downloaded.
    Just dont have time to do anything with it. Will be a few days b4 I can do anything. Will advise as soon as I do.
     

    Advertisement
  2. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    OK, well good luck when you get the chance to work on it. :)
     
  3. bendabood

    bendabood Active Member

    Joined:
    Dec 1, 2010
    Messages:
    36
    Likes Received:
    5
    Hey,
    I've been reading up on the "One Click Lag Fix" for the Galaxy S series of phones and I was very intrigued. Would their be any way to port this same option to the LG Ally? This would great to see in the next version of Velocity. If it is possible and you need anyone to help test I would be glad. I have a good amount of experience with adb and am not worried about bricking my phone.
     
  4. FinalStorm

    FinalStorm Active Member

    Joined:
    May 15, 2011
    Messages:
    41
    Likes Received:
    5
    I updated to Velocity 1.1 a week after it was released. Runs FAST and beautifully. How ever I have a small/big problem. After a while of my phone being on, I Phone calls and SMS/MMS stop coming through. When someone calls, it rings normal on the callers end (vs going straight to voice mail) but my Ally doesn't wring. Same with SMS and MMS. Data still works fine, and when I make a phone call when its in this state, the call goes through normal, however when I end the call the phone app the other end is disconnected, and the phone app on my Ally seems as though it won't let me end the call, and won't close, thus forcing me to reboot. But heres the thing, one I reboot, my phone works just fine, and all of my messages start to come in, but after a while, the problem comes back and I have to reboot again to fix this.

    One thing I can think of is I haven't noticed this until after I installed the amazon app store about 6-7 days ago, and I have been getting a number of force closes from this app (which I have been ignoring). Is it possible that the Amazon App Store is causing this problem?

    Also one other small problem, for some reason my velocity scripts won't update, stuck at ver30.

    Other details:
    Velocity v1.1
    Clocked at 787.2 Max, 320 Min (scaling ondemand), using CPU Master Free
    Link2SD for apps on my 8GB class 6 partitioned SD Card
    -32MB Swap
    -640MB EXT4
    -Rest is FAT32

    I really hope this is an easy fix. Like just uninstalling Amazon App Store.
    Any help or ideas is helpful.
    Thank you all in advanced.
     
  5. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    One common way to troubleshoot 'computer' problems is to backtrack, undoing each step of things you have recently done, until the current problem stops. This helps locate the likely cause of the problem. Were I in your situation I would certainly try removing the Amazon App Store program and see if it helps.

    Do you have a recent Nandroid backup you could restore? I have gotten into the habit of making a Nandroid every week. It has saved me some grief more than once, and only takes a few minutes to do.
     
    FinalStorm likes this.
  6. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    These are some rather unusual settings compared to the "average" user of Velocity 1.1. Most are using no EXT partition at all, and I don't recall reading about anyone using a Swap partition on the SD card with Velocity. It also seems you are using 'aftermarket" apps to do all the things that Velocity Scripts have built in, such as OCing and setting which governor to use. These may be complicating whatever the problem is. I am unfamiliar with those programs, but I would suggest you rely on the intrinsic abilities of Velocity 1.1 since it can do all that. Why add extra baggage to achieve the same goals?
     
  7. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Joined:
    Apr 27, 2010
    Messages:
    477
    Likes Received:
    788
    In fact swap is useless as I have it disabled in kernel.
     
    Zoandroid and savoxis like this.
  8. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Joined:
    Apr 27, 2010
    Messages:
    477
    Likes Received:
    788
    Nope. The Galaxy phones use entirely different arch then ally uses with a qualcomm based processor. Not to mention the file systems the two phones use are different too. IMO ally doesn't need a "lag" fix as we have already pushed the far past stock to its upper limits.
     
    savoxis likes this.
  9. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    I was thinking it might not, but wasn't sure enough to mention it. :)
     
    FinalStorm likes this.
  10. FinalStorm

    FinalStorm Active Member

    Joined:
    May 15, 2011
    Messages:
    41
    Likes Received:
    5
    I have tracked down the problem to one of my amazon apps (Amazon.com or Amazon App Store). When one I get a force close for the app, my basic phone functions no longer work. However my phone comes back right after a reboot. Just waiting for the next force close to confirm.

    Doing a Nandroid now, Just in case.
     
  11. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    Very interesting! I use the Amazon market app that has been out for several months, and to my knowledge it isn't causing me issues. So perhaps it is the newer of the two? Did you get it from the Market, or from Amazon's app store?
     
  12. FinalStorm

    FinalStorm Active Member

    Joined:
    May 15, 2011
    Messages:
    41
    Likes Received:
    5
    I was able to get the Amazon.com app from the Android Marketplace, however the Amazon App Store I had to download and sideload to my Ally.
     
  13. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    Well, it seems you are not alone. I Googled " amazon app store causes problems"
    and this return caught my eye. Interesting reading.

    Amazon.com: Customer Discussions: App Store crashed my phone!

    Apparently the app itself has 'issues'. I believe I would avoid using it until they get the bugs worked out.
     
  14. FinalStorm

    FinalStorm Active Member

    Joined:
    May 15, 2011
    Messages:
    41
    Likes Received:
    5
    Interesting, I guess I should consider myself lucky that nothing has crashed my phone requiring a full wipe............ yet.
     
  15. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    What I also find interesting is that installing a single application can be so 'devastating' as to actually stop the phone from working as a phone. I guess I had thought that a smartphone was a "cell phone" with a "mini-computer" sort of "tacked on". But this seems to indicate that the very operation of the phone AS a phone is also dependent upon the same software (OS) that runs the added on apps. Apparently there is no "hardware firewall" between those distinctions.

    When I asked where you got the App Store app, I had the thought that if it came from the Market it might be one of those disguised malware apps I have read about which have shown up there. But getting it right from Amazon? Well, that tells me they need to 'bake' the app a lot more before shoving it out to us. It may serve us all well if you report this incident to them (if you haven't already). :)
     
  16. artcloud

    artcloud Well-Known Member

    Joined:
    Jun 28, 2010
    Messages:
    73
    Likes Received:
    16
    Off of the Amazon App Store topic, I recently ran into a friend with Cyanogenmod on his droid. I showed him some of the awesomeness of Velocity and he was impressed, what impressed me was ADWLauncher that they build into Cyanogenmod. So much, that I downloaded it from the market and installed the standalone ADWLauncher.

    Point of the story, is that it fixed the long delays between home screen rotation (keyboard out to keyboard in or vice versa at a home screen takes an extended amout of time to redraw apps and dock) that has seemed to plague the Ally since the release of ZVD (Froyo). By no means am I pointing fingers at Velocity for this problem, my theory behind the problem is Apps2SD as the stock launcher doesn't seem to misbehave until you have at least one or more app, that is installed on your SD card, being displayed on one of your home screens.

    Performance and response time is much more smooth than stock launcher also, at least it seems to be anyway. Also, ability to have 5 dock buttons is much more useful than the dots next to it for scrolling. Probably asking a lot, but I wouldn't mind seeing this as the default launcher for the next release of Velocity!
     
    Zoandroid and savoxis like this.
  17. DaemonOfChaos

    DaemonOfChaos Member

    Joined:
    Feb 13, 2011
    Messages:
    21
    Likes Received:
    1
    I am at a complete loss and am hoping someone can provide me with a little guidance / direction.

    I was not able to send pictures in text messages with Velocity 1.0 and thought by upgrading to Velocity 1.1 that might resolve the issue.

    I have performed a complete phone reset from within Settings > Privacy > Reset Phone as well as wiped the userdata and cache from within recovery prior to installing Velocity 1.1, which I have also done several times. I have also formatted my sd card in case there were any settings saved to it.

    No matter how many times I try the above wipe and install I am not able to send pictures within text messages.

    Is there anything else that I should be doing or that I could possibly be missing?

    On a side note, when attempting to access Google Navigation I am immediately prompted to install text-to-speech for turn-by-turn navigation, which I like. However when I click OK to install the text-to-speech I get a market screen saying no package exists. Has anyone else encountered this and more importantly know where I can get the files for voice navigation?
     
  18. mightysween

    mightysween Active Member

    Joined:
    May 5, 2011
    Messages:
    35
    Likes Received:
    0

    Indeed, it is stable at 729 MHz with the interactive governor. The downside is that it seems to drain my battery faster than smartass.
     
  19. bendabood

    bendabood Active Member

    Joined:
    Dec 1, 2010
    Messages:
    36
    Likes Received:
    5
    My brother has a droid running CyanogenMod and two features that I would love to see on Velocity are lockscreen gestures (gestures performed on the lockscreen that can launch applications, adjust volume, take a picture, etc), and the power control widget in the notification bar. Just a few ideas to improve an already amazing ROM :)
     
  20. KingOfGreen

    KingOfGreen Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    842
    Likes Received:
    179
    Are you restoring system data with titanium backup? If you are wipe all data and caches then reflash. If you arent restoring data then try dialing *228 option 2 and if it doesnt work dial *22899


     
  21. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    I had been using Launcher Pro, but the sometimes long delays to display home page icons is annoying, so I'm giving ADW a try. So far it does seem to put a stop to the icon display lag, although I did experience that 'once'. But it was during the installation of an ADW Theme, so makes sense it would re-draw things. Other than that its defaults seem a lot like how I had Launcher Pro set up, so not too bothersome to switch, except for needing to re-select all the icons for the home screens.
     
  22. bendabood

    bendabood Active Member

    Joined:
    Dec 1, 2010
    Messages:
    36
    Likes Received:
    5
    I also use Launcher Pro, I'll give ADW a try and let you guys know.
     
  23. 9qwer1

    9qwer1 Member

    Joined:
    Nov 16, 2010
    Messages:
    5
    Likes Received:
    0
    i still keep getting this OTA update notification when i updated to Velocity 1.1
     
  24. DaemonOfChaos

    DaemonOfChaos Member

    Joined:
    Feb 13, 2011
    Messages:
    21
    Likes Received:
    1
    No, I am not using Titanium Backup or ROM Manager.

    The *228 option 2 fails and when I do *22899 it says my phone cannot be activated and that I need to call an 800 number.
     
  25. KingOfGreen

    KingOfGreen Well-Known Member

    Joined:
    Nov 3, 2010
    Messages:
    842
    Likes Received:
    179

    Odd. Have you tried rebooting then dialing *22899 ive had it fail like that before but i rebooted and redialed and it worked.
     

Share This Page

Loading...