[Rom][5-17-12]Broken Out Connect 1.0 w/ Blitzkrieg Kernel

Last Updated:

  1. akikhia

    akikhia Well-Known Member

    honestly just 750 per core is enough

  2. Dracconus

    Dracconus Well-Known Member

    MtMichaelson would it be possible for me to get a version of the Blitzkreig Kernel for Stock ZV8, 9, or A ROM?

    I'm sure that I could chop it out of the Broken Out Rom, but I'd rather not, as I'm not sure how safe that could be.
  3. Lito007

    Lito007 Well-Known Member

    I know this is kind of a noobish question haha, but when you set the speed of the cores in SetCPU, am i setting it for just one or is that number the total of the two? For instance i set mine at 1350 Mhz, does that mean each core is at 1350 oorrr both cores are actually at 675 and when put together they make 1350? Completely off topic from the ROM here haha but its just a quick question, didnt think i should start a whole thread about it :p Thank you in advance =)
  4. airtioteclint

    airtioteclint Well-Known Member

    legit question. I was wondering the same thing when I read that. How do you set each core? Can it be done with romtoolbox?
  5. Dracconus

    Dracconus Well-Known Member

    The only thing that I've seen that even acts as if it knows that there are two cores is the Connect Optimizer.
    To further that, according to what I've read the second core is (at times) disabled by default, so unless otherwise specified to stay on it wouldn't matter what you set it's clocks to.

    Downclocking the second core is useless since at max speed it will automatically use the second core to optimize thread handling, and at a lower speed requirement, it would simply disable it, expanding your battery life.
  6. jprosek

    jprosek Well-Known Member

    No you wont ever be able to set each core speed seperatley because they both run off one clock and have the same multiplier installed. While u can set the processor speed they have to run at the same speed because of the limits set by the hardware of the chipset
  7. Dracconus

    Dracconus Well-Known Member

    Yup, has to do with the way the software is embedded into the processors control set when they're cutting them from the die. You'll never (as far as I know from fifteen + years of working on computers) be able to set a core speed individually unless there's a chip that is specifically coded for that purpose, but I highly doubt it since as I stated before, they clock and disable on their own as well as know when they're necessary for use way before you could.
  8. MotoTriumphant

    MotoTriumphant Well-Known Member

    I've notcied that broken out rom kills my battery so fast and it makes it overheat average 3-4 hours @ average 102-105 degrees Fahrenheit while Stock ZVA gives me 6-10 hours @ 95 Fahrenheit... cool.
  9. bwg2469

    bwg2469 Well-Known Member

    Lower the CPU speed
  10. Speeds03

    Speeds03 Well-Known Member

    So, How's it going?
  11. flabinall

    flabinall Well-Known Member

    Can folks please stop asking for eta's so you don't anger the devs who are doing what we're obviously not able to do, so it Don't mess over the ones who are grateful and PATIENT.thank you
  12. hyphieboy

    hyphieboy Member

    Hi all im planning on buying this phone (i have the piece of pure s*** huawei m835) and was wondering if this is a good phone and if broken out is a good starter rom? Thanks in advance
  13. uncholowapo

    uncholowapo Well-Known Member

    You've got 22 pages to answer your question :D
    hyphieboy likes this.
  14. LightenLhar

    LightenLhar Well-Known Member

    In short: Yes.

    In long: Yeeeeeeeeeeeeeeeeeeeeeeeeeeeeesssssssssssssssssss.
    hyphieboy likes this.
  15. over

    over Member

    Cross post from another thread. Appears that the other thread is dead so also making it here in hopes for people to view and confirm my suspicions

    After checking in the file /system/etc/init.qcom.post_boot.sh and also checking the logcat from kanaida, compared to my logcat as well.

    log states:
    • E/ThermalDaemon( 1005): CPU[0] frequency limited to 1512000
    • E/ThermalDaemon( 1005): CPU[1] frequency limited to 1512000

    Going through the /system/etc/init.qcom.post_boot.sh I noticed to lines of code that has a reference to scaling max frequency. *Also highlighted in the original text of the above file for reference.

    • chown system /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    • chown system /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq

    I believe that these are the system persistent files pertaining to the MAX level allowed for the CPU. Maybe mtmichaelson can confirm this as he originally created the ROM and Kernel.

    Further checking of these 2 files show a value of 1512000. I believe that these 2 files are marking the upper level that the CPU is allowed access. Hence why when placing the CPU at 1836 it automatically scales back down to the 1512 file. These files constantly write that max CPU can only be 1512. I have noticed that even if I try to underclock my CPU it defaults back to 1512.

    Given that, if the files are changed to a different value, they may constantly refresh setcpu, no-frill, etc, to the newly changed value. I am unsure of how these programs actually write the changes to the file(s) that are being used or even what files are changed. Seems to be some form of issue with the kernel itself but I will do my best to continue troubleshooting on my end with my limited knowledge to see if it is a system persistent write issue or not.

    I will be testing this on my own phone tonight when I get a chance but if anyone else would care to give it a shot I would not be able to stop you.

    *EDIT - So messing with setCPU app. I believe that I have found a work around to a few things here.

    1. Enable profiles and add a profile for battery level >= 50%(or whatever you want) and set as your top priority, nothing above it.
    2. Set your CPU for whatever you want and make the profile not exclusive

    Have tested this and it seems to be holding the changes now.

    *If anyone does test this before I get a chance either PM with the results or just post if it worked. I have the original files backed up if need be.
  16. Dracconus

    Dracconus Well-Known Member

    Try adding this:

    Code (Text):
    2. echo 1800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    3. echo 1800000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq
    Code (Text):
    2. echo 384000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    3. echo 384000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq
    4. [code]
    6. so that it looks like this...
    8. [code]
    9. echo 384000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    10. echo 384000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq
    11. echo 1800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    12. echo 1800000 > /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq

    and see if that'll work to stick them.
    flboy91 and X2Damon like this.
  17. Dracconus

    Dracconus Well-Known Member

    He gave the max speed system access but not an identifier and that's why it's setting itself to it's default, and sticking there - i THINK.
  18. X2Damon

    X2Damon Member

    Adding those couple of lines to "init.qcom.post_boot.sh" worked like a charm, my cpu speeds are sticking
  19. Dracconus

    Dracconus Well-Known Member

    sweet, I'm glad it worked, I was actually concerned with the speeds that I'd given you because I wasn't sure if there was a specific multiplier I needed to follow for the CPU to recognize the clocks. The speeds I gave you were standard 1.8ghz converted to kilohertz; but I'm really glad it works :D
  20. uncholowapo

    uncholowapo Well-Known Member

    I thought the same thing. Its supposed to be 1.82Ghz or something like that but if it works... it works :p
  21. ChiweN

    ChiweN Well-Known Member Contributor

    You are right, those values are missing. I dropped the post boot file back in and added these values, and yes it does stick now, but I'm getting a conflict somewhere. The phone has frozen 4 times since. I've deleted the file again and the phone is running right again with no freezing.

    Going to play with it more later and see if I can't figure it out.
  22. VeNoMzRevenge

    VeNoMzRevenge Well-Known Member

    Strange, for me it still wont stick. Deleting it is the only solution for my particular phone.
  23. ChiweN

    ChiweN Well-Known Member Contributor

    Did you reboot after you put the file back and changed the values? Either way it was causing my phone to freeze totally, I had to hard restart the phone.

    Alas, deleting the file is all that works for me too, but no big deal. It works with the file gone the way its supposed to and I've seen no.negative consequence yet after a Month.
  24. VeNoMzRevenge

    VeNoMzRevenge Well-Known Member

    Yup I did. No biggie for me too. I moved the file to the SD card, so to have it just in case.

    I have no negative side effects either, so far so good.
  25. LickeyMong

    LickeyMong Well-Known Member

    When I try flash this Rom it just boots splash logo even though I wipe everything and I have to use LG support drivers to reset my phone.
    please help I want to enjoy this rom:(

Share This Page