[ROM/CWM/OC-KERNEL] [OA]2.3.20-[FINAL] CRICKET+MPCS [Updated: 09/23/12]


  1. smokinjoe2122

    smokinjoe2122 Well-Known Member

    I learned error 492 the hard way. You have to wipe everything when installing these roms otherwise I think the cache partition becomes corrupt.

    Wipe user data. Wipe cache part. Then mounts and storage and wipe everything except SD card. Wipe dalvik. Install. After install make sure you can download from the play store. Then you can restore via titanium.

    Ive run into 492 twice and followed these steps and have no problems now. Good luck

    * I'd also like to add that this seems to be the fastest working revision yet. Nice job Spz0. Can you elaborate at all what core files you updated for this revision? Just out of curiosity.
  2. Spz0

    Spz0 Well-Known Member Developer

    I've got an idea or 2 about how to curb this. Need to do some testing first though.
    I've got our niece and nephew over this weekend, so not going to have time to work on anything I think.
    Keep y'all posted.
  3. theevildead84

    theevildead84 Well-Known Member

    You're using stock over this rom? You're crazy.

    I'll probably update to this ROM in awhile. I'm on SPZ0's last revision and honestly I've had no issues and I'm sick of flashing new updates... Thanks for sticking to it, SPZ0. You rock.
  4. ComradeR

    ComradeR Active Member

    Yep that did it. Thanks :D

    I too have to say this is one fast revision. Loading times are just awesome on the phone now. Even less lag on cpu hungry apps
  5. Spz0

    Spz0 Well-Known Member Developer

    Got something in the works with the 492 error. Think it has something to do with cache not being properly unmounted before formatting /flashing. Hopefully it will be ready by the next revision.
  6. pedro1977

    pedro1977 Well-Known Member

    If I recall correctly clearing data for both google services framework and google play, rebooting and waiting an hour should clear this too.
  7. dkurupt77

    dkurupt77 New Member

    Hi can somebody help with what im doing wrong when flashing this rom. it seems to flash ok then hangs and freezes at different places ranging from samsung boot up screen to android logo to trying to run anything on the phone etc....it wont go 5 minutes until in does it. I have flash a few roms in my time so i have a basic understanding of the directions.. i reflashed with every option possible including formatting, wiping, different recovery.. so im stumped
  8. Spz0

    Spz0 Well-Known Member Developer


    You phone probably doesnt like 900Mhz.
    I've packed up Voltage Control app into a flashable zip.
    Download it and flash through CWM, then try to navigate to it once you're booted, and change the Max value to 800Mhz and apply.

    Hope that helps!

    http://openzio.rtrnetwork.com/openzio/OpenAndroid/utils/OA-Voltage-Control.zip
  9. RetroDelete

    RetroDelete Well-Known Member

    Hey Spz0, the ROM works great. I love it bro. I can't wait for the next update ;D You should try playing with the Phone.apk, and change the colors of the input boxes, the loading bars, and volume. The only problem I seem to be having is that I can use the MMS fix, but it stops working after a reboot. I deleted the stock Messaging app, and reloaded the APNs and like I said, It worked once, then I rebooted, and it stopped working. I guess I'll just load the Stock SMS backup.
  10. Spz0

    Spz0 Well-Known Member Developer

    Just another update: I'll be releasing another revision to my ROM (probably tomorrow). An Upgrade will be available.

    Things changed:
    -Moar Kernel Modifications
    --adjusted threshold for better responsiveness
    --defaulted CPU at 800Mhz (for those having issues with booting at 900Mhz)

    -attempting a fix of the "492 Market error"
    -added Voltage Control (for cpu frequency control) --although I still recommend setCPU.

    Got family over atm that I've been neglecting, so I will release this update as soon as I can. So hang in there everyone who is having issues @ 900Mhz -- Help is on the way. :)
  11. Spz0

    Spz0 Well-Known Member Developer

    Revision up!

    New Changes:
    Revision 2.3.12
    • cpu up/down threshold changed in kernel (increase snappiness)
    • cpu defaulted to 800Mhz on boot (for people having issues booting @ 900Mhz)
    • Voltage Control app added to scale CPU (although I still highly recommend setCPU)
    • Attempting fix of "492 Market Error" (Only on Full ROM)

    UPGRADE AVAILABLE! Check Post#1 for all downloads and upgrades.

    Cheers.
  12. Spz0

    Spz0 Well-Known Member Developer

    Quick update: I forgot to adjust the OA graphic that people were talking about reducing in size.
    SO
    I've ammended the change to the UPGRADE.zip as well as the full rom release -- so if the graphic bugs you, just flash the UPGRADE zip for the reduced size graphic.

    ALSO, I wanted to bring to peoples attention (as it was late last night and I forgot a crucial description), that my attempt at fixing the 492 market error exists only in the full rom release (and if it works, will continue in all full rom releases).

    Hopefully this will be the last update before my 2.3.7 port (so you'll be able to sit on this revision for a good while. :) ).

    Cheers all. :)
    caseyjp11 likes this.
  13. BuggBunny

    BuggBunny New Member

    nice update but just since you started with this ROM, you have not done the fix of special characters in Spanish language, maybe I'm the only one who wants this, and I do not know much about how I do it myself, but if your bearings me where can I investigate and fix this ;)
    Thanks!
  14. caseyjp11

    caseyjp11 Well-Known Member

    I registered awhile back here, but would have done it again just to say thank you a zillion for this rom. Turned my anemic Vitality into snappy responsive lil' beast again. Until I move to a heavy hitter, this phone + your rom = awesomesauce.

    Oh, I am a "go"-head, and it rocks just fine with that set of apps as well. I drive a taxi, so this thing is my bread/n/better for regular customers, and now I'm not griping about laggy apps. Keep it up and again, thank you x 1000!

    C
  15. skierz

    skierz Member

    my admire freezes and vibrates on boot sometimes. then if it does boot it will start vibrating and freezes up not long after booting. I used voltage control and set to 800mhz. still freezes and vibrates. =( I reflashed at least 5 times now. Any suggestions?
  16. CoolStoryBro

    CoolStoryBro Member

    First off, thanks for putting this together. Sadly, I'm having symptoms similar to those described by skierz:

    My first boot went pretty well - I only use my phone with wifi, so I put it on airplane mode and set up my wireless connection. At first I could connect to the Play store, but it would force close on me (no prompt to choose between waiting and closing, just buzzing) and subsequent boots result in freezing before I'm able to do much of anything.

    I also attempted to change the CPU to 800 mhz max with the same results. I cleared the data, formatted everything but the SD card, and reinstalled but still have the same problem.

    I made a backup, but I'd certainly prefer to use this over stock. Any suggestions?
  17. pedro1977

    pedro1977 Well-Known Member

    See my previous quote, try this.

    If I recall correctly clearing data for both google services framework and google play, rebooting and waiting an hour should clear this too.
  18. CoolStoryBro

    CoolStoryBro Member

    I forgot to mention that I tried it before my last flash. This last boot has yet to freeze on me for the last fifteen minutes or so, but the Play store still force closes on me without warning after clearing the data as you described again since the last flash.

    Thanks for chiming in.
  19. pedro1977

    pedro1977 Well-Known Member

    If it says a vending is force closing then it could be the play installtion itself, ive had this problem before myself too.

    No worries

    Good luck
  20. skierz

    skierz Member

    So far running at 480mhz is stable. No freezes whatsoever. Going back up to 800mhz causes freezes and vibrating. Can't reboot or power off because it gets bumped back up to 800 or 900mhz and takes a few tries to get it boot fully and correctly in order to set it back to 480mhz.

    I did try going back to stock and starting over but it didn't help.

    I love the ROM though. So far it's worth running at 480mhz because it's so f u c king awesome.

    NO ROM has been stable on my Admire except for Admiral Beast.

    After all this flashing back and forth my camera doesn't work anymore and I have that yellow triangle on boot up. And I have the E:can't mount cache ect.... shit while in CWM
  21. pedro1977

    pedro1977 Well-Known Member

    Im not sure why you are all having so many problems with freezes and burps. This ROM was stable a few revisions ago when I tried it, so im not sure if spz0 made a few changes that have caused some instability or there are hardware problems with your phones.

    You didnt say how you flashed back to stock was that a recovery ???? Its probabaly best you flash it to stock with this.

    http://androidforums.com/vitality-a...-eh29-upgrade-utility-leaked.html#post4526975

    install cwm 7 not 8, and then restore your stock backup.
  22. skierz

    skierz Member

    Found out today that GPS causes my phone to freeze and vibrate while down at 480mhz.

    :confused:

    I used Odin to flash back to stock from here....[ACS] THE ODIN THREAD: Return to stock

    then I installed CWM 7 then CWM 8 then OA ROM

    I have an Admire on Metro P. O. S.
  23. pedro1977

    pedro1977 Well-Known Member

    Sorry i was a little confused i didnt realise you were reflashing to go back to OA I thought you were trying to go back to your stock backup. You could try the link i provided anyway, that is a complete install of stock. I cant understand why your phone will not work at 800mhz, flash stock fresh above and see if that works, if it does and his doesnt work at 800/900mhz then their must be something wrong with the OA rom. He seems to be busy with other things at the moment as he hasnt been on for a few days (i think hes onto 2.3.7). You also try other frequencies, why 480mhz??? Another option is to flash an older revision. I do have a copy so maybe if you have no joy I could post it as a temp solution.

    Edit; actually you cant flash our one unless its for a short period as its for cricket not metropcs.
  24. skierz

    skierz Member

    I am running at 480mhz because voltage control goes from 900 to 800 down to 480. VERY STRANGE!!! There is no setting between 800 and 480. It's either 800 or 480.
  25. CoolStoryBro

    CoolStoryBro Member

    The plot thickens... on some boots I've noticed that the freezing that seems to occur is really the phone not displaying the app or utility I just opened. As an example, I opened the drawer and chose Voltage Control, the usual popup indicates that it has been granted super user permission, but the screen continues to show the drawer. When I press the home button it shows the Voltage Control window, but I can't interact with it. This behavior was been consistent during this last boot, but at least I'm able to rotate the screen so it redraws. Changing the CPU to 480 mhz makes no difference with this issue.

    This last boot seems to be working much better, though. I've been able to do more stuff in the Play store without it closing on me. Maybe reinstalling CWM, clearing everything but the SD card, and reflashing did the trick.
Loading...

Share This Page