[ROM] CyanogenMod 7 RC1 V4 [Stock Kernel] for Xperia X8


  1. gabeyong

    gabeyong Well-Known Member

    DISCLAIMER: Please note that I will not take any responsibility for any loss of data or the malfunctioning of your Xperia X8.

    Read the instructions below twice before attempting to install this Custom ROM. There is a chance you might "brick" your phone.


    SPECIAL THANKS TO:
    KUYAGAOL
    CYANOGENMOD TEAM
    XPERIAFAN 13

    Xperia X8 devices can now install CyanogenMod 7 RC1 Android 2.3.5

    CyanogenMod 7 RC1 Android 2.3.5 Features:
    196 MB FREE IN INTERNAL MEMORY
    * Back Button Ends Call
    * ICS rotation animations
    * ICS animations
    * On/Off option for ICS rotation animations
    * Gingerbread's screen on/off animation
    * Loop Ringtones
    * No Bootanimations (now CM7 default)
    * Ultra Brightness
    * ADW Launcher by CM
    * OverClock
    * Undervolt
    * SdCard Cache Size
    * More option on VM heap Size
    * Send Mic Mute to Audio Manager
    * Camera Button play and pause music on lockscreen
    * ext app2sd
    * Custom text on carrier level
    * Bubble, Ravamped, Holo and Blade stile for ring lockscreen
    * [NEWS!] All windows change with the theme, including the volume bar and the phone menu options.
    * ThemeChooser now available from Settings/display

    BUGS: Radio (working on fix for this bug for V5 release)

    You can read about the features...here... <---

    Requirements:
    - Rooted Xperia X8 E15i NOT E15a
    - xRecovery installed
    - ClockworkMod Recovery*
    - SE Stock Kernel

    If you are stuck in a boot loop it's because you have got an old baseband xxx006
    Download and flash Baseband 015 using FlashTool

    METHOD
    (A) Make a backup of whatever ROM you are using ClockworkMod Recovery*
    1. Restart Xperia X8
    2. Reboot into ClockworkMod Recovery*
    by hitting the back button multiple times when you see the SE Logo on the screen
    3. Go to Backup / Restore <click><backup>
    4. <reboot> your Xperia X8
    5. Download:
    CM7_RC1_V1
    CM7_RC1_V2
    CM7_RC1_V3
    CM7_RC1_V4

    (B) Installation of CyanogenMod 7 RC1 ROM:
    1. Copy CM7_RC1_V4.zip to root of SD Card
    2. Reboot to ClockworkMod Recovery*
    3. Scroll down to <mounts and storage>
    3a. and <format /system>
    3b. and <format /data>
    3c. and <format /cache>
    3d. go back to Main Menu <Wipe data / factory reset>
    4. Install custom zip <select> CM7_RC1_V4.zip
    5. install completed <Reboot>
    6. Enjoy super fast and stable Gingerbread 2.3.7 on your X8

    (C) Going back to your previous Custom ROM (Are you sure you wanna do that?)
    1. Shutdown and Reboot your Xperia X8
    2. Reboot into ClockworkMod Recovery*
    by hitting the back button multiple times when you see the SE Logo on the screen
    3. Go to Backup / Restore <click><restore>
    4. When restore is complete <reboot> X8

    NOTE*:
    For those who do not have ClockworkMod Recovery
    a) download ClockworkMod Recovery
    b) flash the ClockworkMod Recovery zip file using xRecovery
    c) reboot into ClockworkMod Recovery

    RESOURCES:
    ClockworkMod Recovery 4.0.1.5


    SUPPORT:
    SONY Ericsson Support Website
    PC Companion, USB Drivers for Xperia X8, SEUS & Media Sync...

    If you need any help... you can post your problems/issues here.

    cheers :)
    gabe

    Advertisement
    fauzan89 likes this.
  2. Hi, I've tried to install the new CyanogenMod, but while I launch the .zip install, it returns "assert failed: getprop("ro.product.device") == "E15i" || [...]".

    Rebooting the phone, from terminal I have looked for getprop and values are ok.

    I have try to install both before and after system format, but the error persist.

    Anyone can help me ?
  3. tritonas00

    tritonas00 New Member


    same problem here :(
  4. gabeyong

    gabeyong Well-Known Member

    sorry not enough info to help, so i am guessing...

    are you using xRecovery to install?
    you should be using clockworkmod recovery to install

    cheers :)
    gabe
  5. tritonas00

    tritonas00 New Member

    i use clockworkmod 3x

    I followed exactly your insructions.Its first time i have this problem.Every other rom installed fine.

    Now i use gingerdx 017.Are there any differences with this rom?

    Thanks for reply!
  6. The Man

    The Man Member

    plz help me...i do many time...all the intruction i follow..nothing i skip...but when i use CMW, it always aborted...i tried every way..i enable sign varification, also cannot...what actually must i do? im using 2.1....already rooted installed CWM 4.0.1.5...what i do wrong? thanks for helping me :)
    mitsosgest likes this.
  7. mitsosgest

    mitsosgest New Member

    me to :/
  8. The Man

    The Man Member

    come....anyone, plz help me...or did i need to flash it using flashtool??
  9. gabeyong

    gabeyong Well-Known Member

    Hi,

    Apologies... This ROM is a bit fussy (signed ROM).

    It requires Xperia X8 E15i NOT E15a
    And baseband 015 = X8 Shakira E15i_2.0.2.A.0.24_ril.ftf

    The reason for your error message is either...
    Wrong Xperia X8 Model or wrong baseband.

    cheers :)
    gabe
  10. The Man

    The Man Member

    mine is E15i......baseband also 015 n the file i download is shakira...so whts the problem?? file.ftf? is that means i need to flash it using flashtool???

    actually what i need to makesure is done on my x8??
    root = done
    xrecovery = done
    CWM = done

    is there anything tht im forgot to install??

    tq for helping me :)
  11. The Man

    The Man Member

    ok like this...lets assume that my x8 is new hp...then i root my hp...install xrecovery...then install CWM...mine is latest kernal ri8 becoz yesterday, i dont knw how many time i flash my x8 using SEUS...10 hours in front of my laptop bcoz trying to install this cyanogenmod 7.1 @ shakira...so i just need to flash this roms through CMW using ur instruction ri8? all i done but the result is aborted...
  12. The Man

    The Man Member

    omg...no body here...
  13. troika

    troika Member

    I'm gonna tell anybody who reads this exactly what i've done, and why it is still not working:
    a) Rooted my phone.
    b) Got all thingys (xrecovery blah blah blah...) installed.
    c) Cyanogenmod 6 (android 2.2) previously installed.
    d) Got baseband ... 015.
    e) My phone model is E15i.

    What I did was:
    a) download CM7.1 from the website.
    b) Copied update-cm-7.1.0-x8-signed.zip to my sdcard.
    c) rebooted to clockwork mod.
    d) tried to install zip from sdcard.
    ...
    AND I STILL GOT THE ERROR.
    if anybody can tell me where i went wrong, i'd be really grateful for it.
    Thanks in advance.
  14. troika

    troika Member

  15. fash_ric

    fash_ric New Member

    Ok same problem as everyone else asset failed error my phone is E15i and 15 baseband. Everything done exactly but still the error. Maybe the zip is corrupted?
  16. troika

    troika Member

    @fash_ric:

    umm, i can see a few reasons why maybe you're wrong:

    a) i've downloaded the file from different websites, which means there isn't any problem with cyanogen's servers (and the files stored in it).
    b) cyanogen would never release an update which doesn't work.

    at the same time, i really really hope you're right, since i heard cm7.1 is awesome, and i'd really love to have it on my x8.
  17. shameeltas

    shameeltas New Member

    i'm also facing the same problem
  18. veervardhan

    veervardhan New Member

    Hi,
    I am using floyo 1.0b since last month , yesterday onwards i started facing network problem in my fone when i was trying to fix andrd market . As told by Gabe I deleted .android secure and android folder also , but the problem persists.
    after that I updated my fone to GingerDX.v17 all went smooth excpt the phone network .

    Ironically network re appears after 15 min. or so . Right now i rolled back to floyo

    Please Help me out!!!
  19. troika

    troika Member

    @veervardhan:

    unfortunately, we x8 users have extremely limited options.
    CM is the best custom ROM for any phone, since it is extensively tested by loads of people and the developers are pretty good, too.
    Other ROMs like the ones you mentioned are developed by a few kind people who have the time and resources to develop ROMs for a particular phone.
    These unfortunately cannot match up to CM in terms of stability and performance, since there are always sure to be a few bugs around, and the comparatively less number of users means there aren't as many people to identify such things.

    So, maybe what I'm saying is, we're all in the same boat, stuck on an old OS, waiting for someone to identify the problem with CM7.1 for x8, so that we may use it too.

    THANK ME IF YOU FIND THIS REPLY USEFUL!
  20. seanpr92

    seanpr92 New Member

    dont know if you guys know this but cyanogenmod requires an unlocked bootloader otherwise it will fail you cant simply just root and xrecovery

    heres the guide for noobs


    forum.xda-developers.com/showthread.php?t=1267273
  21. The Man

    The Man Member

    hurm.....................................already unlock bootloader...not done! failed!!!!
  22. The Man

    The Man Member

    already unlock bootloader...failed also!!!........haizzzzzzzzzzzzzzzz
  23. The Man

    The Man Member

    orait guys...i solved it!!!!!!!!!! YESSS!!!!.....

    its true tht u need to unlock bootloader, but its IMPORTANT for u to change ur kernel too!!!!! go flash FXP028 kernel.....huhuuuuiiiiiiiiiiiiiiiiiiiiiiiiiii :D OMG, admin, ur information, soooooooooooooooooooooooooooooooooo, not helpful..im sorry...u say for requirement, "latest kernel"....suppose u said, must have FXP kernel!!!!
  24. gabeyong

    gabeyong Well-Known Member

    Hi,

    Thanks for the update. I have been away for a while.
    I have updated the instructions to include flashing FXP043 Kernel

    cheers :)
    gabe
  25. The Man

    The Man Member

    great...love u!!!! :D

Share This Page