[ROM][FINAL] CM7 7.2 RC1 - g60 style [7.11.12]


  1. g60madman

    g60madman Well-Known Member Developer

    [​IMG]
    Image by: CornfedChris

    README:
    This ROM is Cyanogen Mod 7.2 RC1. The most current version of CM7 which runs better is http://androidforums.com/triumph-all-things-root/590069-rom-hold-mtdev-cm7-build-20120810-a.html

    THANKS:
    There is a lot of thanks and appreciation that go into this rom. First I would like to start out by thanking Wyzor for handing the keys to the castle to me. Hopefully I can stand in his shoes and help bring continued success to this rom as he did. Next of course I can not thank TickerGuy and Issacj87 enough for all their hard work in paving the road for all of us devs and making the Motorola Triumph a usable device!! Finally I would like to thank mantera for his continued success with both CM7 and now his show stopping CM9!! Also I would like to thank all the other devs that continue to release roms for the triumph, keep it up!!

    KNOWN PROBLEMS:
    ∙ HDMI does not work (Keep a Froyo backup if need to use it occasionally)
    ∙ BT or WiFi enabled will prevent deep sleep mode, this is a required hack on custom ROMs (Use built-in Notification bar widget to quickly toggle)
    ∙ Some videos in portrait mode flickers. (Enable CM settings 180 orientation & flip upside down)
    ∙ Camera and Camcorder hard click when auto focusing causing feedback clicks when recording video

    FIXED PROBLEMS:
    ∙ Volume sometimes low (pausing or restarting audio sometimes helps)
    ∙ Proximity issue with the phone when you move it away from your face during a call, screen stays off
    ∙ Toggling video from front to rear camera crashes
    ∙ Screen stays dim 3 to 5 seconds when set to auto-brightness FIXED

    REVISION FINAL:
    ∙ Took ROM r0.9 and edited build.prop to show g60style-final as this ROM was most stable ROM as Camera works
    ∙ Removed all Theme ICS, MIUI, Cyanbread, Androidian
    ∙ Replaced Launcher2.apk with new updated version from r.11
    ∙ Rom is 85MB in size
    ∙ Fixed headset issue on reboots no more plug unlplug

    DOWNLOAD:
    All revisions of ROM's will be listed on this site below as I continue to develop and make changes
    http://dl.mtdev.us

    DONATIONS:
    Your donations are very much appreciated. All funds are strictly used to help better MTDEV releases be that website or workstation upgrades for all Team Members
    [​IMG]

    DONATION THANK YOU:
    I appreciate any and all donations for my work. This is not my daily job but it sure is fun! Here is a list of people I would like to thank for donating to the cause: MAC_NYC, RileyPER, MikeRL, samhande, garrmack, dsmryder

    Advertisement
  2. g60madman

    g60madman Well-Known Member Developer

    FINAL VERSION
    —————————–
    CM7 7.2 rc1 g60 style final:

    ∙ Took ROM r0.9 and edited build.prop to show g60style-final as this ROM was most stable (Camera works)
    ∙ Removed all Theme ICS, MIUI, Cyanbread, Androidian
    ∙ Replaced Launcher2.apk with new updated version from r.11
    ∙ Rom is 85MB in size
    ∙ Applied headset fix to ROM
    ∙ 3G Speeds are rocking now!


    INSTALLATION PLEASE READ:
    Follow these simple instructions if you’ve never flashed a ROM on the MT. If upgrading from a previous CM7, it is HIGHLY recommend to always do a full wipe data/factory reset & advanced -> dalvik-cache in recovery mode. If you simply wipe both caches and install the ROM you will be carrying over parts of the last ROM. If you need to carry over settings here is a written guide [Guide] How to Backup and Restore Apps and Data when installing new ROMs

    Android Market/Play is not included for legal reasons, you MUST flash gapps.zip RIGHT AFTER flashing this ROM zip for the first time before rebooting, gtalk.zip (Google Talk) is optional. After booting into the ROM, you may remove some of the bloatware, see this thread.

    REMOVED SOFTWARE
    ———————————
    If you still would like the old Applications I have removed you can download them from here

    http://dl.mtdev.us

    ADWLauncher.apk – ADWLauncher
    360 Launcher
    CMStats
    CMWallPapers
    CMUpdateNotify
    Email
    File Manager
    Launcher 2
    Sound Recorder
    Speech Recorder
    Terminal Emulator – Not offering download as this app does not update, but updates from Play Store
    Themes have been removed from ROM

    OLD VERSIONS
    ———————–
    CM7 7.2 rc1 g60 style r0.11:

    ∙ updated android_framesworks_base 34 files changed, 439 insertions(+), 328 deletions(-)
    ∙ updated android_hardware_msm7k 3 files changed, 54 insertions(+), 38 deletions(-)
    ∙ Audio problem fixed again based on CM7 code updates
    ∙ Removed Launcher2 old wallpapers and any image over 400k to slim ROM size

    ——————————————————————————————-

    CM7 7.2 rc1 g60 style r0.10:

    -Updated ROM build name to remove update & triumph to shorten zip name to “cm-7.2.0-rc1-g60style-r0.xx.zip”
    -Reinserted CM7 camera code, imported changes from MSM/QSD Code Aurora, inserted back in Tickerguy’s complete focus fixes (missed a few settings in r0.9)
    -Changed 5MP profile from 2592
  3. thebryceee

    thebryceee Well-Known Member

    Screenshots?
    guiitardude likes this.
  4. b_randon14

    b_randon14 Well-Known Member Developer

    It will look exactly like CM7 reloaded. If you had of read the post, he said it is exactl the same code as Whyzor's CM7 reloaded. He is just going to be taking over to development of the CM7 build because Whyzor is moving on to other things.
    guiitardude and g60madman like this.
  5. FroyoShark

    FroyoShark Well-Known Member

    Great to see that CM7 development is being continued :)
    guiitardude likes this.
  6. skarni

    skarni Well-Known Member

    I have really enjoyed using CM7 so I appreciate your taking on the task. I hope you will enjoy your role of keeper of the keys.
    MikeRL, guiitardude and g60madman like this.
  7. garrmack

    garrmack Well-Known Member

    Using WhyKernel as well?
    guiitardude likes this.
  8. skarni

    skarni Well-Known Member

    I know that all you did was recompile Whysor's ROM, but I ran ANTUTU and scored almost 200 points higher, exactly 3000! I'm not overclocked or over-volted. I also ran Quadrant and Nemark and got slightly better scores.
    guiitardude likes this.
  9. marc12868

    marc12868 Well-Known Member Contributor

    The only thing that will really tell you anything is nenamark and nenamark 2 which show FPS. Quadrant and antutu and other benchmarks aren't all that accurate... So if you run quadrant again I bet you would have a different score whether it be higher or lower.
  10. DenverNugs

    DenverNugs Well-Known Member

    Can't wait to see some of the things that will be implemented. Glad that someone is taking over. :D
  11. xploPR

    xploPR Well-Known Member Contributor

    Good to know CM7 for MT is not over!
    guiitardude likes this.
  12. dsmryder

    dsmryder Well-Known Member Developer

    I hope to be able to help in my own, small but growing, way:D
  13. dsmryder

    dsmryder Well-Known Member Developer

    I setup my github and made a small change to the camera app so the focus rectangle should switch to green instead of red when focused. It's a dirty method, but until I learn more, it will do.
    thangfish and g60madman like this.
  14. Izzard

    Izzard Well-Known Member

    I still have a problem with video playback, all the videos are lagging, despite what class SD card I use.
    Another issue I found is Bluetooth streaming. I used to stream Pandora and Google Music via Bluetooth in my car all the time. Doesn't work anymore.
    guiitardude likes this.
  15. g60madman

    g60madman Well-Known Member Developer

    Did you do a full wipe or just cache? I was streaming Pandora to work this morning through Bluetooth. I only have Netflix and YouTube setup for video and I have not experienced any lag at all.
  16. Izzard

    Izzard Well-Known Member

    Yes. I do full wipe, wipe davlik. Bluetooth connects, see my phone, but won't stream. As soon as I shut down the radio in the car, the music comes out from the speakers.
    Lag in video I described in Reloaded thread. Whenever I watch the movie I can see how video (xvid or mp4) lags, freezes and unsynced. Not always though. I can watch 20 min of the movie with no problem, and then the picture freezes. I can easily fast forward or rewind, close the app, so it's not an app freeze (MX Video, Mobo, VPlayer - doesnt' matter). I've never seen anything like that on the stock rom.
    Some suggestions were maybe it's my SD card, so I upgraded to higher class and then even higher. But the lag is still there.
  17. g60madman

    g60madman Well-Known Member Developer

    Couple of questions
    1. Which Rom are you using?
    2. After you do the wipe data/factory reset and then advanced/Wipe Dalvik Cache, are you installing the fresh rom and then gapps? Or are you restoring from backup?
    3. In CWM recovery have you ever done a Mounts and Storage Menu < format /system? DO NOT DO IT I just want to make sure you have or have not as I have seen issues with that.
    4. If you are not restoring from back up once you reboot the phone are you using any other apps to restore data, profile or apps other than google's wizard restore?
  18. skarni

    skarni Well-Known Member

    You might want to check on what the minimum CPU setting is in cyanogenmod settings/performance. Default is 61. I had some lags in videos and with music player. after i set minimum to 245, it worked fine. I guess the cpu just slows up if it can not if it should.
  19. Izzard

    Izzard Well-Known Member

    @g60madman
    1. CM7 g60 style_r0.0
    2. Fresh rom then gapps
    3. Yes I did. Long time ago, was playing with different roms, something went wrong. I restored to factory afterwards. Didn't think that might be an issue.
    4. Nothing, just the google wizard.
  20. g60madman

    g60madman Well-Known Member Developer

    First check the phone info Settings < About Phone on the Rom and make sure it says g60madman@motdev #1 if it doesn't redownload it.

    Next Because you did the format system a long time ago I would recommend downloading

    http://androidforums.com/triumph-al...eodex-roms-triumph-now-resets-splash-img.html

    After downloading boot into recovery and do a factory wipe, wipe dalvik and then go into Storage Menu < format /system and format it. Once done install the bone stock and boot it up. After it boots up then shut down and the boot back to CWM and do another factory wipe, dalvik and then load 0.0
    Izzard likes this.
  21. thangfish

    thangfish Well-Known Member

    What governor were you using while having those issues? If you remember.
  22. skarni

    skarni Well-Known Member

    I was and am still using the Interactive governor. Moving up the minimum to 245 Mhz didn't have any effect on my battery life. Deep sleeps fine.
  23. MikeRL

    MikeRL Well-Known Member

    I will do my best to test and report any bugs for this ROM. I do not know any programming, but I can at least lift some of the heat off the developers by aiding in bug reporting and pinpointing possible solutions. I'm just beginning learning web design. I'm currently running Ubuntu, so if I read some instructions, I should be able to build and test this ROM. Some bugs might be a little noobish, (I hope not) but I have ran Ubuntu for a few years, since Jaunty, and can at least help bring some structure. On a side note, would it be worth filing a bug report on random rebooting with this phone/rom? (I think it is a bug with the Triumph itself).
    dsmryder likes this.
  24. g60madman

    g60madman Well-Known Member Developer

    I have not had any issues with random reboots. Are you running specific apps at the time of reboot? Make sure before you do submit bugs that you take the time to wipe the phone completely and reload the ROM and test again.
    MikeRL likes this.
  25. Rolo42

    Rolo42 Well-Known Member

    I had random reboots with 04 Mar CM7 but a wipe/reinstall 25 Mar CM7 fixed it. (The phone was new and I installed a bunch of apps in a short time, so it could have been anything.)

    I've had the problem return and reverting to a recent backup/reinstalling app cured it. (I installed Torque free & paired OBDII BT, tested it, installed Torque pro, updated an existing app, phone got wonky/reboots; I reverted to pre-Torque backup then updated app, then paired OBDII & installed Torque pro--all is well.)

    This leaves me wondering about the install process.

Share This Page