[ROM] MTDEV-CM7 build 2013-03-03


Last Updated: 2013-12-18 17:44:28
  1. g60madman

    g60madman Well-Known Member Developer

    Install the stock froyo ROM and see if the issue is still happening. If it is send it in for a replacement.

    Advertisement
    gpetrick likes this.
  2. calitrippin

    calitrippin Well-Known Member

    I had a similar issue a while back, for me it was because I wasn't doing a full wipe when I installed the new rom, it might be a good idea to make sure that you do a full wipe each time you install a new rom. in recovery wipe data/Factory Reset, clear cache then clear Dalvik Cache, then install rom and gapps, that worked for me, other than that you can try going stock to see if it works there
    gpetrick likes this.
  3. gpetrick

    gpetrick New Member

    Well almost like clockwork, I have been muddling around with this camera issue for about 1 month now and I think I figured it out the day I finally post a 'help me out' request! When I was CWM wiping and factory reset, I hadn't noticed an error while doing it. The error was "E:format_volume: make_extf4fs failed on /dev/block/mmcblk1p2". I think a combination of wiping so often and my poor eyesight caused me to miss this. I repartioned my sdcard with CWM and now it seems to work (at least no errors so far).

    I don't know if that helps anyone else out there, but I thoroughly appreciate the responses I got in such a short time. Peace out and looking forward to CM10 (once the camera issues are worked out!).

    I threw MTDEV a little bone as well. Keep up all the excellant work!
    g60madman likes this.
  4. Tokens210

    Tokens210 Well-Known Member


    Im pretty sure that error is fine to get, I've gotten it everytime I've ever wiped with no ill effects, im pretty sure its the version of cwm just looking for a folder that doesn't exist or doesn't yet
    gpetrick likes this.
  5. mattbodin

    mattbodin Well-Known Member

    There are 3-4 errors that always occur, they are listed somewhere here. Are you restoring anything?
    gpetrick likes this.
  6. Tokens210

    Tokens210 Well-Known Member

    I pretty sure the number of errors is based off the version on cwm recovery the person is currently using

    I personally recall an older cwm used to give me a bunch of errors that never did anything, ill, they were just looking for a folder that I guess different models of phones probly had, after I switched to the newest I believe the 5.5.0.4 there only ever seems to be 1, the devblock

    Eitherway I'm pretty certain the devblock error is nomrmal and doesn't do anything bad
    gpetrick likes this.
  7. mattbodin

    mattbodin Well-Known Member

    I can't seem to remember which ROM I loaded last... Is this g60 style final?

    [​IMG]
  8. g60madman

    g60madman Well-Known Member Developer

  9. mattbodin

    mattbodin Well-Known Member

    Sorry, thanks
  10. dsmryder

    dsmryder Well-Known Member Developer


    I looked at what we have on our phone and /dev/block/mmcblk1p2 does not exitst. I wouldn't worry about it. I have seen a few users say that this error shows up and it doesn't seem to be an issue.
    The sdcard is mounted from /mnt/sdcard. I think you found the problem by formatting your card.
    gpetrick likes this.
  11. g60madman

    g60madman Well-Known Member Developer

    No problem :) just check out the Mod version and it will normally say. The catch with g60 final is I released version r09 and then r10 and r11. Final was a modified r09 which I modified the build.prop and also recompiled the frameworks.jar with some patches as I felt r09 was the best version I put out. Mind you mtdev-cm7 is much better than g60 minus the current release which has some WiFi issues.

    Also Chairshot will be pushing up some new commits which should take cm7 to a whole new place. Sadly he has been sick all weekend, so right now just hoping he gets better soon!!! The updates can of course wait.
    Inc0gnit0 likes this.
  12. mattbodin

    mattbodin Well-Known Member

    So you would recommend the 8/10 release?

    I had some issues with the tethering also on it but I'll give it another go, get you some more specifi info.
  13. g60madman

    g60madman Well-Known Member Developer

    Yeah 8/10 should be a little better right now. Once we work out the issues I'll delete some of the older bad builds.
    Inc0gnit0, ecarlson and mattbodin like this.
  14. chrofycl

    chrofycl New Member

    I don't know if this has been said before, but I'm pretty sure the camera click is actually the lens hitting the outer glass... dunno if there are configurable settings in the camera stuff, but seems like it could be a pretty quick fix if there are, to change either the speed or the distance that the lens is allowed to travel...

    Cheers,
    Jason
  15. g60madman

    g60madman Well-Known Member Developer

    Jason,

    The problem with this of course is we have no source code for the camera so we are flying blind as to what parameters we can or can not set. I have been trying to get more info on the camera but right now the company denied my NDA so I need to try another route to look a little more professional ;)
  16. mattbodin

    mattbodin Well-Known Member

    i reinstalled 8/10 after a full wipe. i did restore user apps from backup but nothing from a system backup and last time installled this rom i had the same issue and had not installed or restored anything.

    i setup wifi tethering with no security and tried connecting with my kindle touch. it connected for a second then dropped. the ssid was no longer in the list after scanning a few times. after about a minute it showed back up but when i tried to connect to it after that it wouldnt connect at all. during all this time nothing has changed on the phone, looks like it should be working, turned it on and off on the phone and it wouldnt connect. i rebooted the phone and tried again with the same result.

    rebooted the phone again and tried connecting to it with my roku, it connected and stayed connected. it wasnt a usable connection for the roku but it stayed connected. i connected to it with the kindle and it also worked fine. disconnected them both and tried connecting with the kindle the first situation recurred. i tried after that to connect the roku first and again they both worked fine.

    i know youre probably going to say its the kindle but i have the same issue on another computer over wireless, does the exact same thing as the kindle. i left it out of the equation this time though. also i had been using tg-reloaded for 4-5 months and it worked fine with the kindle. i dont remember connecting anything else to wifi tethering over that time though.

    the gps doesnt lock after 10min, i gave up. honestly i dont remember the gps ever locking so that may be the hardware.

    edit: a view of my 3g and Wi-Fi on 8/10....

    [​IMG] [​IMG]

    it is late out so take the 3g for what it's worth (the stuff after 12am, is at my house, 30 miles from the previous location).
  17. dunni88

    dunni88 Active Member

    Hey Check it out, RadioShack has the Triumph for $150. I gave you guys a shout out in the comments.
  18. magohn

    magohn Well-Known Member

    Thanks Devs!!!

    I moved from MIUI and installed the 8/19 rom. GPS was instant for AGPS but actual GPS took forever - 5 mins and counting (I quit waiting). Im goning to try the 8/10 build and see what that does as I switched from MIUI specifically for the GPS issue.

    Thanks again.
    g60madman likes this.
  19. magohn

    magohn Well-Known Member

    Are people confusing this "gps fix" as being an actual GPS fix? In other words, true GPS still is unbearable for me. To the uninformed, the gps appears to find a very fast fix but its using your wifi or 3g connection - not the GPS radio.

    Unfortunately 8/10 is the same. Instant AGPS (wifi etc) but "real" GPS just sits searching for satellites.

    "Real" GPS works for me in MIUI, SHARP and stocks roms but takes 5 mins or so. For this 8/10 (and 8/19) release after 5 mins I stopped waiting for a "real" GPS fix.

    My wifes VM Optimus gets a "real" GPS fix in 5 seconds from the same location.

    Thanks though - worth a try.
  20. Tokens210

    Tokens210 Well-Known Member


    I'm not 100% sure but I believe the "fix" was that the devs pulled the GPS stuff from the sharp rom but like everything else I think gingerbread goes about GPS differently, I believe its also suggested to have all the assists in location turned on

    Either way it should be better then it was, stock outta the box froyo for me GPS never did anything unless I connected to a wireless network and used that location, if I only had the GPS selected it could take hours

    Haven't really tried GPS since coming to the mtdev but from what others have said its slightly better then before
  21. magohn

    magohn Well-Known Member

    I will play around with it some more and try it in other locations.

    Other than the GPS I really like this rom. Im using a MIUI launcher and so I get all the functionality of MIUI but with all the fixes for C7 :)

    Thanks devs!
    g60madman likes this.
  22. g60madman

    g60madman Well-Known Member Developer


    magohn,

    If you like miui swing over to AjaXplorer once there browser to

    /g60stlye/removed_apps/themes

    In there you will find a miui theme I used back on g60 rom. It's the best miui theme I found at the time. There maybe others but that one is pretty good.
  23. ecarlson

    ecarlson Well-Known Member

    You are confusing AGPS with Network Location: They are 2 separate things. AGPS helps the real GPS sync faster, and does download data from the network. Network location uses the network itself (towers and access points) to determine your location.

    If you were outside when having those GPS issues with the Sharp ROM, then your phone's GPS is bad. When I was running the SHARP ROM, with Network Location turned off, so that it could only use real GPS (with AGPS speed up), the real GPS would lock in under 30 seconds, and sometimes in like 5 seconds.

    Unfortunately this ROM doesn't yet have the same real GPS performance as the Sharp ROM, but I'm hopeful that it will someday.
    dsmryder likes this.
  24. sqwerl

    sqwerl Well-Known Member

    Thanks for the hard work guys. I'm still having issues.

    Turns out the power widget/brightness control is still sticking after a full wipe and reinstall but not restoring system settings with Titanium. I also seem to be prompted too frequently by Browser/Dolphin/Tapatalk default after I've already checked my choice.
  25. dsmryder

    dsmryder Well-Known Member Developer

    If I remember correctly, even Whyzor had issues with the "slide your finger accross to control the brightness" feature. I presume that's what you mean? Maybe there is a part in the code that can be tweaked to make it better. When we get the bug tracker up, please post that one so I can remember it.

    And I wish there was a way to show how many times I have to hit the backspace because I'm sleepy and can't type, but want to get something finnished:D

Share This Page