1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[ROM] MTDEV-CM7 build 2013-03-03


  1. jamesd1085

    jamesd1085 Well-Known Member

    Believe me I don't in any way think we have very good chances of an official update...but if this makes them any better I'm all for it
  2. antpila33

    antpila33 New Member

    updated yesterday, wiped all 3 (cache, data, and delvik) wouldnt get past motorola logo, reflashed rom again without any wipes and all seems good. (flashed gapps after each as well).
  3. rcarter10

    rcarter10 Well-Known Member

    Full wipe, clear caches, flash Rom, flash gapps, rebooted fine.
  4. snoobzilla

    snoobzilla Member

    Is anyone on this ROM having issues with wifi hotspot? I am getting an error.
  5. calitrippin

    calitrippin Well-Known Member

    personally i'm of the school of thought that you should just through everything at the wall and see what sticks, that's basically how I got it to work for me, I'm running CWM 6.0.1.2 I personally didn't have any success with the fixing permissions only approach so what I ended up doing was:

    1. Factory reset
    2. Clear cache
    3. Clear Dalvik Cache
    4. Install rom/gapps
    5. Clear Cache
    6. Clear Dalvik Cache
    7. Fix permissions
    8. Reboot
    after that point it booted up normally and I haven't had any problems since, if you still have any issue just boot into recovery and fix permissions again
    mexicaninja likes this.
  6. rcarter10

    rcarter10 Well-Known Member


    I had that a few days ago, a reboot fixed it. It's working on the current version for me too
  7. Chairshot215

    Chairshot215 Well-Known Member Developer

    This is pretty much ware I am at. Will test things over adb before adding to the source when I can and end up needing to re-flash on the regular. Have now probably flashed the Rom about 20 times in the last day and a half with CWM v5 and have not yet been stuck on the M logo. Flashed on lunch yesterday with v6 and was stuck on the M logo. Decided just a bit ago to try v6 again and got stuck on the M logo again. Flashed a second time but this time did the old wipe data 3 times and then everything else twice before flashing and it had booted. After went back to cwm v5 and it booted doing my regular wipe data, format/system and wipe caches. Then tried flashing CM9 and then back to 7 to see if I would need to fix permissions but like before booted without issue. With that said I did not even sign into gapps on CM9 so now thinking should maybe go back and do that plus use a few other things before flashing back to 7. That and do a second boot for the wifi fix to take effect, dow!
  8. g01851

    g01851 Well-Known Member

    These steps worked for me.

    Using CWM Recovery v6.0.1.2
  9. dsmryder

    dsmryder Well-Known Member Contributor


    That might be it!

    Everyone, list your CWR version. Mine is 5.0.2.6 ish. I added in clearing cache and installing to /data. We aren't using it yet, but I was going to use it on ICS to squeeze out more space for the ROM. I think that for those who are not running the same CWR should open up the ROM and navigate their way to the updater_script (I think that's what it's called) and delete the lines for formatting /cache and the first lines for /data.
  10. mexicaninja

    mexicaninja Member

    These steps worked for me too.
  11. Gaffadin

    Gaffadin Well-Known Member

    Using recovery 5.5.0.4.

    Factory reset -> format /cache -> wipe Dalvik cache -> install ROM -> Fix Permissions -> Reboot -> Permanent boot logo

    Pulled battery -> booted to recovery -> format /cache -> wipe Dalvik cache -> Fix Permissions -> Successful reboot
  12. dsmryder

    dsmryder Well-Known Member Contributor

    Guys, I have eddited the updater script. Test this out for us please. I can't figure out a reason why it would work for some and not others.

    MTDEV-CM7-20120921.zip
  13. AlteredBeast

    AlteredBeast Member

    Just want to say thanks for this version of CM7. I have tried a lot and they have always had so many nagging issues with freezes, restarts, crappy Wi-Fi speeds, crappy GPS, etc. This one is excellent. Thanks for the hard work guys.

    I am finally at a happy point with owning the Triumph. :)
  14. ZipLipZ

    ZipLipZ Well-Known Member

    That one worked for me. Wiped cache and flashed over the previous version with no issue. Thanks!!
  15. dsmryder

    dsmryder Well-Known Member Contributor

    My testing of the kernel is done. I am so glad I have help on this. I really think that this will produce a minor improvement, but it's the first step on my list.

    I'll post my results later. Also, does anyone know how to resize a picture in BBcode? I'm pretty sure it's the pseudo HTML that's used here in AF. I have tried some stuff I found, but it didn't work.

    https://dl.dropbox.com/u/36543382/Screenshot.png
    This is my table so far. If you want to PM me with your data, I think that would be best. Posting screen shots is cluttering up the thread and slowing the load times for everyonw who is on that page.
  16. youaregreat

    youaregreat Well-Known Member

    anyone else having trouble with texts? i can send fine, but can't receive at all. started after latest rom failed to load and reinstalling the previous, so not sure if its my phone or virgin
  17. calitrippin

    calitrippin Well-Known Member

    I was sending and receiving texts just fine yesterday, and I'm running the newest version of the rom, might be a problem that is local to your area, but it isn't the rom
  18. g60madman

    g60madman Well-Known Member Developer

    09/23/2012
    ∙ Flicker who? Flicker is GONE!!!
    ∙ Better video
    ∙ More stability

    Once again Chairshot steps up to the plate and smacks one out of the park. Video flicker is completely gone from the build!!! Also he has added better video drivers, and more stability. This by far is the best CM7 yet! When he post make sure to thank him :D
    Coping, piper_, b_randon14 and 10 others like this.
  19. MikeRL

    MikeRL Well-Known Member

    Next stop for my Triumph: the moon! LOL. It just keeps getting better and better around here! No need for Motorola or Virgin. They can go code on MS DOS and ship themselves off to /dev/null. LOL.
  20. inub

    inub Well-Known Member

    good news!
  21. MikeRL

    MikeRL Well-Known Member

    Hold fast - flicker is gone for most videos, and most videos play smoothly, but a major issue remains. I do not know what is causing it, but on some videos garbled lines are the only output I get. See this video as an example using the Youtube App. Should I post up a logcat?
  22. g60madman

    g60madman Well-Known Member Developer

    Hang tight Chairshot is already working on a new version, as he spotted some problems.
    Inc0gnit0 and freakboykevin like this.
  23. mexicaninja

    mexicaninja Member

    the infinite Motorola logo seems to have been fixed. thank you so much for all your hard work!!
  24. sikk66

    sikk66 Well-Known Member

    Geez with all the releases I have become a ninja at flashing and installing everything fresh from the market. What used to take hours I can now do in under half an hour. :)

    Thanks Chairshot, G60, and the rest of the MTDEV crew for all your hard work!
  25. g60madman

    g60madman Well-Known Member Developer

    Best app I use is Titanium Backup it's free and backs up your apps. So wipe, reload setup market install Titanium Backup and restore.
Loading...

Share This Page