[ROM] MTDEV-MIUIv4 build 20130102 [BETA]


Last Updated: 2014-12-21 23:17:30
  1. jamesd1085

    jamesd1085 Well-Known Member

    You said it flashed quickly...could be an incomplete download...try another download and flash again...I don't know...if problem persists try on the older miui v4 rom post on the main page...its the same rom as MTDEV hasn't yet starting to rebuild it yet

    Advertisement
  2. chucksaysblah

    chucksaysblah Well-Known Member


    I downloaded this rom 5 seperate times and had the same issue. I just did it one last time to try it and it worked just fine thanks for the help. I was starting to feel like a dumbass.
  3. GKNByNW

    GKNByNW Well-Known Member

    I am having the same issue with mine. Wiped, installed ROM & gapps, reboot, then got stuck on the Motorola logo for almost 40 minutes before I pulled the battery. This time I installed just the ROM (can always go back and flash gapps later) and it's been sitting for close to 20 minutes. I'm quite happy with my current ROM, so I was only installing this one to check it out for a little while. I'm sorry, but I'm not gonna sit here forever waiting on my phone to boot just to play around with this ROM.

    Anyway...

    One thing that crossed my mind is this. My phone is pretty much brand new, as I bought it less than 2 months ago. Could the newer Triumphs have a different baseband or some other firmware/internal "component" that is incompatible with this ROM? I only ask this because I seem to recall that the baseband on some of the Optimus V's was incompatible with some ROMs while working fine with others.
  4. jamesd1085

    jamesd1085 Well-Known Member

    I do know they changed out some things from the very first triumph release...but the only new work being done on this phone is from private Devs on forums like this...which recovery are you using and what rom are you coming from...also are you using the ics gapps or the miui ics gapps listed on the page?
  5. GKNByNW

    GKNByNW Well-Known Member

    I run CWM v5.0.2.6 and I did grab the MIUI_gapps.zip listed above in the OP. I tried installing twice, the first time flashing gapps immediately after the main ROM and the second time without flashing gapps. My "daily" ROM was MTDEV CM9 but I switched to MTDEV CM7 a few days ago. Correct me if I'm wrong but I wouldn't think my previous ROM could have any bearing on the new one, provided I do the proper wipes in Recovery first.

    I listed the way I do my wipes in another post, but I'll reiterate here:

    1.) Wipe data/factory reset
    2.) Wipe cache partition
    3.) Wipe dalvik cache
    4.) Format System, Data, and Cache
    5.) Flash the given .zip file(s)

    I realize that doing things this way is a little repetitive, but it's a habit I got into from owning my Optimus V for almost a year. I've never had any problems doing it like this on the MT, so I see no reason to change. If it ain't broke then don't fix it, right? :p
  6. jamesd1085

    jamesd1085 Well-Known Member

    OK...I believe 5.0.2.6 had problems with leaving data behind...I would recommend updating to one of b_randons 6.0.1.5. Variants...I just flashed miui v4 using it and it booted in less than 2 minutes... also no problem switching back to CM9...good luck

    Also when flashing rooms do factory reset, wipe cache and dalvik cache only...formatting system and other partitions can break symlinks needed for root access and can cause roms not to boot
  7. chucksaysblah

    chucksaysblah Well-Known Member


    Yeah i got it to work still buggy thoiuhg had issues with the themes crashing every time i loaded it so no go for me.
  8. jamesd1085

    jamesd1085 Well-Known Member

    Yeah...its not much now...but once MTDEV gets it going it will be better
  9. GKNByNW

    GKNByNW Well-Known Member

    Installing b_randon's recovery did the trick for me. Instead of getting stuck on the Motorola "M" logo, it went straight to the MIUI boot screen and then booted up. I must say, WHAT a difference in this ROM compared to anything else I've ever used. It's like having a whole new phone. As stated in the OP, there is no working camera and that's really the deal-breaker for me right now, so I did revert back to my previous ROM after spending some time with this one. But this really is a very smooth-looking and attractive operating environment.

    Once/if G60 and the other devs get the camera sorted out for MTDEV CM9, I hope they will find a way to get it up and running on this ROM. Keep up the hard work guys!
  10. oki doki

    oki doki Member

    Thanks g60 and mtdev for all of your work. Don't ever think no one appreciates it, because everyone does!
    dsmryder and Sunny74 like this.
  11. Ken2Chill

    Ken2Chill Well-Known Member

    Is it possible to get the browser from tour MiuiV4 rom on Cm9? I like the bottom tab switcher.
  12. g60madman

    g60madman Well-Known Member Developer

    1/2/2013
    ∙ Camera displays
    ∙ Video displays
    ∙ Panorama does not work

    With all the excitement of CM9 everyone forgot MIUI. I have added in all the parts from CM9 the only thing that is not working in Panorama, however video does display.
  13. ShadyBusiness

    ShadyBusiness Well-Known Member

    Nice to see some love for MIUI
    arcticfix and g60madman like this.
  14. GKNByNW

    GKNByNW Well-Known Member

    So awesome to browse the threads and see "build 20130102" :))) I'm still on CM7 for now but looking forward to switching back to CM9 or maybe even this beauty of a ROM.

    Thanks so much to g60, BSydz, MikeRL, and anyone else who has racked their brains and wrapped their heads around the camera issues. Keep up the great work!
    MikeRL and g60madman like this.
  15. Poweredge99

    Poweredge99 Well-Known Member

    Can't wait to get my triumph back. Thanks so much.
  16. jhonka232

    jhonka232 Well-Known Member

    Just flashed it, it's beautiful. The battery usage stats work, but they don't in CM9. Maybe you could use some config files from this ROM in CM9...

    EDIT: I think I can fix the battery usage display in CM9, check your PM g60
  17. MikeRL

    MikeRL Well-Known Member

    Maybe one day we could consider updating it to the latest MIUI v4. I dunno if that might break some things, though.
  18. zironia

    zironia Member

    tried flashing over and over. Even reloaded brandons cwm recovery. Every time i reboot after flash it just gets stuck at red motorola logo. Any suggestions. did full wipe, system, cache, dalvik but no luck.
  19. jhonka232

    jhonka232 Well-Known Member

    I had that issue, after the full wipe flash CM9, and then flash MIUI, and then GAPPS. I don't know why you have to flash CM9 first, but it worked for me.
  20. MikeRL

    MikeRL Well-Known Member

    Same problem here with flashing it. Maybe g60 should investigate?
  21. dsmryder

    dsmryder Well-Known Member Developer

    The battery usage stats are a result of the power_profile.xml having never been done. I started to look into it a little while ago and made a quick CM7 ROM to test with. I haven't gotten down how well I want to make the file. I could use a DVM, but I think there's a command I could run from the terminal to see what the current usage is. If so I'll post a "Help me to help you" thread to get some more stats.

    Gapps modifies the ROM to work in a certain way. If you flashed the ROM afterwards the /system (where most of the included apps reside and where the gapps go) gets formatted.
  22. dsmryder

    dsmryder Well-Known Member Developer

    I'm going to investigate to see if it's something simple.
  23. Total1nsan1ty

    Total1nsan1ty Active Member

    Any way to get rid of the double signal bars?
  24. dsmryder

    dsmryder Well-Known Member Developer

    That would be for one of the hackers. All I know is it would be in the status bar UI area.

    Of course it worked for me. All I did was factory reset, the flashed the ROM then the GAPPS for it. There's one specificly for the MIUI ROM, those who are having problem, are you using the one for CM9?
  25. jhonka232

    jhonka232 Well-Known Member


    Yeah I was thinking exactly the same thing, the MIUI ROM has working battery stats and the cell standby isnt out of the roof like it is with the CM7 roms. I extracted the power_profile.xml from the MIUI framework and PMed it to G60 to put into CM9. If you want it you can find it here: https://dl.dropbox.com/u/1098942/power_profile.xml
    just drop it into your overlay

Share This Page