[ROM] PlainJaneT2 Stock 2.1 with OC and A2SD


  1. T2noob

    T2noob Well-Known Member

    *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
    This rom is a version of Jcase's PlainJane that can be found Here.
    I Just added to this rom the latest a2sd that can be found HERE
    This rom uses Zanfurs OC path which can be found Here
    Scripts from Bugless Beast Here
    *-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*--*-*-*
    Downloads at the end of this post.
    Reviewed By andrew8806 at http://droid-roms.net
    This is the 2.1 Eris OTA(JULY) With Root, A2SD, and Overclocking.
    This is for people that like the SENSE UI, and have lots of apps.
    I was using PLAINJANE and filled up the internal Memory, so I went about looking for a way to keep the rom and have all my apps.
    Presenting PlainJaneT2 V2.0 Screenies attached New Fonts!

    Change Log:
    Code (Text):
    1.  [B][U]PlainJaneT2 v1.0[/B][/U]-Added A2sd to Original PlainJane from Jcase.
    2. [U][B]PlainJaneT2 v1.1-1.4[/B][/U]-Various Deodexed Versions of
    3. the Rom that never were made public.
    4. [U][B]PlaingJaneT2 v2.0[/B][/U]
    5. -Based on JULY OTA
    6. - Fully Deodexed without any FC (This was a Killer to figure out...)
    7. - Added the Newest A2sd Preview 4
    8. -Added Scripts to rom to enable ext mounting on linux
    9. systems, get cpu Info, make system folder rw, and the ability to
    10. zipalign all apks.
    11. -Added Modified boot screen.
    12. -Changed Default Fonts.
    13. -Made it all stock (some People were asking to leave the apps untouched.
    14. ^^(I made a flash zip you can you use to get rid of the all BloatWaredelete)
    15.  
    16.  
    Remember to BACKUP your sdcard before doing the step below!!!.
    Things you need to know and do.
    How to set up your sd card for a2sd:

    Code (Text):
    1. 1. Boot into recovery
    2. 2. Scroll down to PARTITION SDCARD
    3. 3.Click On PARTITION SD
    4. 4.Click trackball to confirm
    5. 5.Select Swap size 32mb is fine
    6. 6.Select ext size (I did 768mb you don't have to make it that big)
    7. 7.Click again to partition sd card.
    8. 8.Go to PARTITION SD menu and choose SD:ext2 to ext3
    9.  
    This New A2sd Makes it so when you go to the data/app folder, it actually takes you to the /system/sd/app folder. So when you use Root Explorer to look at the data/app folder you are actually looking at the /system/sd/app folder.
    You know you are in the /system/sd/app folder in root Explorer because at the very top it says something like this "92.88MB used 593.51MB free" as we all know the Eris doesn't have that much space in the data/app folder. The space in the data/app folder might still be going down because the cache isn't moved to the sd card by default, if you want to change this you can change it yourself.

    For a2sd help:
    Code (Text):
    1. adb shell
    2. su
    3. a2sd help
    Use of scripts:
    Code (Text):
    1. Go into terminal emulator or adb and run these scripts
    2. -"sys -rw" Will Make system Read and Write
    3. -"sys -ro "Will Make system Read Only"
    4. -"usb -e" Will mount Sdcards Partitions" On linux
    5. systems will mount the EXT partition. Sorry windows people.
    6. "usb -d" Will unmount the sdcard Partitions..
    7. -"cpuinfo" Will give you the OverClock settings,
    8.  giving you the max, min, and what you have it set to.
    9. -"zipalign_apks" Does just that zipalign all apks.
    To change the over clocking settings Download Setcpu from this thread Here
    Remember to Wipe Factory/cache Before flashing this rom.
    Downloads:

    PlainJaneT2 V2.0
    PlainJaneT2 V2.0
    - Flash this to get Default Fonts to original
    DefaultFont.zip
    -Flash this to get rid OF BloatWare
    BloatWareDelete.zip
    -Flash this to Disable the OTA that some people are getting
    DisableUpdate.zip
    Alternate Links
    T2noob Roms


    BloatWareDelete.zip Deletes
    -AmazonMp3
    -Stocks (widgets and app)
    -Twitter (Widgets and app)
    -HtcFootPrints (Widgets and app)
    -Teeter
    -Visual Voice Mail
    -PDF VIEWER(the adobe one is better than this one, get it on the market)

    I hope this helps someone, I Had a hard time getting a2sd to work because there isn't that much documentation on how to enable the boot.img for a2sd, now people don't have to go through what i did to get a2sd on 2.1 stock rom.And Jcase Gave me his ok.(In case you were wondering)

    Advertisement
  2. rvpartsguy

    rvpartsguy Well-Known Member


    Nice rom ..... running it now .... been a while since I have run a stock sense rom....forgot how smooth they are .....a2sd worked perfectly for me ..
  3. jcase

    jcase Well-Known Member

    A+ lmk if you need anything.
  4. T2noob

    T2noob Well-Known Member

    Yea i've always liked stock best, I thought that someone might also like it.
    I might tweak it a bit in the future but for now it's good.
    Jcase will do...you just opened a can of worms lol..
    fritzel67 likes this.
  5. fritzel67

    fritzel67 Well-Known Member

    Thanks t2noob, can't wait to try it. Has anyone installed LWP on this ROM?
  6. andrizoid

    andrizoid Well-Known Member

    cant. its stock/sense based. LWP doesnt really work with sense based roms
  7. wildtouch83

    wildtouch83 Well-Known Member

    is the A2SD option enabled in the menus? My SD card is already partitioned, so, I was hoping that I could just flash this ROM, enable A2SD and it will see my apps. :)
  8. T2noob

    T2noob Well-Known Member

    Edit: This isn't like AOSP roms that you have the option to enable it through the settings menu.
    in order to remove it you have to go through a terminal or adb and run this
    Code (Text):
    1. a2sd remove
    ^^ will disable a2sd
    Code (Text):
    1. a2sd install
    ^^ Will enable a2sd

    I don't know if it will work we had problems with another person making the Plainjane have a reboot loop when he left his apps on the ext partition. a2sd is enabled by default, so if it doesn't give you a boot loop you should be able to see them. But im not a hundred percent sure that it wont boot loop.
    Edit: I think this boot loop has to do with people using the old a2sd and then people trying to use the new one on this rom.
    to check if a2sd is enable try this
    Code (Text):
    1. adb shell
    2. su
    3. a2sd check
    And it should output where the apps are being run from and other stuff you might want to take a look at.
  9. jdog94

    jdog94 Well-Known Member

    so do you wipe then do the a2sd stuff the flash the rom???

    or what are the exact steps?
  10. joshminton

    joshminton Well-Known Member

    im confused. i flashed the rom and everything is fine, but exactly what do i have to do to enable apps2SD?
  11. T2noob

    T2noob Well-Known Member

    All you need to do is partition your sdcard, thats it.
    A2sd is enabled by default. If it finds an ext partion on your sdcard thats where it will install your apps
    if you want to make sure that its enabled you can do
    Code (Text):
    1. adb shell
    2. su
    3. a2sd check
    and it will output where the apps are being installed where the cache is and other things you may want to know.
  12. joshminton

    joshminton Well-Known Member

    ok cool thanks. should i partition the sd before or after i flash the rom? or does it even matter?
  13. T2noob

    T2noob Well-Known Member

    I would say do it before your first boot that way once you install apps they will be installed onto the sdcard and you won't have to be moving apps from internal to sdcard.
  14. joshminton

    joshminton Well-Known Member

    awesome. thank you so much. all this stuff is starting to make sense now.
  15. joshminton

    joshminton Well-Known Member

    ughh...problem. i flash the rom then i go to partition the sd card and i get to the last step (ext2 to ext3) and it says

    Error : Run 'fs ext3' via adb !
  16. T2noob

    T2noob Well-Known Member

    Weird.. did you try to run
    fs ext3 through adb?

    If you did, did it throw out another error?
  17. joshminton

    joshminton Well-Known Member

    i havent tried running it through adb cos i dont know how. what would i have to do?
  18. joshminton

    joshminton Well-Known Member

    well now i booted up the phone then shut it off and then did the sd card thing and everything worked fine. im gonna check to see if it's enabled now.
  19. T2noob

    T2noob Well-Known Member

    Ok to try this you're going to need adb If you don't have it download it from Here Click on the one that corresponds with your Operating System.
    And follow these directions to set it up right on windows
    Code (Text):
    1.  Extract the Android SDK zip file unto c:\AndroidSDK\
    2.  
    3. 4. Double click on SDK Setup.exe
    4.  
    5. 5. Many times, you will need to click on Settings and check the box to force HTTP instead of HTTPS.
    6.  
    7. 6. Choose to download the USB drivers package. Nothing else is required.
    8.  
    9. 7. Enable your phone's USB debugging mode: Settings > Applications > Development > check USB Debugging
    10.  
    11. 8. Connect your phone via USB to your PC.
    12.  
    13. 9. Right-click My Computer > Properties, click on Hardware, and go to Device Manager. You should see a device with a yellow exclamation next to it, this is your phone (if you don't see it you probably forgot to enable USB debugging mode)
    14.  
    15. 10. Right-click the device, select Update Driver. Browse to your Android SDK directory, and you should see a "USB Driver" folder in it now. If you don't, you forgot to download the USB Driver package when in "SDK Setup.exe". Select the driver in that folder.
    16.  
    17. 11. To make life easier, lets add a global path to the android SDK tools. Right-click My Computer > Properties, click on Advanced, then click on Environment Variables. Doubleclick on PATH, then at the end of the Variable value, add a semi colon ";" and then c:\AndroidSDK\tools
    18.  
    Once that's set up boot Your phone into recovery
    Then plug your phone to your computer.
    Then open a terminal or a command prompt in windows and type the following
    Code (Text):
    1. adb shell
    2. su
    3. fs ext3
    4.  
    and see what happens.

    EDIT:
    LOL ok let me know how it goes.
  20. joshminton

    joshminton Well-Known Member

    hahhaa damn, i think im just gonna start over completely.


    when i go to type that stuff in the command prompt do i need to be in a certain directory or do i just open command prompt and start typing?
  21. T2noob

    T2noob Well-Known Member

    If you follow the directions i posted above you can just open up a command prompt and start typing.
  22. joshminton

    joshminton Well-Known Member

    cool. thanks for all your help. im sure ill get it all figured out soon.
  23. joshminton

    joshminton Well-Known Member

    ok i think i got it to work. i had to do some weird stuff. in the end i had to type in a2sd install into the terminal app and it said moving apps to sd card now i cant see any of them. any idea how to access them? i cant see the market or anything just a handful of random apps like deskclock and facebook etc.
  24. joshminton

    joshminton Well-Known Member

    ok nvm, i rebooted my phone and all the stuff that disappeared is back. i did the a2sd check in the terminal and its sayin alot of stuff. i'll try and type it out

    Apps - [-] Linked to SD Card
    [-] Apps2SD no start not found.
    [*] Programs run from SD card

    etc, and so on.

    does this mean it worked???
  25. T2noob

    T2noob Well-Known Member

    Yep its running from your sdcard.
    I find it weird that you had to do
    Code (Text):
    1. a2sd install
    Because I just wiped, repartitioned my sdcard, and reflashed everything. A2sd worked without me doing anything. i didn't have to do the a2sd install command for it to work. :confused:
    If you have problems let me know but I think you're good to go now. :)
Loading...

Share This Page