[ROM] Proper port of CM7 for the Optimus C


  1. PlayfulGod

    PlayfulGod Well-Known Member Developer

    I have to package the mms fix. been trying to get it work by default.
  2. 0DD

    0DD Well-Known Member

    Toms cm7 port
  3. 0DD

    0DD Well-Known Member

    Which recovery you using? I'm using Tom's and it gave me the same error. Do we need the cwm recovery?
  4. mattsledge

    mattsledge Active Member

    I flashed the recovery PG linked to in the other thread.

    I did use Tom's a while back, but not this time.
  5. PlayfulGod

    PlayfulGod Well-Known Member Developer

    I would highly recommend it. The recovery Tom stole the dev wasnt happy about him putting out for ppl to use, from what I was told anyhow.

    The CWM I ported has be verified as working great by all who has used it. And I have it submitted to koush to be merged into rom manager too. ;)


    And I'll have to repackage the mms fix for it to work. I have been told several times it isnt flashing.
  6. PlayfulGod

    PlayfulGod Well-Known Member Developer

    OP updated with new build.
  7. 0DD

    0DD Well-Known Member

    I like your recovery better. The only thing is I like to control what exactly gets backed up with nandroid. Any chance of that being added?
  8. PlayfulGod

    PlayfulGod Well-Known Member Developer

    That one would be on koush I just ported CWM to the OC lol. You do know that with a nandroid it does it by partitions and you can just restore the data.img etc.
  9. sillyputtyddd

    sillyputtyddd Member

    One note when using the Cricket MMS fix flash. Cricket has a limit on the MMS size and the picture resolution. I use "Reduce Photo" from the market to resize the picture to no larger than 640 x 480. Also, you must create a custom user agent in the mms settings and for the OC, it must be LG-LW690. I have been sending and receiving mms with CM7 by following these.
  10. PlayfulGod

    PlayfulGod Well-Known Member Developer

    can you find out what the actual file size limit is plz ;)
  11. jgotsch

    jgotsch Member

    Update:

    - Used Flash Image GUI to install CWM.
    - Used CWM to install the latest build of CM7 (08212011-build 2).
    - Used CWM to install gapps.

    Everything went fine with a couple of notes:

    - When I try to "power off" the handset it reboots instead. ?

    - Had issue waking up from screen off. Turning off the screen on/off animations fixed it, as noted in the wiki.

    - The gapps install after reboot is a little buggy -- but was able to work around it. After installing gapps and rebooting, I am prompted to "slide open the keyboard" in order to enter my account info. For the life of me, I couldn't figure out how to open a virtual keyboard. I skipped this and went on with the download of the google apps. The first app to start downloading was Gmail, which bombed at 47%. None of the other apps I selected downloaded. However, I was now able to go to the market and download/install from there. I entered my google account info using google contacts app menu.

    - No idea if bluetooth is working as I don't have any devices to try.

    - MMS works.

    - GPS does not work. I have tried turning if on/off and turning airplane mode on/off. I have never seen the GPS icon at the top of my screen. When I try to use google maps navigation, it says "searching for GPS..." at the bottom of the screen and I sit indefinitely at a busy prompt that says "Waiting for location".

    Besides the GPS issue, I'm really enjoying CM7 on the Optimus C. So thanks to PlayfulGod, BobZhome, sillyputtyddd and everyone who contributed and tested the port up to this point! And thanks to papasmurf520 for the nice installation walkthrough. Made me way less jittery. ;)
  12. jgotsch

    jgotsch Member

    Hmmm...

    Anybody ran into this error message yet when trying to download an app from the market:

    "Error downloading [application name]. There is insufficient space on the device."

    However, when I check my storage space, I see this:

    SD Card
    Total Space 1.84GB
    Available Space 1.68GB

    Internal Storage
    Total Space 201MB
    Available Space 121MB

    Is this a partitioning issue perhaps? What else might cause this?
  13. LG-optimus-C

    LG-optimus-C Active Member

    I have the same problem even when I reverted back to my backup...but the only app it wont let me download is a update for Google maps?
  14. mattsledge

    mattsledge Active Member

    Yes, I have had this problem. It's never happened on the stock/rooted ROM for me, only on the recent Cyanogens. I did a little research, and it seems to be an Android cache issue. Clear out your caches and it should install.
  15. PlayfulGod

    PlayfulGod Well-Known Member Developer

    yupclear cache ;)
  16. jgotsch

    jgotsch Member

    Thanks! Clearing the cache seems to work.

    On another note, I seem to recall testers on other web site forums claiming that GPS worked when they installed CM7 on their Optimus C. Have any of these claims been confirmed?

    I'm just curious because I'd love to get the GPS working. I can live without it for a couple weeks -- but I'll be out of town eventually and typically use GPS.

    Have any potential patches been identified? I'd be willing to help test.

    Thanks!
  17. PlayfulGod

    PlayfulGod Well-Known Member Developer

    GPS seems to turn on but doesnt display an icon in the statusbar. I havent installed gapps yet to have gmaps to test it out yet. I will do some testing when I get done working on a few other things.
  18. jgotsch

    jgotsch Member

    I too noticed that GPS turns on but doesn't show any icon on statusbar. I didn't have much luck w/ gapps install -- but I did get gmaps installed via the market app. When I use navigation it says "searching for GPS..." at the bottom of the screen and a busy prompt that says "Waiting for location". Doesn't seem to find any satellites.

    BTW -- Is there an alternate way to get the market app installed w/out the gapps zip? I was wondering if the "out of space" and "invalid package" error messages might be attributed to the market app that is included in the gapps package? It seems to be partially resolved by clearing the market cache (I usually clear all the caches). But I've received a "invalid package" error even with a clean market cache. Weird.

    I'll check back here from time to time. I don't mind helping you test GPS if you need a tester.

    Thanks!
  19. PlayfulGod

    PlayfulGod Well-Known Member Developer

    I think its an issue with the market app
  20. PlayfulGod

    PlayfulGod Well-Known Member Developer

    OP Updated, new build uploaded.
  21. LG-optimus-C

    LG-optimus-C Active Member


    Do you have a link man?
  22. mattsledge

    mattsledge Active Member

    Go to the first post in this thread.
  23. DUDENPHX

    DUDENPHX New Member

    Hi after this last build my camera and voice to text do not work. Any suggestions?
  24. PlayfulGod

    PlayfulGod Well-Known Member Developer

    not sure what broke the camera, still digging for that. The voice to text try installing tackback, voice search, n g voice. Think thats how I fixed that b4.
  25. Lilg37

    Lilg37 Well-Known Member

    Ok major problem withgmail once installed will not sync
    Contact mail or anything Google related, there's a server issue with the rom

Share This Page