[ROM] Quattrimus JB (CM10.1, AOKP42)


  1. tdm

    tdm Well-Known Member

    Announcing Quattrimus: JB for the LG "iproj" family (Nitro, Spectrum, etc.)

    What does not work?
    * Pressing power button while in camera app instantly reboots the phone.
    * [i_vzw] Accepting a WiFi-P2P request instantly reboots the phone.
    * [aokp42, i_vzw] screen does not blank. This is a show stopper for aokp42 on i_vzw.

    All of these are being investigated.

    Kernel
    Overclocks to 1674 MHz.
    [coming soon] Compiled with Linaro.
    Source: github.com

    Credits
    death2all110 and PlayfulGod for providing vendor binaries and a bit of help here and there.
    Neph81 and death2all110 for finding the patches to fix mobile data.
    Code Aurora Forum
    The CyanogenMod team
    The AOKP team
    Many, many others

    Download for CM10.1
    getquattrimus.com [Hosting by Chris Talkington, TalkingtonTech]
    androidrepo.net [Hosting by Jeremy Countryman, HardCore FX Web Design]
    vmroms.com [Hosting by LeslieAnn]
    Current Version: beta4
    md5=81b7150d72c6669249e769480583786c

    Download for AOKP42
    getquattrimus.com [Hosting by Chris Talkington, TalkingtonTech]
    androidrepo.net [Hosting by Jeremy Countryman, HardCore FX Web Design]
    vmroms.com [Hosting by LeslieAnn]
    Current Version: beta4
    md5=beca08d906d9b312c47f3c94a765be21

    This is a "multi ROM". It will automatically detect your phone model and install the appropriate files.

    Supported models:
    * i_atnt (P930, NitroHD)
    * i_vzw (VS920, Spectrum)

    Note:

    Phone model is detected using the SoC build id. If the install fails, send me the contents of your /sys/devices/system/soc/soc0/build_id and I'll add support.

    Install instructions
    * Install the latest recovery. As of this writing, it is CWMT 6.0.1.1. See other threads in this section for how to obtain and install it.
    * Download the ROM, verify the md5sum, and put it on the root of your sdcard.
    * Download JB 4.2 (not 4.1) gapps from goo.im, verify the md5sum, and put it on the root of your sdcard.
    * Power off your phone.
    * Hold volume-down and power until you see the scary warning screen.
    * Confirm by tapping the power button twice.
    * Make a backup of your current system (use the tar method!)
    * Do a full wipe / factory reset.
    * Install the ROM.
    * Install gapps.
    * Reboot.

    When and why do I need to do a full wipe?
    Always do a full wipe for now. There are issues with dirty flashes that I need to investigate (eg. the browser won't open up).

    Bug Repoting
    death2all110 set up a bug tracker here. Please consult this before reporting any new issues.

    Donations
    I don't accept donations. Please donate to the EFF or one of the hosting providers.

    Advertisement
    :
  2. cryoaura

    cryoaura Well-Known Member

    Oh it's happening, right here, right now. THANK YOU TDM!
    tdm likes this.
  3. IMUcarmen

    IMUcarmen Well-Known Member

    awesome man. thank you very much my good sir!
    tdm likes this.
  4. PhoenixPath

    PhoenixPath Well-Known Member

    Saw the beta on your iproj folder and almost began channeling Gollum.

    Cannot wait to get home and check this out. Needless to say, it's going to be a *very* long day...(Left the spectrum at home today - that'll teach me)
  5. IMUcarmen

    IMUcarmen Well-Known Member

    its not working for me.

    I flashed it three times in three different ways but got the same issue each time.

    What happens is when I get to the point where you would normally setup your gmail account and such it just repeatedly says "setup and stopped working" and "gapps has stopped working". I click ok and it pops right back up. Both of those popups happen over and over again and I can't get out of them. data works, I can drag the notification window down and the toggle window but I cant get to settings from the notification window. None of my hardware buttons work for anything either. I get a haptic response from them but they don't do anything.

    As I said I flashed this three times. The first time I flashed it with 4.2 GAPPS, second time I dirty flashed it, third time I did another clean wipe and flashed it without gapps, and all three times I got the same issue.

    Any thoughts?
  6. ortrigger

    ortrigger Well-Known Member Contributor

    can you get a logcat? CM and AOKP should have adb debugging on by default.
  7. tdm

    tdm Well-Known Member

    It worked for me both clean and dirty flash. But I'll try again just to be sure.

    And yeah, a logcat would be helpful.

    Anyone else have feedback, positive or negative?
  8. vj950

    vj950 Well-Known Member

    Don't have words to describe how much I appreciate your work.

    Installed without any problems (3x3 wipe), running fine, No issues yet (1 hr of use), at present trying to get my data restored using Titanium.
    tdm likes this.
  9. droid-man

    droid-man Well-Known Member

    So, I can't just dirty flash this if I'm already running your RC1 (CM10)? or can I?
  10. sosaudio1

    sosaudio1 Well-Known Member

    Downloading now will do a clean flash and give results
  11. tdm

    tdm Well-Known Member

    Yes but please don't report bugs on a dirty flash. And in my testing a couple system apps fc'd and needed their data cleared: Google play music and youtube.
  12. cryoaura

    cryoaura Well-Known Member

    Clean install straight off of a flashed v7 cab. No FC's on setup. Will post what I run in to after everything's installed.
  13. Dcaugust

    Dcaugust Well-Known Member

    TDM,
    Thanks so much for getting us here so quickly! It's working great so far...the only issue I am running into is that the option to turn on GPS does not exist. it allows you to set Google apps to use your location, but the option to turn on your gps is no longer there. I tried to go into the quick settings under the notification drawer where I added a gps toggle, but when clicked, nothin happens. The icon just remains dark.
    I was one of the lucky ones that had GPS on CM10 as well, so I just wanted to let you know that I lost GPS flashing this from CM10.
    Thanks for all your hard work! Love being able to mess with this!

    **I did a clean install
    tdm likes this.
  14. cryoaura

    cryoaura Well-Known Member

    ERMAHGERD! I ARE FERND A BURG!

    Under volume settings, when you choose to unlink ringer from notification volume, it "looks" like it works at first. If you try to make them different, then go back into volume, you can see they both link up at the same volume, though that box remains unchecked.

    As far as GPS, in my location settings there is an option for GPS satellites, but as with Dc, my GPS is not working, only AGPS. ERR NERRR!!!

    Will continue sifting through bugs.
    tdm likes this.
  15. Dcaugust

    Dcaugust Well-Known Member

    I did actually see the GPS satellite check box in the settings, but it still does not actually turn on GPS.Other than that, works great!!!!
    tdm likes this.
  16. Dcaugust

    Dcaugust Well-Known Member

    one other thing...I did not notice a camera app. I didn't see this mentioned in the OP, so I wanted to check and see if something went wrong with installation or if the camera was not included. I know there have been problems with 4.2 camera, so you might have chosen not to include it. Thanks again!!!
  17. reeseboy

    reeseboy Well-Known Member

    w00t w00t!!!!

    I had to do a double take - at first I was trying to figure out what happened to all the pages, then I realized the title said CM10.1 and AOKP42. AWESOME WORK TDM!!
    tdm likes this.
  18. IMUcarmen

    IMUcarmen Well-Known Member

    I got it working.

    I had to download a different gapps. the one I had was causing issues for some reason. I used that version many times on 4.1.2 and never had issues.

    I'm not sure why it wouldn't work when I tried a clean install but I went ahead and rolled back to cm10 and did a dirty flash and flashed the new gapps I downloaded and now everything seems to be working.

    As far as the camera goes. It works, but I don't see an option for photosphere. Does anyone know if it was removed in cm10.1 because of cross compatiblity issues? I've looked everywhere I can think of in the camera app but I don't see an option for photosphere anywhere.
  19. cryoaura

    cryoaura Well-Known Member

    I have a camera in mine. You flashed the 4.2 google apps after flashing the ROM right? I have the camera when I scroll to the right on lockscreen and in my apps menu.

    Also, the reboot when in camera while hitting power is confirmed happening, no camera/sleep function at the same time... :(

    On another note Does the lock screen take an abnormal amount of time to wake up for anyone else? It takes around 2 seconds for me after hitting the wake button.
  20. PhoenixPath

    PhoenixPath Well-Known Member

    This must be a bug in CM10.1. I just checked my Galaxy Nexus and it behaves exactly as you described, so probably not something introduced by tdm or the LG blobs.
    tdm likes this.
  21. Nokoko

    Nokoko Well-Known Member

    I also had GPS on CM10 but can not get it to work on this. Even restored Eclipse, got a lock, then flashed this and it still won't connect. Shows it's on in settings but Maps/GPS Test still register it as off. Other than that it's working great so far!
  22. legmando33

    legmando33 Well-Known Member

    Yeah it is. My galaxy s3 with latest cm10.1 nightly does exactly that.
  23. PhoenixPath

    PhoenixPath Well-Known Member

    I should have probably mentioned that I was using the latest (0206) nightly.

    Now I guess I have. :) Thanks for the confirmation!
  24. IMUcarmen

    IMUcarmen Well-Known Member

    anyone know how to get to development settings? I'm trying to get usb debugging turned on but I can't find where to do it for anything.

    To the person asking the question about the lockscreen...I to have this issue. Takes a good second or more to turn on.
  25. legmando33

    legmando33 Well-Known Member

    Tap the build number a couple times in settings/about phone til its enabled.
    IMUcarmen likes this.
Loading...

Share This Page