[ROM]Stock 2.3.4, Sense 2.1[Rooted][Apps2sd][MetroPCS]- Only for marvelc


  1. insink71

    insink71 Well-Known Member

    This is a rebuilt nandroid backup from dsixda's Android Kitchen. Be sure to do a nandroid and do NOT flash this on any other model wildfire s [A510c ONLY]. 2.3.4 as is stock to MetroPCS, added everything including busybox, A2SD, and su, If any devs would like to pull it apart and meld your kernel in, go for it; otherwise it works on marvelc only. Again, make nandroid. Should have full HTC sense 2.1. Download Link2SD from market for some space savings, and don't say I didn't warn you to nandroid [three times].

    Also, as with any new rom installation. I recommend doing the following in your recovery: a factory reset [which wipes your data and cache] and advanced clear dalvik cache. If you do those two things, you usually don't have any transference issues.


    Code:
    Android OS version             : 2.3.4
    Device                         : marvelc
    Model                          : HTC-PG762
    Rom Name                       : 1.05.1550.00
    Rooted (Superuser.apk + su)    : YES
    Rooted (unsecured boot.img)    : YES
    BusyBox installed              : YES
    BusyBox run-parts support      : YES
    Apps2SD (Apps to EXT) enabled  : YES
    /data/app enabled              : NO
    Custom boot animation allowed  : NO
    Nano text editor installed     : NO
    Bash shell support             : YES
    /system/framework is deodexed  : NO
    /system/app is deodexed        : NO
    radio.img found                : NO
    ROM will wipe all data         : NO
    --Download Link--

    Changelog:
    01-05-12 got contribution of
    official RUU from Football
    built from that.
    Full friendstream choices :)

    Known Issues:
    You tell me

    Thanks
    So many I can't remember them all.
    eoghan2t7 - for his work developing s-off [w/o xtc clip]
    GotsOJ - for being the first to document his s-off experience (was very helpful).
    alquez - for his work on the Unoffical CWM Recovery and port of CyanogenMod [which is where I'll be spending some development time next (kernel editing)]
    dsixda - of course for his kitchen
    jikantaru - lots of sense development for the Euro-side of this phone
    Football - for his skill at acquiring RUUs.. please go thank him [over on XDA]

    Please note: I do try to support my roms and I am working on a newer Rom for MetroPCS; however, I am tired of supporting people that flashed other roms (sometimes even gsm), screwed up their phone, flashed my Rom back on, and then say it don't work. Luckily I've not seen this on this thread, but my pm and email boxes have been blowing up with MetroPCS support cases. This is the ONLY known rom written specifically for your device. MetroPCS has good coders working for them, because their base is more complex than the other two carriers the MarvelUSc team supports. If I owned your device I would not flash any other ROM. If you choose to, and you then come back to me for a fix... I may well ask a donation amount.. It's hard enough for me to care for my code, but if I have to dl roms, break them apart, see what partitions they may or may not have kicked up (as it pertains to your device), then Use the RUU (I paid for) to administer the fix (which I haven't got working right for the newer S-ON bootloader as of yet)... Well it's time consuming and I can't work on newer roms for you guys if all my time is monopolized. So take it easy and flash THIS ROM ONLY right now if you are MetroPCS.
    Thanks.

    Advertisement
    reilus, jonny wad, jleon426 and 12 others like this.
  2. insink71

    insink71 Well-Known Member

    Hey guys,

    More than a few MetroPCS users contacted me [mainly from this forum] and requested that I do a stock [flashable] build for you. Welp, here it is. Very similar to the bases I made to VM USA and US Cellular except it came from the official RUU [so it's even cleaner] :) Ok. Now I got to go fix some other things.

    Regards,
    Rob

    Edit: These bases usually had trouble getting the cooked in A2sd working [cache to sd, etc] Download A2sd Gui and Link2sd from the market. Then slowly go through the options... I have a mini guide I'll pull over from another thread...
    reilus and ForeverShine like this.
  3. insink71

    insink71 Well-Known Member

    WFS has severe memory challenges; so, I cooked in Apps2sd support.
    That being said, it still needs to be enabled.

    EDIT: First you need to prepare your sd card to use Apps2sd & Links2sd. Here is a good guide from an acquaintance. http://forum.xda-developers.com/showthread.php?t=1432459 . It may be labeled preparing for Links2sd, but Apps2sd also relies on you having an ext partition setup.

    A2sdGui
    Fire up your newly installed v1.1 and select the A2sd gui app.
    Allow Superuser access.
    Click Yes to continue. [maybe two times]
    A note here. All of the roms I have ever released are zipaligned [contrary to another dev's opinion].
    You may choose zipalign on boot if you want to keep zipaligning them each boot cycle.
    Ignore swap as the stock kernel doesn't support it.
    Now click the Dalvik tab at the top.
    Select Dalvik Cache on SD-EXT
    Then lets say set [judgement call] set your VM Heap size to 30 at the bottom
    then select move and rebuild and confirm with yes.
    Another note: I cooked this to have the dalvik on sdcard; so, it has the support; just doesn't pull the values.
    Your device will now reboot [and make take a minute to rebuild your dalvik cache].
    You may [or may not] choose to go back into the A2sd gui now & click yes again.
    Go to low memory tab at top and choose a setting [I like Optimum]
    Then hit change at the bottom.
    You are done with this app.

    Link2sd
    Now that we've got the A2sd mounting issue resolved easily, fire up Link2sd.
    It will scan your sdcard and ask what kind of format it is.
    Now if you have partitioned your sd card, you should know the value to choose [Mine is ext3, but I partitioned it that way]
    If you are still using the factory sd card, You will want to choose Fat32/Fat16 here.
    Allow Superuser access.
    It will give you a message about creating a script. Click OK.
    Now hold down the power button and then choose restart. Might come up with a message, but click restart again if it does.
    Upon restart, you can move any program you download to your sdcard from the Link2sd app. No matter if it has A2sd support or not.

    And that is your mini-guide. I cannot write a script for it unless I knew what kind of partition you may or may not have; so, this is an easy way to get it up and running.

    Regards,
    Rob
  4. michael916

    michael916 Member

    I'm new I just got this phone today and its rooted but how do I know if this is the A510c model. It is on metropcs but I don't how to tell
  5. insink71

    insink71 Well-Known Member

    You are A510c; there is only one metropcs phone to my knowledge and it's A510c. But, since I don't have that rom loaded I would guess that if you booted into hboot, it would show you your phone model [at the top]. [power down, wait about 10-15 secs, hold the volume down button down and tap the power button]. Nice to finally see a response. :)

    Rob
  6. Vyrus69

    Vyrus69 Well-Known Member

    Nevermind, just read the first post.

    I'm loading now, will let you know any issues asap.
  7. Vyrus69

    Vyrus69 Well-Known Member

    Installed it and went back to stock, everytime I tried to move the Dalvik to the SD card it was giving me an error so I gave up.
  8. anarchem69

    anarchem69 Member

    is this the only rom for the metro marvelc bc this is all i can find anywhere unless u can flash any rom and still get a metro signal?
    saber85 likes this.
  9. djthebogan

    djthebogan Well-Known Member


    U should be able to flash any Rom for marvelc, but it will say different carriers on your dropdown list
  10. insink71

    insink71 Well-Known Member

    I noticed that the signal was lower when I tested this on my VM USA phone. There is a simple fix I am testing with the Euro-port [still in beta on another site]. Basically, VM USA and USCC are the same device; MetroPCS shares a device with one of the marvelct variants; then there are another two carriers who share another device [both marvelct]. So, I have a wrapper that I believe will fix VM USA and USCC roms for your device [just a slight variation but it can affect signal]; let me know which rom you'd like to test-drive; I'll make it work for you because I'd love the testing feedback ;)

    Rob
  11. insink71

    insink71 Well-Known Member

    So the A2SD Gui app guide didn't work... I will double check it. Cooked it fast bc had a bunch of ppl waiting [bricked or semi-bricked from flashing the wrong rom/RUU]. Did you happen to remember the error or have a logcat, or is anyone else experiencing this issue [that could provide me with one]?

    Thanks,
    Rob
  12. Vyrus69

    Vyrus69 Well-Known Member

    Yea said something about not enough space, not 100% sure.

    I might play around with it again because I don't think I wiped the Dalvik before flashing the new ROM, and I didn't partition the SD card either.

    Its frustrating cause this phone has soooo little internal memory.
  13. insink71

    insink71 Well-Known Member

    I believe to move dalvic to sdcard, you will need a ext2 or ext3 partition [stock kernel doesn't support ext4 unless you've flashed a kernel that does support it]. Definately back-up your sdcard, partition it like you want it, and throw the data back on [you backed up]. The difference is night and day. I also included the link2sd; so, ppl could move any apk to sdcard [little more savings].

    Rob
  14. bobdamnit

    bobdamnit Well-Known Member

    Thanks for this, insink71! As far as I know, this is the only MetroPCS specific ROM available. For now, I'd like to keep the phone as stock as possible, but as you know, the WFS has horrible internal memory.

    Is there a reason you are using Link2SD instead of DarkTremor's A2SD? Link2SD works, I've never used it though. Always just flashed the A2SD script. But I'm coming from an LG Optimus M so...
  15. insink71

    insink71 Well-Known Member

    I did not cook in Links2sd only included a mini-guide above if users want to download and use it. It works with Darktremors Apps2sd which is cooked in, but end users may want to download A2sd gui to activate it [also referenced in above mini-guide]. For some reason the Apps2sd doesn't want to auto-start [or enable without dropping to command prompt or using an app like a2sd gui]; I have heard this is common in newer stock roms. Hope that helps.

    Rob
  16. bobdamnit

    bobdamnit Well-Known Member

    I just flashed darktremors a2sd script, zipaligned, and reset caches. EXT3 partition mounts perfectly and I have full onboard app space. The phone suffers from slow bootup times and slow initial load times after boot, but once its up and running everything is smooth.

    Again, many thanks! Now if only Cyanogen would work. :-(
  17. insink71

    insink71 Well-Known Member

    Yes,

    I joined a team; where, my teammate had attempted a CM7 port. Unfortunately, that build has many challenges. Team MarvelUSc will look at it again soon enough. Personally, I'm trying to work the kinks out of a 2.3.5 Euro Port to cdma. If I'm successful, that will be my next project(s). [I have slated to attempt to port alquez's unofficial CM7 from gsm side and heroc's CM7 official branch simultaneously; whichever one works out first will be the one released most likely >> Seeing heroc's configs will also prepare me for the next project which would be to port sense 3.5 [[something they have already ported from htc explorer]]]. That should keep me busy for awhile.

    Rob
  18. bobdamnit

    bobdamnit Well-Known Member

    Heh. I just spent most of the evening getting rid of Sense. I don't much like the look of it. Feels cumbersome too. Did a pretty good job of it too.

    I'm not expecting a whole lot. Coming from an LG Optimistic with reboot issues, I'll take stable and stock over CM7. One thing I haven't looked into at all: an overclock kernel. Is one available for CDMA/Marvelc phones?
    insink71 likes this.
  19. insink71

    insink71 Well-Known Member

    Mindhexer made a good cross-compatible kernel (for marvel, marvelc, and marvelct).
    Here's a link to the copy I have of his kernel:
    http://www.mediafire.com/download.php?l6nzcywt0wz23x2
    Btw htc released sources to all gsm based wildfire s. The Virgin Mobile source is canadian (which is gsm). I won't build a kernel until I get clean source for our cdma devices; I'm picky like that ;) but that cross-compatible ran well in my tests.

    Rob
    bobdamnit likes this.
  20. bobdamnit

    bobdamnit Well-Known Member

    Thanks Rob! Kernel flashed and runs great. Should help battery life, as well as some of the apps I use. 768Mhz stable, with no gfx artifacts!

    I'm glad someone is working on the CDMA phone. Far as I know, you and the MarvelUSc team are the only ones.
  21. daft909punk

    daft909punk Member

    hello im kinda new to this site . i have a quick question. how will the flash work if you have a stock wildfire s hboot 1.09.000.? and how can i flash it without CWM?
  22. insink71

    insink71 Well-Known Member

    If by stock bootloader you mean s-on, you won't be able to flash custom rom.
    If you have unlocked your bootloader, why would you keep the stock recovery?
    Either way, I'm not versed in using stock recovery; so honestly idk on that count.

    Rob
  23. chicle

    chicle Well-Known Member

    I've flashed this ROM and it's working great.

    My WFS is MetroPCS, bl unlocked, s - on, rooted. Am I right in assuming that you have to be s - off to flash the kernel?

    Sorry for the noob question, but I've searched and haven't been able to confirm this.

    I also have a touchpad, dual boot, webos & cm9 ics alpha 06. I'm more comfortable with that, this is really my first time flashing a phone.

    Thanks again for the rom. I'll be on the lookout for future developments.

    Edit : I'm s - off now :)
  24. insink71

    insink71 Well-Known Member

    Think you are right on that one. Not familiar enough yet with the htc bootloader unlocked but security flag still on thing yet, but I'm getting pinged with support requests on it. So, I'll try to figure it out. Did you attempt flashing the kernel with failed result?

    Rob
    chicle likes this.
  25. chicle

    chicle Well-Known Member

    I tried but it would boot and freeze. Could not flash a rom either.
Loading...

Share This Page