[ROM]Stock 2.3.4, Sense 2.1[Rooted][Apps2sd][MetroPCS]- Only for marvelc


  1. Dodger420

    Dodger420 Member

    spoke too soon my wifi doesnt work
  2. insink71

    insink71 Well-Known Member

    Nope.. I don't know of new radio tricks. You don't want to mess with the radio too much; in fact, the new bootloader blocks anything from writing over your radio.img if you have s-off you could still do it, but it is not advised by me. There are some ADVANCED hackery tricks for changing you SPL which may or may not net you better reception, but honestly, I'd wait for FOTA updates (which you can't install after you've unlocked boot loader) give me a link to them... let me make them installable for you ;) and see if that doesn't improve your reception... or call your carrier and ask them for tips and tricks (each carrier has their own set of codes to get into things like Diagnostic Mode and so forth). Honestly, based on our short conversations thusfar, I would not advise any ADVANCED hackery. You can render your device useless with one misstep. But I've given you enough info that you can do a Google search and figure out some of what it takes.

    Regards,
    Rob
  3. chicle

    chicle Well-Known Member

    Some info on my phone :

    MetroPCS, unlocked bootloader, s - off.

    (the following is the info on the HBOOT screen)
    Marvelc, EVT1 SHIP S - OFF RL
    HBOOT - 1.09.0000
    MICROP-0354
    RADIO-0. 94.00.1014
    Dec 21 2011, 12:14:03

    I have your MetroPCS rom installed and it runs fine.

    I have tried installing the kernels you suggested, but the touchscreen is unresponsive and I can get no further, can't unlock the screen.

    I haven't flashed any gsm roms. I tried Jmz's rom with the same results.

    I have cwm 5.0.2.6 and I restore the backup I made to get the phone running again.

    Before I flashed your rom, I did a wipe/delete data, factory reset, wipe dalvik cache.

    I've searched and googled, but wasn't able to find anything like this.

    I don't know if I've missed a step somewhere. If you can think of anything I could do, I would really appreciate it.

    I hope that your next MetroPCS rom has an oc kernel, which is what I'd like, and that it flashes ok.

    Thanks in advance.
  4. insink71

    insink71 Well-Known Member

    Ahh... Been meaning to write you a thank you note :)

    I believe I have found a simple fix/explanation... in that complete wipe list a couple posts ago... nestled down in there... format boot. I recently messed my phone up a bit coming off one of my betas (trying to build 2.3.5 for marvelc but it still has some gsm elements) That complete wipe method worked for me... but if you break it down... there is only one thing you do in addition to your regular wiping regiment. That's under the mounts and storage.. you format boot. Of course that's going to knock out your boot.img so you better have a backup kernel (or rom with kernel) ready to install. But after that, my phone went back to acting normal instead of "wobbled." Think this might help you too. Try it and let me know. And thank you so much for your patronage :) If needed I'll make the stock kernel flashable for you, if you would like it as insurance ;)

    Regards,
    Rob

    Quick question: Is Jmz a MetroPCS guy? There are some subtle things you have to change to get roms acting right from MetroPCS to VM_USA or vice versa bc of the device number (but the kernel should work across... and any recovery should too)
    chicle likes this.
  5. chicle

    chicle Well-Known Member

    Thanks for your quick response!

    I'll try your solution and let you know how it works.

    I don't know about Jmz, but I'll reread and let you know if I find anything.

    Edit : I have your MetroPCS rom in my sd card, so I don't think I need a flashable kernel. The rom runs great, and I have no problem getting it to run again. I just would like an oc kernel.

    I noticed you have a touchpad, so do I. I'm more of a tablet guy, this is the first phone I fool with. :)
  6. chicle

    chicle Well-Known Member

    No joy :(

    I followed the above steps. Installed your MetroPCS rom. Fired up wifi, Gmail. Then flashed m1ndhexer's kernel and got the same results, a dead touchscreen. So I restored my backup and the phone is working. I guess I'll have to wait for your next MetroPCS rom and hope that it has an oc kernel.
    If you can think of anything else let me know. If not, I'll wait for your update.
    Thanks for trying. To bed now :)
  7. Duir

    Duir Active Member

    Code (Text):
    1. http://www.mediafire.com/download.php?abxq3qmyuv01oxh
    Had to code-box the link since I created this account to post on this thread.

    If you are able to make a new ROM with the FOTA included that'd be awesome as I'm unable to get it to install. I get some weird assert error (see below). As I said, all I did was flash the included Radio files. I re-locked my bootloader and even flashed the stock recovery no go on the install so a little bummed out. I dunno what's all in there besides updated radio, updated hboot (1.10.0000) and a few updated MetroPCS apps (most notably their Easy WiFi app). I'm guessing it's too small an update to be anything really cool like GB2.3.5 lol


    Here's what I get when I try to apply update:
    Code (Text):
    1. assert failed: apply_patch_check("/system/app/AccountSyncManager.apk", "29fb2aff3a868482c3bedd051e7d6a77258a5b8", "767079d60647a63677bf7fe4e48c3aacf12905d8") E:Error in /sdcard/download/OTA_Marvel_C_S_MetroPCS_US_2.00.1550.07-1.05.1550.00_release_237583kszulzccmio085iv.zip
    2. (Status 7)
    3. Installation aborted.
  8. chicle

    chicle Well-Known Member

    I've also had problems with the MetroPCS ota update. The file name is: OTA_Marvel_C_S_MetroPCS_US_2. 00.1550.07-1.05. 1550.00_release_237583kszulzccmio085iv-1.zip
    It's about 26mb.
    The file is downloaded, when I give the okay to install, it briefly does something, then goes into the android figure with a triangle with exclamation point inside. I've tried several times with no success.
  9. chicle

    chicle Well-Known Member

    After rereading some threads at xda, I think Jmz is VM, though not sure.
  10. chicle

    chicle Well-Known Member

    I don't know if this has anything to do with my problem, but I deleted (in titanium) some bloatware. MetroPCS wifi and some others, not vital (I think).
  11. Duir

    Duir Active Member

    Yeah, that's the standard non-informative error display. If you press Vol+ (or Vol+ and PWR...I forget which) you can see the actual error, which is how I was able to post mine above.
    chicle likes this.
  12. insink71

    insink71 Well-Known Member

    That was an informative error :) The assert checks your bootloader (among other things)
    I and you should have known that once you "cross the line" and unlock your bootloader warranty is out the window. Sadly, carriers extend this by not supporting unlocked bootloaders. I can block the OTA notices/downloads in build.prop but since I don't have phone... It's a good scouting method to leave them in. I got OTA now and glanced it over. They updated some apps, patched more apps, but its not 2.3.5. I'll update to same base although I care little about patching the metro bloat.. and release 1.1. I am still figuring out the HTCDev bootloader for you guys' phone, but it's harder w/o a Metro phone to test on. Figured they'd follow same principles of VM & USCC but it really appears quite different.

    Rob
    chicle likes this.
  13. Dodger420

    Dodger420 Member

    hey ROB if its not to much trouble can u help me out with a kernel?.... tryd those 2 but didnt work i might of flashed em wrong...can u send me a file or something please?
  14. insink71

    insink71 Well-Known Member

    No you didn't flash them wrong; it was a bad recommendation(s) on my part. The oc kernels that work on other marvelc devices [it was pointed out to me] do not work on the MetroPCS phones. It's noted and Simon and I are working on a solution. I got fairly frustrated with kernel cooking attempts Sat and didn't turn on the box Sun...again with that we are working with cross-compiled source from marvel [no marvelc source yet... So it can be difficult at best at times] Will look at it again next weekend. Weeknights for smaller projects ;)

    Rob
  15. Duir

    Duir Active Member

    So I noticed something with my phone...something that seems wrong.

    I did a wipe of my phone (mounting all the available partitions and formatting them in CWM) and re-installed this ROM and noticed that I'm only ever connected to the Mobile Network when I am connected to a WiFi network.

    If I disable the WiFi my the Mobile Network stays at "Turning On". So basically I seem to have no internet access on my phone now unless I'm on WiFi. I can still make calls and send SMS, but the market complains of no connection and to try again.

    I have no idea how long it's been like this (usually only use the market when on WiFi anyways) but I even restored an old backup from when I would've thought it would be ok but it did the same thing.

    EDIT: Just to clear it up, I'm running just the ROM nothing else on there and getting the mobile network issue.
    Also wanted to add in regards to the FOTA/Bootloader issue, if you unlock your bootloader via HTCdev it's easy enough to relock it (and unlock again) but doing so seems to make no difference with the FOTA succeeding which sux (cuz why else would I wanna relock the bootloader except to make their FOTA work LOL)
  16. insink71

    insink71 Well-Known Member

    That is odd indeed. What cwm you using if I might inquire? Since I don't have phone, I cannot check partition [starting] memory addresses, but alquez's were same as VM [and subsequently USCC] if you are using something other than alquez's 5.0.2.6, I'd recommend switching, there was one put out by a dev who shall remain nameless that I do not support; it was listed as 5.0.2.7 but I listed it as garbage upon 5 mins of testing. That being said, partition start addresses are cooked into recovery... My guess is someone attempted but failed to get those right and you still have corruption somewhere.
    Alternately, your network is working but you get no data... This would typically be easily fixed with a PG76IMG.zip I could put together on the fly for you [reflashing nvitems and rcdata.img's]... But those aren't flashing right from the new hboot. So.. which hboot you on? And if on new one... wanna irc on Fri and see if we can figure this stuff out?

    Rob
  17. Duir

    Duir Active Member

    Figure I'll make a new post to reply to some of the other stuff in this thread.

    OC Kernel:
    I personally have had success with JMZ's kernel found here.

    Stock Recovery:
    If you need it, it's here.

    Radio Files (MetroPCS):

    0.94.00.1014 - This was stock when I got my WFS.
    0.94.00.1226 - Provided early Feb via FOTA


    Both Radio files and the stock recovery come in their own PG76IMG.zip files.
  18. Duir

    Duir Active Member

    I am using a 5.0.2.6 version (I believe it's the one you are referring to) that came from here. I thought I saw a version mentioned to be specifically for MARVELC on XDA, don't know if that's the 5.0.2.7 you mention or the same 5.0.2.6 from above, but I can find that and give it a try (assuming it's not 5.0.2.7 lol).

    Noob question...what would happen if I attempted to flash the ROM from the stock recovery?

    Yes, I am using the new hboot. I basically flashed that whole firmware.zip file from the FOTA (excluding the recovery and boot).

    I know for MetroPCS unlocking via HTCdev you need to download a RUU from their site which included hboot 1.09.0000...the RUU wouldn't install on my phone but I extracted the ROM.zip file from it and flashed hboot that way and proceeded to unlock it. I still have that file too if it would be of any use. Now, however the hboot on my phone is 1.10.0000.

    EDIT: Oh, forgot to mention...I have no idea what my work schedule is for Friday yet, but if I can I would be up for it.
  19. insink71

    insink71 Well-Known Member

    That isn't a noob question... In fact, I have real trouble flashing anything from stock recovery. You got to remember to enable the verbose for one that's mentioned above or you'll be staring at the exclamation screen... So, since I'm old and can't remember all that, I opted for cwm early on. So, short answer is... I dunnow, never tried it. I built the rom on the older radio.. and I do need to gather up a lot of the aforementioned things... This FOTA I just got I couldn't drill down into firmware.zip from my phone, but I'm guessing it's the newer radio. I'll peep and rebuild v1.1 as a PG76IMG.zip everyone can flash... and clearly state what is being updated (will include hboot) that way everyone is on same page and I'm not swatting bugs from different hboots or radios... Won't that be nice :)

    So, in retrospect my earlier answer is null and void. It's this rom not patched to work with newer radio... At least that's my new best guess ;) But most are not as advanced as you and still have old radio and by most accounts data works ok. We will carefully upgrade... Then, I'll release 1.1... I like to go slow for a reason ;)

    Rob

    So.. for those keeping score.. something may have indeed been amiss... No wonder there have been tons of support emails and pm's...carrier releases patch to fix this.. thus allowing oc kernel(s) (Jmz's mentioned) to work proerly but breaking old config (my rom) for data at the very least... Yep, this has now moved to priority red for me.
  20. Dodger420

    Dodger420 Member

    coo thanks for the supprt ROB.....


    would anyone know a good site or trick to where i can get paid apps free?
  21. Duir

    Duir Active Member

    I don't think it's the rom not working with the radio files. I flashed the older 1014 radio files and installed the rom again and it made no difference. I have no idea why it's doing or for how long it was like this. Pretty sure it worked before as I seem to recall using the XDA app while at work, and I have no WiFi there so obviously it had mobile network access then. I wonder if it's the version of hboot? If you have a link to the stock hboot (1.06.0000) I would love to see if that makes a difference. That's the only other thing I can think of that's changed about my phone.


    EDIT: Looks like I had already downloaded the CWM recovery I mentioned previously about being specifically for MARVELC on XDA (just not installed it). However, after flashing it, I saw it was 5.0.2.7 and didn't bother with it. The post now points to Alquez's Unofficial CWM 5.0.2.6 which I downloaded and flashed just to make sure I was using that one and reflashed the rom with no change. Also, for I fun, tried flashing with the stock recovery and it took about half a second before it complained about no signature...so that question answered, cant flash the rom w/ stock recovery LOL.
  22. insink71

    insink71 Well-Known Member

    I do have a stock hboot I will pm you. Here's some of the challenges though... The oc kernels are reported not working.. touchscreen prob with original bootloader. So You strike me as a fairly advancer user at least.. I probably don't need to warn you but I will anyway... The hair on the back of my head stands up anytime I flash hboot... its a fastboot only flash imo. And well its on my box at work... So I'll send it pm to you later. You can flash it and try it... i'll send you stock boot.img as well ;) If it works we may fix wifi but limit kernel to stock. Alternatively, there were a bunch of patches in that FOTA did you apply them or just the firmware.zip? I think this is a newer bootloader issue as you are not the only report of this wifi behaviour ... But I wonder if a patch has fixed it as well... In other words, if you were just a reg joe I am not going to root my phone and I'll live with whatever they give me kind of person... Well nevermind you probably wouldn't have newer bootloader... My point was going to be the stock is rarely broke [not my stock or some other dev's stock.. those can get wobbled but also can do things that stock blocks.. ie wifi hotspot. If you can't irc fri you want to sat? Simon my teammate wanted a crack at ya'll's rom so he is releasing one... tom or sat... I would like to figure everything out though still.

    Rob

  23. insink71

    insink71 Well-Known Member

    I believe stock recovery checks for the official signatures. But my rom is unpacked compared to the FOTAs and original RUUs... I could pack it all up in .img files and throw the original autoinf in and it may work in stock recovery but I would still have to sign it so no guarantees. I've heard sometimes you can get FOTAs to flash a second go-round if you'd like to try that as well in stock recovery. In other words, they are supposed to autorun and update but fail, some have then reflashed (same FOTA) with success on other devices... Worth a shot.

    Rob
  24. Duir

    Duir Active Member

    I've tried to flash the FOTA multiple times in stock recovery, CWM, hboot locked/unlocked and it still fails - fails at different points, but fails just the same.

    I had only flashed the radio files from inside the firmware.zip originally. I had done hboot later on (but went back to 1.09.0000 to see if that fixed my mobile network issue) and at one point also flashed the boot.img but I had too many issues with that (no doubt cuz it was built for the new ROM version#).

    At present I have none of it flashed.

    My hboot is back to 1.09.0000 (where it was after htcdev unlock)
    and my radio is back to the 1014 listed above. My recovery is the one you recommend (Alquez's unofficial 5.0.2.6).


    If I could force the FOTA to update I totally would just to see if it made a difference with the Mobile Network issue but I don't know how, and had know lock on my searching.


    I am still interested in trying with the 1.06.0000 hboot just to see as that would have been the version I was using at the time I remember it working.

    Also, I will be home Friday, so all we need to now is nail down a time. I'm in California so am on pacific time.
  25. insink71

    insink71 Well-Known Member

    I got embroiled with tax stuff at work and totally forgot to drop you the hboot; my apologies. Later today is a new day though; I'll tie a string around my finger.

    Rob
Loading...

Share This Page