1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

[ROM] Velocity V1.2 | LG Ally | Android 2.2.2 Froyo | Sexy | Sleek | Stable


  1. FinalStorm

    FinalStorm Active Member

    I would love for explain to me why a Lock Screen App even needs to directly call numbers.
  2. Zoandroid

    Zoandroid Well-Known Member

    I can think of only one reason - to mine all the data on your phone. I admit that before now I had given app permissions lists a cursory glance and not much more. After seeing this, I'll carefully read them now! It is exactly our level of complacency these malware writers are hoping to depend upon for their evils to succeed. People are far too trusting, especially with their data.
  3. don_al_corleon

    don_al_corleon New Member

    Hey. I just wanted to say thank you and am very appreciative of all the hard work that i s put into the velocity roms.
    I have always used velocity on my old lg allys but I just got a replacement ally with 2.2.2.my question is to flash this rom, do I have to downgrade froyo?can't I just use rom manager and flash? I already rooted my 2.2.2. Using gingerbreak.
    Thank you for your time.
  4. FinalStorm

    FinalStorm Active Member

    You're already running Froyo with 2.2.2. Just nandroid, wipe, and flash and it should work.

    I wouldn't use rom manager to flash. Much better to flash using clockworkmod recovery, or amon ra recovery.
    don_al_corleon likes this.
  5. Zoandroid

    Zoandroid Well-Known Member

    I can never remember the reason it was we would want to have Fastboot, which I am wondering if he won't have on the newer Ally. What was that for again?

    don_al_corleon - some of us (myself especially) have had some problems which were caused by using Rom Manager, so I too would recommend not using it.
  6. don_al_corleon

    don_al_corleon New Member

    Thanks for the replies. I am a little confused with the steps I take to flash. So with your recommendations I will not use rom manager. I just downloaded amon ra zip. What do I do from there? I know after I wipe everything and then flash velocity but I'm so confused with amon ra.
    Thanks
  7. Zoandroid

    Zoandroid Well-Known Member


    Once you have the amon ra recovery downloaded (make sure to use the MD5 key to save yourself some grief and verify the downloaded file is good) then on that site where you downloaded the recovery file from, find the line:

    Directions to flash recovery

    Below that are specific instructions on how to install the recovery image (mostly in the gray box area) using either terminal on the Ally (simpler) or ADB from a PC.

    Once you get Amon Ra Recovery installed, return to this thread, message #1, to read what to do to flash the ROM.

    Hope that helps. :)
  8. Idunno

    Idunno Well-Known Member

    Me too, apples give me diarrhea.
  9. Johnny Langton

    Johnny Langton Well-Known Member

    I must say this is the smoothest I've ever seen my lil 'ol Ally run. Love the theme, love the tools, love the functionality. Both my Ally and my wife's Ally are flashed to this ROM-she really likes the dark mms and contacts apps. As for stability-my Ally will only OC to 729mhz reliably, but my wife's warranty replacement Ally flat out loves this ROM. It has no problem running 864mhz. Linpacks scores 10.55 Mflops, and Quadrants are in the 1140's repeatably. I ran 30 rounds of the Quadrant benchmark back to back with 30 rounds of Linpack benchmarks and have tried every single app on her phone trying to get it hang/kernel panic, but I can't get it to hiccup. I can only guess that the CPU in hers is a perfect sample. I'm impressed with the Ally all over again after playing with her phone for a bit with Velocity 1.2 onboard.
    JL
  10. tigersfan1

    tigersfan1 Well-Known Member

    I am having some calling problems on Velocity 1.2. I use to have the same problem on Velocity 1.1 but i fixed somehow and i don't remember how. So whats happening is that when I make or receive calls it stays on dialing during the call then when I hit the end call button it doesn't end the call and my screen keeps on the call. Is there a fix for this?
  11. Zoandroid

    Zoandroid Well-Known Member

    I can tell you that it is a bad idea to turn of the auto-update feature on Super User. :D I tried that and it affected every app that uses super-user root access, wanting to keep them from running. So I turned it back on.

    Can anyone tell me if it is OK to uninstall or TIBU-Freeze the "Upgrade Utility for Ally" which had been a requirement to get one of the last OTA updates some time back? Do we still need that now?
  12. savoxis

    savoxis Well-Known Member

    You dont need the Upgrade Utility. Also the SuperUser apk has been having some issues recently, I broke my Incredible2 by upgrading it. You can always use RomManager to get/flash the older version.
    Zoandroid likes this.
  13. savoxis

    savoxis Well-Known Member

    Reading through the thread I notice that the main problems are:

    Some apps not updating from the market properly
    As for the apps not updating, I replaced a few of the stock apps with modified variants (mostly just dark themed) this will cause problems with updating, but, If you need the latest version, you can run my script ( I know its f****d up right now but you can launch "velocity -ol" to run it in offline mode) and uninstall the apps you want to update using my super freaking awesome dynamic system app remover.


    The calculator not having a - sign
    I think it is epic that this made it into the thread. Nuff said.



    I want to do a little more work mayhap release another patch, but I dont have internet or an ally right now. One of my old testers owes me an Ally and I will get on him a little harder about that. And my internet will get paid at the latest around the 20th of this month, unless I get enough donations to get the bill paid early - speaking of which I would like to thank the very few, albeit very generous donators, I now only need ~$45 to get comcast back on - which is all I need to move the script mirrors and repositories off site so service is not dependent on my not being a deadbeat
  14. A Lex and Er

    A Lex and Er Member

    Hey folks

    Velocity has been making my house holds Ally usable for quite a while now, I think about one and a half years.
    The Ally was my wife's first Android and at this time it is our home phone.
    Cause my Android hackery occasionally levees me with out a working device for a few hours at a time, I'm sure ya'll can understand;)
    Anywho, mad props and big Thanks for making this sometimes unbearable device usable for us all, a small donation went out to each person in the OP:) this AM but it's no comparison to my appreciation for all of the fine work and time of the gentlemen who continue to make this project happen.

    Thank You!
    from,
    aLeXandEr and Family
  15. Zoandroid

    Zoandroid Well-Known Member

    Could the issue of a spontaneously 'stuck key' be related to the problems you mentioned with the newer SuperUser app?
  16. FinalStorm

    FinalStorm Active Member

    I had that problem in Velocity 1.1 and occasionally in 1.2. Just curious, do you use google voice, and have your phone setup for google voice mail. I found that as soon as I set up GVmail I start getting this problem. It also happens after I tether (wired or wireless) for long periods of time. Its a weird issue I know, and I don't think I'm any closer to figuring this out than yourself. But it seems to happen much less often with 1.2, so I guess that is good.
  17. savoxis

    savoxis Well-Known Member

    Could be related to overheating. Tethering will cook your phone quick, causing a whole litany of strange reboots and other issues
  18. FinalStorm

    FinalStorm Active Member

    That is entirely possible, but I thought it was only wifi tether that overheats like a mofo (please correct me if I'm wrong). So I use wired tether most of the time. That doesn't seem to overheat my ally.
  19. tigersfan1

    tigersfan1 Well-Known Member

    I dont use google voice i think i uninstalled it and my phone is at 600mhz so it isnt really overclocked
  20. kinghawg98

    kinghawg98 New Member

    The only thing I have noticed so far (minimal use) is that the landscape view of the alarm is incorrect when setting an alarm time- You can't really see the "-" button to lower the hour/minutes. Perhaps just my phone.

    Looks pretty neat so far though.
  21. Ramious

    Ramious Member

    Wow thanks for Velocity my first android phone, yey a reall noob here, Velocity 1.1 makes it run screaming fast and with no issues i have found. So natureally I am dying to flash it up to 1.2 but all of the download links that i have clicked in the first post willl not download. am i missing something? or is there another place i could download from ?


    Sorry . must have just been IE8 downloaded fine with firefox. can't wait to get this flashed !!!!! yey finaly :)
  22. Zoandroid

    Zoandroid Well-Known Member

    I see that exact same issue with the missing "-" button, but if you are really exacting with where you tap, it "is there", in just a sliver of the button. So you can use the - feature. It's just a little tricky. I also see some of what I think are "scaling" issues in another application. Its menu choices when I used it in Velocity 1.1 were scaled to fit the screen in groups of 3. Now part of the 3rd menu choice is obscured at the bottom of the window, similar to the +/- key issue. I wonder if Velocity 1.2.1 has done something to change the screen resolution (number of pixels high by number of pixels wide)?
  23. savoxis

    savoxis Well-Known Member

    The LCD density should be default, however as I cant see what it looks like you might want to check and possible lower it a bit, you can do this from the scripts, just remember you will need to launch with the -ol switch as the servers are down
  24. Zoandroid

    Zoandroid Well-Known Member

    Back in Velocity 1.1 someone posted discovering a solution for the lag experienced in the home screen being re-drawn, like after closing a browser app. I'm seeing that again on 1.2. Anyone remember what the solution was?


    Edit - Well, I found in my logs where this issue had been mentioned before in 1.1. As it turns out, it was an issue with Launcher Pro, and switching to ADW 'was' the fix! :rolleyes: So now that it is happening in ADW, anyone have any ideas how to stop it? What I am seeing is the blank home screen that should be full of icons and widgets and the side bar, which is also devoid of icons, for several long seconds until they suddenly all appear again. This usually happens after closing Opera Mobile following a web browsing session. I don't like any other browser, for reasons I explained in detail back in the 1.1 thread. (Short story, only Opera Mobile keeps up with my typing into a forum post - all the rest have such SERIOUS L A G that is so slow, typing is unnervingly impossible for me.)
  25. Zoandroid

    Zoandroid Well-Known Member

    Here's a screen shot showing an example of what we are seeing. These scrolling date number menus should each have a "full sized " minus sign, equal in thickness and proportion to the plus sign above. But as you can see, they are barely visible as slivers of what should be there for the "-" sign. They are still workable, but you must tap precisely on the thin sliver of the "-" sign to activate scrolling the number smaller.

    I also attached a portrait view of the same menus, and you can see what the "-" signs look like when they are correctly rendered. For some reason the total "window" size showing these menus in the portrait mode is not tall enough to allow them to display properly.

    Attached Files:

Share This Page