[ROM] ViewCOMB 3.2 - Honeycomb 3.2 for ViewPad 10sGeneral


  1. [Legionnaire]

    [Legionnaire] Active Member

    [​IMG]

    Good day to everyone! :)

    This is the most stable ROM that exists for ViewPad 10s. ViewCOMB 3.2 is based on VegaComb 3.2, including all updates. My idea was to adapt VegaComb for ViewPad 10S. I made few cosmetics changes on VegaComb, added some applications, and made some tweaks in kernel. All credits goes to the VegaComb developers. Thanks to Newbe5, Rebel1, Ejtagle, Corvus, Cass67 and all VegaComb developers.


    Changelog:

    Build 7.2
    • 160 MB GPU (This should stop browser fc's)
    • New kernel (Ideally should be used with a 352 MB swap partition)
    • New WiFi drivers
    • Increase framebuffers to 8 MB each 720P HDMI output
    • Video playback grainy set to 32bit depth
    • Disabled allow nvmap to use system memory and reclaim iovmm which gives a slight performance boost
    • Keyboard power button debounce interval set to 50
    • Boot issue fixed
    • Some apps have been removed (OS Monitor, Terminal, ViewCOMB Screen)
    • System partition size: 160 MB

    Build 7.1
    • Boot issue fixed
    • Added new Android Market v.3.4.4

    Build 7
    • Rotation lock switch has been enabled
    • 80 MB GPU
    • New WiFi drivers
    • Added Hide TaskBar app
    • Added OS Monitor app
    • Added Terminal Emulator app
    • Added ViewCOMB Screen calibration app
    • Added Music v4.1.511 app
    • The most apps from system partition were transferred to a data partition
    • Managing memory space is improved
    • New kernel has been compiled
    • Minor kernel fixes
    • System partition size: 130 MB

    Build 6.3
    • Full Screen HDMI

    Build 6.2
    • Stable 1.2GHz CPU mv
    • Support hidden networks (SSID)
    • New kernel has been compiled
    • Minor kernel fixes

    Build 6.1
    • New WiFi drivers (Proven WiFi & Bluetooth can operate at the same time)
    • Working EAP MSCHAPv2 WPA-Enterprise
    • New Android Market v3.3.12
    • Minor kernel fixes
    • Minor ramdisk fixes

    Build 6
    • New kernel has been compiled
    • RAM memory lack fixed
    • New wifi drivers
    • Bluetooth improved
    • Color deep fixed
    • Possibility of increasing CPU frequency to 1.2GHz
    • Power management fixed
    • Added new Movie Studio v1.1
    • Added new Google Maps v5.12.0
    • Added new Android Market v3.3.11
    • More stable
    • System partition size: 160 MB

    Build 5.1
    • Added Ice Cream Sandwich Clock
    • Added Animated Clock widget
    • Added Digital Clock widget
    • Added Email widget
    • Added Lock Screen widget
    • Added Weather widget
    • Status bar has beeen changed
    • New wallpapers
    • App Launcher with 5 rows
    • Added new Honeycomb Market
    • Added new Google Maps
    • Added Music3 app instead Music2
    • Added Shuttle Tools app
    • Added Drive Mount app
    • Added Draw app
    • Added Movie Studio app
    • Added eFile app (better file manager)
    • File Manager has been removed
    • Google Books has been removed
    • Updated camera libraries
    • Working USB Host
    • Splash screen has been changed
    • Boot animation has been changed
    • Default wallpaper has been changed
    • System partition size: 155 MB

    Download:
    ViewCOMB 3.2 Build 7.2


    Installation

    First install USB driver for ViewPad 10s. Download driver: ViewPad 10s USB driver
    Step-by-step instructions for driver installation: PDF
    Open PDF file, go to the page 4, follow instructions from step 1. to step 8. Close PDF when you done step 8.

    If you are sure you installed driver correctly, download file ViewCOMB 3.2 and double click on it. Wait few minutes to finish installation process, then turn on your tablet.

    That's it! Very simple and easy.

    Enjoy! :)

    More screenshots here.

    Advertisement
    :
    neerlaj, slateblue, presna and 7 others like this.
  2. sammyc250

    sammyc250 New Member

    Nice, so easy, and pad is super nice to use with 3.2, cheers mate :)
  3. whisper380

    whisper380 New Member

    Do you need to root your tablet or can it be installed like in the manual? And where can you download stock android 2.2 rom?
  4. [Legionnaire]

    [Legionnaire] Active Member

    Just like in the manual. Follow instructions in first post. It's very simple.
  5. aldoc

    aldoc New Member

    Hello from Spain!
    I've just bought that tablet and I was wondering if you're going to update your ROM.
    Because It's 3.2 Build 5, and we can find in xda 3.2 Build 9 update 3.

    Thank's for all!

    EDIT: I also want to know if my tablet will be rooted?
  6. [Legionnaire]

    [Legionnaire] Active Member

    Hi!
    All updates from Vegacomb are included in ViewCOMB 3.2 Build 5.
    Your tablet will be rooted with ViewCOMB.
  7. [Legionnaire]

    [Legionnaire] Active Member

    New update is ready!
    Build 5.1 is available for download in the first post.
  8. caved11

    caved11 Member

    Hallos, I have been testing 3 releases 5.0 and 5.1 and vegacomb 9n the update 3 version.

    There is a problem with 5.1, it pushes memory use just over the edge. You know alot of mem is used to play tegra games. were some games ran on 5.0 they will not on 5.1. This is a big problem for me and makes 5.0 the best rom for me for now. To give an example Big Bang Racing would run on 5.0 were it would nt on 5.1. Makes sense to really have a good look at the memory footprint for 6.0

    I also gave Vcomb 9n upd. 3 a spin, it is somewhat lighter but also has a bug in the google registration code, it wouldn't see my wifi. All in all i think 5.0 is stil the best rom for me with a good mem tweaker. Good work though...
    Just my 2cp
  9. [Legionnaire]

    [Legionnaire] Active Member

    Thanks for advice! I'll have it in my mind during the construction of build 6.
  10. alligator1

    alligator1 Member

    Hi Guys,
    First of all thanks to [Legionnaire] for the great work, it is absolutely awesome.
    I have upgraded my Viewsonic 10s with the 5.1 build (went like a breeze)
    Something bothers me very much though, is this device so poor or something in the performance of the software is not OK.
    The device renders, video and graphics absolutely fine, but when you start a browser or almost any other app for example and than hit the Home button it takes approx 6-8 sec until you get back to the home screen. (Some other navigation functions behave like this)
    This behavior is very noticeable and sometimes makes the device very laggy.
    I have the feeling that it somehow has problems switching between tasks
    Does anyone of you experienced such things?
    Thanks in advance once again!
  11. [Legionnaire]

    [Legionnaire] Active Member

    This issue is fixed. Currently testing the new version.
  12. alligator1

    alligator1 Member

    Thanks [Legionnaire], you rock!
    I can't wait for the next build to install because, honestly now also the browser and some other apps behave strange and laggy and it simply kills the device usefulness.
    One more thing I also noticed, the device is somehow not going into deepsleep and when idle is draining the battery for about 15h.
    Is this normal or is it supposed to be preserve the battery when you leave it without actually shutting it off.
    Are you going to post here the next build?
    Thanks in advance, once again! :)
  13. [Legionnaire]

    [Legionnaire] Active Member

    Build 6 BETA was released. Download in the first post.

    Features:
    - new kernel has been compiled
    - RAM memory lack fixed
    - new wifi drivers
    - bluetooth improved
    - color deep fixed
    - possibility of increasing CPU frequency to 1.2GHz
    - power management fixed
    - added new Movie Studio v1.1
    - more stable
    - system partition size 160MB
  14. alligator1

    alligator1 Member

    Many Many Thanks!!!!
    I just installed it, it is 1000000 times better than 5.1 :)
    as from the 1h I have tested it so far I can say the display is way better than before, the lagging problem is totally fixed, the calibration is much much better.
    I also managed to totally screw it (may be not me but Skype) I installed it from the market, and guess what, it started, I signed in, and as it was loading the device crashed totally, and could no boot any more, in any way it was hanging on the View Comb animation, just before the mechanical weels to appear.
    I didn't reset it but tried to reboot it, didn't help at all.
    I reflashed the OS to get it back.
    Than tried installing skype again and this time it worked OK, crashed the device, but did not break it fully, the restart went OK and than the skype loaded OK.
    I think the skype app SUX anyway because it is way too heavy and full of bugs and very slow and unresponsive.
    Otherwise so far I am amazed, this device is now comparable with the much higher-end devices.
    Thanks once again!
    I will report how is the deep sleep and battery life.

    Greets :)
  15. alligator1

    alligator1 Member

    Hi again,
    The device gets out of sleep with a bit difficulty.
    it is a small problem, but yet, when you hit the power button for a short interval
    it is not lighting up, than if you press it for a longer 1-2 sec it lights up but the unlock screen is like jammed, you touch it but nothing moves, than you press the power button sever times more it makes ON/OFF the screen and at some point it stats to work normally.

    I think the problem appears only when the device is in deep sleep, because when you hit the power button to shut off the screen and than hold it again (1-2 sec) it lights up normally and the unlock functions as expected.

    Thanks again!
    Greets
  16. [Legionnaire]

    [Legionnaire] Active Member

    Exactly the same problem I had with skype! I doubt that the problem in skype application.
  17. [Legionnaire]

    [Legionnaire] Active Member

    Thanks for your support. Each feedback is welcome.
  18. alligator1

    alligator1 Member

    Hi [Legionnaire],
    The special thanks come to you in the first place :)
    I actually found another strange problem, after a longer sleep the wifi seems not functional and when you go into settings and tap on it, it gets grayed (like disabled) and when you tab back and than again to Wifi it is ON again but no connectivity.
    I still cannot say it this problem is persistent but I had to reboot the device to get it working and the wifi was disabled after the reboot, but I could enable it without any problem.
    I'll continue testing and report more if I find anyting.
    BTW the unclock/start of the device is very annoying, you have to make 2 or 3 long pressed before you manage to unlock it.

    Greets :)
  19. alligator1

    alligator1 Member

    Hi again,
    Definitely the deep sleep is killing the wifi
    Interesting enough I have the feeling that at the begining it was resuming successfully but now it can't. (Only reboot fixes it).
    UPDATE:
    Actually ON/OFF of the screen several times fixes it too
  20. alligator1

    alligator1 Member

    Hi [Legionnaire],
    I am sorry to report that I crashed the device BIG TIME for a second time.
    Here is how it went:
    1. This morning I checked the battery level, for the night it has drained only 2%(power management look ok so far) than I left it for about 40 mins (didn't turn it off or something just left it in 1 min it turns itself off autmatically)
    2. When I came back to it the battery was at 6% from 30%:( (for 40mins with display turned off, something might be wrong on the power management anyway)
    3. I decided to power it down and later charge it.
    4. I plugged it in for charge
    5. Charging for about 2 hours
    6. Still on charging cable I tried to turn it ON, no success ... it is hanging on the viewcomb animation just before the turning wheels and the Viewcomb animation is looping (at first the progres bar, goes to 20% and loops, than 50% and loops, than around 70% and starts to loop to 70% infinitely)
    7. I tried restarting several times didn't help
    so I will have to reflash it again.

    My guess is that there is something incompatible in the Skype service, I will now reflash it and reinstall everything without the Skype and report.

    Once again, I am not complaining, I only report what is my experience :)
    Greets.
  21. alligator1

    alligator1 Member

    Hi,
    I have reflashed the device.
    now without the skype it seems to work more stable but still the wifi is not getting out of the sleep correctly. you have no internet and cannot disable/re-enable the wifi, it simply does nothing.

    Cheers
  22. alligator1

    alligator1 Member

    Hi [Legionnaire],
    Crashed it BIG TIME again, this time there is no skype and no apps installed at all.
    It is a totally fresh installation.
    After the wifi couldn't be enabled I decided to restart the device and now it won't boot :(

    Cheers
  23. Rotorman

    Rotorman New Member

    Hi
    I`m newbie - so maybe a stupid question -

    What about the 10s 3G?

    Will it be supported?
    Or does anyone know where to get a Honeycomb for it?

    Best regards
    Thom
  24. [Legionnaire]

    [Legionnaire] Active Member

    First, I want to thank all of you for support.

    Second, Build 6 is ready for download (in the forst post). No more bootlop. :)
  25. alligator1

    alligator1 Member

    Hi [Legionnaire],
    Thanks for your efforts!
    Unfortunately build 6 is still a no go, it is looping and cannot boot :(
    Did you forget to put fix inside?
    Thanks in advance!
    Best regards
Loading...

Share This Page