[ROM] Viper4G 4.0.0 and beyond


Last Updated:

  1. Granite1

    Granite1 Zercron Encrusted Tweezer Moderator

    You'll want to update to the latest firmware before flashing 3.1. The devs recommend being on the latest for the best user experience. ;)

    I highly suggest going for S-off Crit. Its really not that bad and if you get stuck we're always here. :)

    Seriously you want to be S-off for the long haul. Every OTA throws a monkey wrench into the gears, and it seems to be getting harder for the devs to get everything working right afterword.

    Advertisement
    CriticalCritic likes this.
  2. CriticalCritic

    CriticalCritic Well-Known Member

    Grrr... Now I remember one of the reasons why I gave up last time... this just looks like such a huge PITA with hboot 1.12. DirtyRacun doesn't support it without first upgrading the hboot (with no clear instructions on how to accomplish that), and lazypanda supported 1.12, but it doesn't really exist anymore.

    Well, I have the lazypanda files and I can still find the instructions, so here goes nothing...
  3. CriticalCritic

    CriticalCritic Well-Known Member

    Well I've been at it for a solid 5 hours now and I cannot get the first stage of lazypanda to work. I even flashed Fresh 5.1.1. But no matter what I do it simply says:

    Found device.....
    Finding some bamboo.....
    Cannot write file /mnt/sdcard/sdcard.img
    FAILED at first step

    blah blah blah. I guess I'm installing with S-On.
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    what is your hboot and basband?
    CriticalCritic likes this.
  5. CriticalCritic

    CriticalCritic Well-Known Member

    And now I can't seem to get this new Viper ROM to flash! Soon after it starts it kicks me back to the TWRP loading screen!

    hboot = 1.12
    baseband = 1.02.12.0427
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    you will need to update your firmware. you can't flash firmware as you are not s-off. you can try and re-lock and ruu up to the latest firmware. but i would stop at 3.15 as 3.16 has a boinked tp(touch panel) that will not work with twrp 2.4.0 or lower. the new twrp 2.4.1 will work with the latest tp. however, you will not be able to flash aosp roms with the latest ota/firmware(3.16). you can only flash JB sense roms.

    here is a guide about firmware:
    http://androidforums.com/evo-4g-lte-all-things-root/689274-guide-evo-4g-lte-firmware-guide.html

    again you will need to get s-off, it just makes flashing firmware much easier.
    CriticalCritic likes this.
  7. CriticalCritic

    CriticalCritic Well-Known Member

    That sounds like such a huge PITA. I just want to get LazyPanda S-OFF to work since it's meant to work with hboot 1.12
  8. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    how much room do you have on your internal and external sd card?
  9. CriticalCritic

    CriticalCritic Well-Known Member

    Internal = 270 megs
    External = 9 gigs
  10. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    not sure where lazypanda writes to but i would try and free up space on your internal and see if that helps as it error'd when trying to write onto the sd card.
    CriticalCritic likes this.
  11. CriticalCritic

    CriticalCritic Well-Known Member

    It worked! I cleared out a couple gigs and BOOM! It went through! S-OFF success!!!
    GREAT CALL!!!

    Now to try and get this ROM loaded without screwing up anything else...the only problem now is that my SD card seems to have been erased during the S-OFF process :(
    Granite1 and ocnbrze like this.
  12. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    NICE!!!!!!
    glad it worked.

    yeah lazy panda will do that to sd cards.....i do have a warning in the lazypanda guide about it.....not much you can do though....you should always backup the sd card regularly anyways......at least i do.
    CriticalCritic likes this.
  13. CriticalCritic

    CriticalCritic Well-Known Member

    I did. Everything is backed up and I'll restore it as soon as I get this new ROM up and running.

    The trouble is... I'm still having the same problem when trying to flash it. It keeps glitching and going back to the TWRP loading screen. Any thoughts on that one? :confused:
  14. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    did you flash the latest firmware via the bootloader?

    if yes, then what are you wiping? are you doing full wipes before flashing?

    if no then: you will need the 3.16 firmware to flash the current viper4g.

    and here is the guide you will need again;
    http://androidforums.com/evo-4g-lte-all-things-root/689274-guide-evo-4g-lte-firmware-guide.html
    CriticalCritic likes this.
  15. CriticalCritic

    CriticalCritic Well-Known Member

    I forgot the new firmware, but as of now Yes and Yes. Still no luck. It's still having the same problem. :confused:
  16. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    hmmmmm just curious what is your baseband now? and you say it glitches? what does that mean?

    do you mean it just boots back into recovery? if so then check the catlog. it is the middle icon. you can even move the catlog to the sd card. and then you can post it here. the option is found under advanced on the main menu.....then select copy log to sd and post it here.
    CriticalCritic likes this.
  17. CriticalCritic

    CriticalCritic Well-Known Member

    You have been so incredibly helpful. Thank you!

    I'm redownloading the ROM as a precaution even though the md5 of the last copy was greenlighted when I checked it.

    When it glitches it goes back to the recovery loading screen. Where there's an animation like a Teamwin logo/curtain going up, but it just never goes up. Sometimes it flashes black, and then shows the curtain/logo again, but it never goes up to reveal the functionality of the TWRP recovery.

    Baseband = 1.12.11.1210
    hboot = 1.12.1111
  18. CriticalCritic

    CriticalCritic Well-Known Member

    just tried it again. This time it did boot back into recovery.
  19. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    no worries,

    ok see if you can move the log to the sd card and post it here. i'm curious to see what it says.
    CriticalCritic likes this.
  20. CriticalCritic

    CriticalCritic Well-Known Member

    I tried a few more times but it has not booted back into recovery. At this point I don't have any more time to waste on this and I'm going to need to flash my nandroid soon.
  21. dustwun77

    dustwun77 Endeavor to Persevere :) Guide

    what version of twrp did it come with? Maybe you need to install the latest version of twrp?
    CriticalCritic and ocnbrze like this.
  22. CriticalCritic

    CriticalCritic Well-Known Member

    Well, that could have a lot to do with it :eek: I'm using TWRP v2.1.8

    I thought I read somewhere in this thread that someone was having trouble using the newest version of TWRP so I pushed the thought of updating out of my head. But now seeing that I am nearing to 1 dozen releases since my version... maybe it's time to update... :thumb:
    dustwun77 and ocnbrze like this.
  23. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    nope twrp 2.4.1 should be fine for you. i need to update as well, but i'm on 2.4.0.
    CriticalCritic and dustwun77 like this.
  24. CriticalCritic

    CriticalCritic Well-Known Member

    That worked! I feel like such a moron.:stupid:
    *Oh, you're having trouble with the recovery? Why not update the recovery?* :idea:

    I now have S-OFF and Viper4g 3.1.0!
    Thank you very much ocnbrze and dustwun77!!!
    dustwun77 and ocnbrze like this.
  25. dustwun77

    dustwun77 Endeavor to Persevere :) Guide

    You make it sound so simple! I about hurt myself thinking of that... :stupido2:

    :D:D:D Glad it worked,

    Now, in the immortal words of the legendary OCN, "Get your flash on!" :p
    CriticalCritic and ocnbrze like this.

Share This Page