1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[ROM][WIP] BACKside ROM (CM7) + Green Machine Theme


  1. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Just downloaded the new build. Got to wait for the battery to come up a little. Hey JerryScript, I found the hint you were referring to,and checked as per instructions. Only found Talkback,no eggs. Remember though....(I'm not just a member,I'm a "Nuub")
  2. bhasden

    bhasden Active Member

    First of all, I'd like to say that the ROM is great. It's been very stable and I haven't come across anything that hasn't worked properly. That being said, I just ran my phone off the charger for a little while and the battery is getting murdered by something. I'm running both Advanced Task Kill and Juice Defender Premium and it's not helping. On the stock rom, I could take my phone to work and plug it into a usb port on my work machine and it would charge without issue. Today, I plugged my phone in and it almost seemed to discharge faster than when it was not charging. The phone says it's charging, but it's either not actually charging or it's all of a sudden pulling more power to charge than it did before. I put the phone into airplane mode and turned off all the sync stuff and still it was discharging at the rate of about 10% an hour. Once I got home, I installed Watchdog Lite, but it's yet to report anything.

    The running services are:
    Settings
    Google Voice
    Maps
    Smooth Calendar
    Music (Google Music)
    Advanced Task Killer Free
    Google+
    JuiceDefender
    Watchdog Lite
    Google Services
    SwiftKey X

    I don't have any applications installed (minus the stuff that comes with the rom such as Superuser, Spare Parts, etc) that I didn't have installed prior to flashing this ROM. I did see that there was an update to the ROM made today regarding charging, but my understanding is that's related to being able to charge without having the phone turn on. I'm going to try the updated ROM but wanted to post my issues first in case anyone was having similar problems or knew what was going on.

    Thanks for everything. I look forward to seeing how this ROM progresses.
  3. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Trust me that ain't normal. I'm running the latest build and everything's great as far as the battery life. You could try going back into recovery and wipe everything and format boot,system,data,and cache. Then reinstall. Where you coming from another ROM? and what did you do in recovery just before you installed the ROM.
  4. bhasden

    bhasden Active Member

    I'm coming from stock, so this is my first flashing of a ROM for this phone. I did just flash the ROM from today and it seems to be charging properly when connected to my laptop. I'll move onto installing some of my apps and see which one starts causing issues. Like I mentioned, there's nothing I installed that I didn't have prior to flashing this ROM, so I'm not real sure what the issue could be. Hopefully I can get to the bottom of this since I'm sure someone else may run into the same issue given that I only had common/mainstream apps installed. My wife is also experiencing the same issue, so maybe I can find some commonalities there.

    Thanks for the quick response. I'll let you know what I find out.
  5. Jayziac

    Jayziac Well-Known Member

    I noticed Google Maps using about 40% of the battery yesterday, I used navigation for a bit and it seemed to have triggered higher drain (according to settings - about phone - battery use - graph). Today with new build & reboot I haven't launched navigation yet and it's holding pretty well.
  6. bhasden

    bhasden Active Member

    I've got Google Maps installed but haven't used navigation in days so I doubt that was causing my issue. I do have all of my Market apps installed now and my phone is still charging over USB, so it looks good so far. At this point I'm wondering if the issue is somehow related to either widgets that were on my home screens (TuneIn Radio, Google Music, Beautiful Widgets, Google Voice) or apps/widgets that were moved to the SD card.

    I'm still searching for the answer. I really hope that I don't go through this reinstall and not encounter the issue again. I'd much rather be able to reproduce the issue and know what to avoid.
  7. bhasden

    bhasden Active Member

    Ok, at this point it looks like the battery drain issue had something to do with apps and or widgets that were moved to the SD card. I moved everything from the SD card to the phone on my wife's phone (which was experiencing the same issue) and it appears the battery drain has stopped. I'm still working on confirming this, but that's where I stand right now.
  8. JerryScript

    JerryScript Well-Known Member

    First of all, get rid of ATK, do a little research and you will find that ATK is a dinosaur from pre-Froyo days. It is actually bad for your battery with Froyo or Gingerbread based ROMs. The only thing it is usefull for is on non-rooted phones you can use it to kill off pre-installed bloatware such as Where and Twidroid.

    Basically, the way Android works is to keep apps in a background loop without running them except when necessary. If you use ATK and kill them off, they will attempt to restart when they are supposed to and get killed again by ATK. This becomes a never ending process, and each time the app tries to start and gets killed by ATK, you are draining battery power you don't need to.

    Droidwall and Juicedefender can help with your battery, but ATK is not recomended!
    AndyOpie150 likes this.
  9. frontlinestraw

    frontlinestraw Well-Known Member

    yeah and plus i read an article about atk. its slows the phones performance down drastically when people think it is speeding it up.
    http://androidforums.com/motorola-droid/18334-task-killer-apps-truth.html
  10. jroxas17

    jroxas17 New Member

    I love this ROM, but I hate the Kernel.

    I am using the 072511update with the Xiona 014 kernel from Zeife. It switched the home and menu buttons, but I dont really mind that. It has the same exact speed as the kernel that came with this rom except that there is no battery drain (i was losing 1 percent every 2 minutes) and that Xiona has a well known problem of not showing that USB debugging is on (its on, it just doesnt show)

    I will switch back to the BACKside Kernel as soon as the battery drain problem gets solved.
  11. dwcasey

    dwcasey Well-Known Member

    Thanks JerryScript for bringing this to the LGOV. I feel like I'm "home" again. Been using CM on/off for a while and really like it.
  12. fototogo

    fototogo Well-Known Member

    Hi Everyone and thanks with special thanks to all the developers.

    I've been a professional photographer for most of my life and I install/run windows and now android. I got my first android phone in early March (Optimus V). Started reading about rooting and Roming and was running AOSP CM7+ May 16, 2011 till a few days ago when I went BACKside ROM (CM7) July 22.I had the power drain issue and wiped both caches and updated it with July 25th.... The power issue is fixed but I have some bugs I want to report.

    Angry Birds can't seem to install from market or backup, and my wired headset with toggle switch for playing-pausing music or call waiting or mute is not working....just the switch is not functioning. It worked with 5/16 CM7+ and stock. I also get fc on the ADW launcher upon startup, and press wait.....It then works fine and the os is smooth although I haven't tried everything I use.

    I installed it with Rom manager and either used Cyanogen Mod recovery or Thunder C. Let me know if anyone else has these issues or if I have some sort of corruption. My external micro sd card is not newly formatted or partitioned, and I install everything from it.

    Droid onward,
    Randy
  13. JerryScript

    JerryScript Well-Known Member

    Sounds like you probably have a large number of apps on your sdcard. This makes ADW have the issue where you have to push the wait button during startup (a couple of minutes in usually). This could also be the reason you can't install Angry Birds, it is a pretty large app, and if you are getting low on storage space, it may not install. Try uninstalling another large app (backup it up with TB first), then try installing or restoring Angry Birds.

    A quick and easy way to free up extra space is to uninstall all the live wallpaper and theme packs, if you don't use them. This should free up 20mb at least. I do plan on eventually posting a lightweight build once the release is a bit more stable.
  14. bhasden

    bhasden Active Member

    I wan't running ATK or anything battery saving application until I ran into the issue where my battery was draining. At this point, I'm pretty sure that the issue was with some of the apps I moved to the SD card. My wife was experiencing the same battery drain issue (running the 7/21 ROM) and I moved the GMail, Beautiful Widgets, Google Voice, and similar apps that sync and/or are running constantly to the phone storage and the battery drain issue stopped.

    If anyone else is running into a battery drain issue and has moved some apps to the SD card you may want to try moving some of them back
  15. fototogo

    fototogo Well-Known Member

    Thanks for the reply Jerry: I have a 16GB sd card with 5.49 gigs free. I have fully backed up at least 5 or 6 times all apps and data including system files, maybe that is having an effect???? I have tried to install with app only and app and data....with the same result. My Mixting music playback equalizer disables the seek and numerical counter during playback. If I shut off the eq then all returns to normal. I haven't tried the built in music player because I always use an equalizer and haven't seen an eq in the os yet (but haven't check recently either). My touchscreen has never been more responsive and I greatly appreciate your efforts.
    Thanks, Randy
  16. mkbkr1

    mkbkr1 Well-Known Member

    Look in the app drawer for DSP Manager. That is the equalizer app for all the CM 7 roms.
  17. fototogo

    fototogo Well-Known Member

    I think I reinstalled almost all my apps to the internal memory first, then transfered them to the micro sd card....I ran down to 20+MB and maybe something cross linked. I'm copying over my whole micro sd card to my pc, and the pc found approx 6 zero byte files that didn't exist (an oxymoron), so maybe corruption did indeed occur....I'm going to format the micro sd card and wipe and format the phone and install from scratch....I'll see if all is right. I run 480-729MGHz and I think with this ROM it might be good till at least 787MGHz.... I won't run higher than 729 until I am sure about all other variables. I also will do my best to not waste anyones time. If I find a possible bug I'll be happy to report it if it is timely. I'm sure I could happily live with several under developement ROMS for this phone. I love the configurable icon rows and columns for the homescreens from the included launcher. Any other launchers to reccomend? Otherwise, I'll continue to research and do my homework.... Thanks,
    Randy
  18. JerryScript

    JerryScript Well-Known Member

    You don't restore system apps when installing a new ROM, and though I see you say you tried both ways, I'm thinking that's most likely your issue. Wipe cache/dalvik cache, then reflash the ROM, and don't restore any system apps, all your other restored apps should still be there.
  19. JerryScript

    JerryScript Well-Known Member

    Note- this will break MMS, better off waiting for this to be fixed in the next build!

    The market web interface install issue is due to improper listings in the build.prop file. For those who want to edit it themselves, these are the lines you want to change:

    ro.product.brand=VirginMobile

    ro.cdma.home.operator.numeric=311490

    gsm.sim.operator.numeric=311490

    gsm.operator.numeric=311490

    gsm.sim.operator.iso-country=us


    I will fix this in the next build, and I should have a flashable fix ready soon.
    AndyOpie150 likes this.
  20. JerryScript

    JerryScript Well-Known Member

    Note- this will break MMS, better off waiting for this to be fixed in the next build!

    Attached is a flashable zip file that will fix the market web interface installation bug. I used the build.prop edits posted above. Go into recovery, wipe cache/dalvik, flash the zip file, then reboot.
  21. fototogo

    fototogo Well-Known Member

    Did a clean install of 7/24 including downloading apps directly from the android market. I had corrupt files on my micro sd card and did not want to chance loading anything corrupt into the latest build. The result is complete success although the toggle switch on my wired headset needs to be re mapped. The mute/pause/play/toggle switch turns on the lights to the menu, home,backspace and search keys when pressed. This switch worked correctly with CM 7+ ASOP 5/16 build and also with stock Rom. This ROM is fantastic and I like the so called "bloat" left in. The ADW Launcher is still a bit slow at startup, but the extra features it has is worth it for me. I formatted the Micro sd card before the install and after installed everything including media, I have 5.49 GB left. I also have 141MB of internal memory left. I tried the music player and found the eq....Thanks for the post Jerry, let me know if you'd like a hi res photo of something....name a genre, a few celebs, models or buildings, and I'll send you something I hope you'll like.
    The only other thing I see that can be improved is the music player needs a scroll or something to run in one row x 4 columns where the controls will show. The default is 2 rows which takes up too much space for me....also maybe a 7 page home screen option like the Optimus T. Thanks again to all who made this possible....
  22. JerryScript

    JerryScript Well-Known Member

    You can change the size of widgets by removing them, then re-adding them and selecting the rows/collumns to use. I set the homescreens to hold 5x5 rows/collumns. If you can't get the default music player to fit as you like, try cube music player from the market. See my screenshots in my sig below to see if you like it's widget.

    You can add homescreens by pressing the menu button and selecting edit. ;)
  23. ajgates92

    ajgates92 Well-Known Member

    LOVE this rom...however (always a catch I guess :/) it seems as if the TWS wasn't fixed? I have not so good (actually horrible) reception in my home and with the bumblebee ROM it wasn't an issue. This rom however, I ran out of battery in 7 hours. Help?


    [​IMG]

    [​IMG]

    [​IMG]

    I really hate using airplane mode, as I get no texts. I text A LOT and airplane mode would defeat the purpose of even having a phone.. I moved all the apps I could to SD, so maybe that is a bigger issue.

    @bhasden can you please list ALL the apps you moved? I would like to see if it's those apps messing with my battery as well.
  24. JerryScript

    JerryScript Well-Known Member

    The TWS bug doesn't affect CM7 based ROMs.

    When it does affect a ROM, it manifests itself by showing exactly 50% TWS all the time.

    You do appear to have an issue with poor reception. In two of your photos you show zero bars, and in one you show only one bar. One thing that helped me with poor reception at home is a PRL swap, but it is a bit technical, and may be riskier than flashing a ROM. That said, it helped me in my dead-zone of a home. ;)
    ajgates92 likes this.
  25. ajgates92

    ajgates92 Well-Known Member

    I was actually looking into doing this, but I wasn't sure if the risk was worth it. I am very good with electronics and technical things, so I am not worried. However, I don't know how good of a boost I will get in signal.. How did it help you? I know sprint overall has crappy signal where I live.
Loading...

Share This Page