[ROM][WIP] BACKside ROM (CM7) + Green Machine Theme


  1. JerryScript

    JerryScript Well-Known Member

    You are flashing gapps after you flash the ROM right?

    How are you restoring your apps after install? If you restore using Titanium Backup, make sure you don't restore system apps or data.

    If that's not the issue, you'll need to do a complete wipe/format then reflash, and be sure you flash gapps!
  2. dwcasey

    dwcasey Well-Known Member

    Thanks dev for the great battery life with this ROM. Even though i haven't had to use the phone much, I like not having to worry about looking for a charger more than once a day.

    http://db.tt/X4yj6z3
  3. OmensEdge

    OmensEdge Well-Known Member

    Jerry, how can I completely remove ADW? I prefer a different launcher and need to get rid of this. I tried going through Root Explorer, but the file is read only. I assume I would need to do it through Terminal Emulator. Can anyone help with the command I need to use?
  4. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I just uninstalled ADW launcher with "Root Uninstaller", just like that! Just that easy. Try using super manager. Its really simple and easy to change permissions of any file with a app on the toolbar(tool bar has so many apps that it scrolls right to left) that has three red 7's on it. Plus you can change all files to r/w or back to r/o with ease.
    OmensEdge likes this.
  5. frontlinestraw

    frontlinestraw Well-Known Member

    i removed adw launcher as soon as i installed the rom. download titanium backup pro. and freeze adw. then remove. but make sure you have another launcher already installed. or else, you will be brick, and have to reflash the rom.
    OmensEdge likes this.
  6. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    It's the only thing I use ROM Manager for. It has a feature called Manage and Restore Backups. I can delete any backup without having to go into recovery.
  7. OmensEdge

    OmensEdge Well-Known Member

    Thanks again, Andy. Yeah, I saw the feature in ROM Manager before, but wasn't really comfortable doing any deleting at the time. Downloaded the app again today and got rid of my backups. Tons of free space on my SD card now!
  8. mikeserv

    mikeserv New Member

    Have you heard anything back from the dev? I'm very interested in this. I seem to have internet calling issues no matter which route i take with this ROM: SIPDroid > PBXes.org > Google Voice; Built-in SIP > SIPSorcery > IPKall; Groove IP. I've tried various methods. I think I'm going to flash another ROM until I can work this out. Thanks for all of the hard work though, if I could get internet calling to work correctly I would stick with this one for good! It really is excellent in all other respects.

    -Mike
  9. JerryScript

    JerryScript Well-Known Member

    If you could post a logcat from your attempts to use sip, we may be able to track the issue down.

    GrooveIP has so much audio hacking going on, it's hard to determine what the actual issue is.
  10. Dman861

    Dman861 Active Member

    Some problems I've noticed on my phone so far with the Backside CM7 rom:

    • I'm having trouble with my WIFI. It will not stay connected to my home WIFI. I haven't tried it with another connection yet so I'm not 100% sure if it is the ROM, my phone, or my router (I've tried unplugging and replugging several times). It will connect and turn green, I can browse the internet and other internet apps work, then it will disable itself and restart over again. I'm usually connected for maybe 3-4 mins before it turns itself off and restarts. After a few restart though, it will not even connect and fails at "obtaining IP".
    • Data seems to have problems also and fluctuates between 1x and 3G, even though I have good signal at my home. I'll have to wait till tomorrow to see what kind of signal I get while at work.
    • A few apps have crashed on me displaying a message that says something like "App has become unresponsive", and has options for Kill or Wait. I haven't been able to configure Extended Controls because it keeps freezing on me.

    I previously had the AOSP CM7 rom installed and never had these problems. I backed up and restored all my apps with the "Restore all apps and data" option in Titanium Backup. I'm going to try reflashing this rom to see if that helps, if not I'm going to switch back to the AOSP CM7 rom.

    [update]I just flashed the Backside CM7 rom again, haven't installed anything yet, and still having trouble with my WIFI. It never gets passed 'Obtaining IP' and I have restarted my router several times.
  11. JerryScript

    JerryScript Well-Known Member

    Your problem is most likely restoring all apps and data, if this includes any system apps or data related to another "system", ie another ROM, then the data will most likely not be compatible.

    Restore only apps, then go through and restore data to those that really need it.

    Never restore system apps.
  12. Whyzor

    Whyzor Well-Known Member

    I'm not sure about Groove IP, but when using wifi and the built-in VoiP using my sipgate account with google voice, it's very clear. I would say try to get it to work on wifi first to isolate the problem. VM's 3G data isn't as stable for VoiP calls right now.
  13. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Are you flashing the Theme with the ROM. I was having problems with flashing the theme with the ROM. WiFi and 3G wouldn't work. Try only flashing the ROM then gapps. Reboot. set every thing up.Reboot a couple of times. Leave the CPU speed alone until after you flash the theme. Also was having problems with xionia recovery not thoroughly wiping,and went to CWMod.Coming from another ROM(even though aosp is Gingerbread) You need to wipe cache,dalvik,data/factory reset.Format boot,system.data,and cache. If you are still having problems Turn off your WiFi router and Modem and your phone at the same time. Wait ten minutes and turn them back on.
  14. Dman861

    Dman861 Active Member

    I am just flashing the ROM and gapps. In Xionia recovery, i selected wipe data/factory reset, wipe cache partition, wipe dalvik cache, wipe battery stats. I then flashed the rom, and after flashed gapps. Started up phone, and before I installed or changed anything I opened the wifi settings, and put in the password to connect to my wireless. It will connect and turn green for maybe 3-4 mins, disable, auto-reconnect for another 3-4 mins, disable, and fail at 'obtaining IP address'. If i unplug and replug my router, my phone will connect again but do the auto-disable thing again. Maybe it is my router I'm not sure, but the problem is that I didn't have this problem with the AOSP CM7 ROM. I would like to keep the Backside ROM because it seems a little faster, but connection to wifi is important to me in how i use my phone, as 3G speeds are rather slow in my area (~100kbps max according to the Speedtest.net app).
  15. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    You might have to get ClockWorkMod recovery 3.2.0.1(I had problems with xionia not doing a thorough wipe). After you wipe,You also need to Format boot,system,data, and cache. If you are still having problems with WiFi(I had the problems your having) Then turn off the router and modem and your phone at the same time. Wait ten minutes and turn everything back on.
  16. JerryScript

    JerryScript Well-Known Member

    If you are coming from another ROM, you need to do a complete wipe/format.
  17. yogi-4

    yogi-4 Well-Known Member

    Regarding the bluetooth... last year I bought a cheapo $15 walmart special Emerson headset. I broke it out and started testing. It paired easily, made a few phone calls and Pizza Hut and Dominoes sounded great. I didn't receive any phone calls... I've got no friends. But everything else looks good on the cheapo end. Great job guys!!
  18. joecat

    joecat New Member

    Using the latest build 07302011 sharing contacts via BT is not working
    Was also not working on 07272011

    Both phones on this rom will pair but not connect.
    Errors out with file not sent message.
  19. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    How old is your bluetooth device? There's a jump in technology that leaves a gapp between the new bluetooth devices and the old. If it was not designed for a smart phone,chances are it won't work. You might have to go buy a WalMart cheapo. My visor mount Motorola that I purchased at WalMart 3 months ago cost $40.00 and works flawlessly with this ROM. Yogi-4's WalMart cheapo is working with this Rom. It doesn't appear to be the ROM causing the problem. so it must be the bluetooth device, or..., maybe you could tell us everything you wiped and formated,and what you installed and in what order? The more detailed info, the better and quicker the solution.
  20. exProphecy

    exProphecy Well-Known Member

    Just flashed this ROM onto my OptiV! I actually JUST installed aospCM7 yesterday (new comer to ROMS, rooting, etc). After reading up on which ROMS are updated more frequently and which have more support, I decided to try this one out! So far so good. Seems to have all the settings available in aosp and MORE which is a definite plus! =] One question though.. How do I remove the Green Machine theme? (no offense or anything! looks kool and all but just a tad "too" green for me xD)
  21. joecat

    joecat New Member

    I have 2 phones running this ROM and I cannot share contacts via BT between them.

    they will pair but not connect.
    and they error out if you try to share a contact via BT.

    coming from stock I wipe cache, and dalvik cache
    format boot system data.
    Flash the ROM I started with 07212011
    Flash gapps

    since then i have only wiped cache and dalvik cache flash the new ROM
    Both phones are now on 07302011

    neither phone has the green machine theme on it.

    thats it really just phone to phone sharing contacts does not seem to be working.
    everything else is running very smooth.
  22. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    When coming from another ROM(stock or otherwise) you need to wipe cache partition,Dalvik cache,and data/factory reset. You also need to format boot,system,data,and cache. Install the ROM zip first,then the gapps. Then reboot. Reboot two more times. If the problem still persists borrow a bluetooth device that you know works with smart phones and see what happens. It can't be the ROM as two different types of fairly new bluetooth devices work flawlessly with it.
  23. eriman

    eriman Active Member

    Just got a new microsd card and wanted to started with a fresh clean install of the ROm so I did. I have noticed that when I go to USB connect to connect to my PC my phone reboots itself and stay stuck in that until I unplug the phone or take out the battery. This happened with my previous sdcard as well. any ideas on what may be going on?
  24. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Have you tried to format the SD card with the recovery menu before you put anything on it. If not, you might want to copy data to a folder on your PC. Then format the SD card in the recovery under mounts and format. This is just a shot in the dark in case you have run out of viable solutions,and might not be the most correct solution.
    eriman likes this.
  25. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Go to recovery and wipe cache partition,and Dalvik cache. Then install the BACKside ROM,then install the the gapps. No Green Machine Theme. Reboot
Loading...

Share This Page