[ROM][WIP]CM7 Port for Vortex VS660

Last Updated:

  1. Maw343

    Maw343 Member

    Thanks for responding, I'll give what you said a try as soon as the phone finishes charging.

  2. brianmaedche

    brianmaedche Well-Known Member

    Still no camera, and still can't use screen animations. Roaming indicator no longer shows up in status bar. I had a problem with the 3g connection. Worked around it by checking on international data roaming. And I hit a 1291 benchmark after playing with if for a while. Thanks again for bringing CM7 to the vortex.
  3. asphaltweb

    asphaltweb Member

    Installed the latest tonight. As previously mentioned, 3G was not working by default. Solved this like the previous fella by enabling international roaming. Disabled animations, and things seem to be running smoothly. Still no camera (obviously.) No roaming indicator. (Yay!)

    Hitting the home button when the screen is off seems to take longer than usual for the unlock screen to come up, but this isn't too big of a deal.

    After I starting syncing with Gmail and Google Music, things started to get a little hot. I haven't seen it get this hot without wireless tethering enabled. But after syncs were finished, it seemed to cool back down without any problems. It was probably the database of 19,400 songs in my Google Music account. (But man alive, without this CM7, it took about 45 minutes to load that library. With it, it took less than ten minutes.)

    Now the heat is back. Is anyone else getting massive temperatures with normal operation/charging. I'm at 104 Fahrenheit while charging. I'm not well-versed enough to know about OC changes so I'm going to leave it for now unless someone has a good idea.

    I'm very impressed so far. Can't wait for more updates.
  4. netizenmt

    netizenmt Well-Known Member

    Well I'm danged if I can figure out how to unblank the phone once it blanks. I can swipe and press buttons until I pass out from exhaustion and it never comes back until I do a battery pull. Bummer!! Get that fixed and I'll be hooked!
  5. brianmaedche

    brianmaedche Well-Known Member

    Go into your cyanogen settings in the settings menu and once your in there go to display and unchecked screen on and screen off animations and that should fix your problem.
    netizenmt likes this.
  6. netizenmt

    netizenmt Well-Known Member

    Yep - that seems to have fixed my problem. I KNEW there had to be a fix but I just wasn't picking up on it until I read your post prior to this. Thanks again!

    ...Now... if only we can figure out how to get Netflix to work properly, this ROM will be totally perfect for me! :D
  7. asphaltweb

    asphaltweb Member

    Really, it looks like camera drivers and animation issues are the only things at the top of the list at the moment. So far. Nom' sayin? Riiiirup, Nom' Sayin?

    Edit: Oh yea, and Netflix.
  8. kappacat

    kappacat Well-Known Member

    everything works the same. i wish you luck with few known issues.
  9. netizenmt

    netizenmt Well-Known Member

    I resolved the Netflix issue by installing an older version. You can get it here http://getandroidstuff.com/download-netflix-apk-hacked-work-on-most-android-devices/

    When you launch it, you will be prompted to download a newer version. Always cancel it.

  10. kappacat

    kappacat Well-Known Member

    i can't rotate my screen. :/
  11. BobZhome

    BobZhome Well-Known Member

    In settings > CyanogenMod setting > display > check off the rotations you want
    I personally only like 0 and 90 degrees
  12. Maw343

    Maw343 Member

    For curiosities sake, i was wondering does this rom support ext4?
  13. BobZhome

    BobZhome Well-Known Member

    From the OP(first post):
    ==== '''Changelog''' ====

    Kernel v0.9: a) Reverted: Video Drivers b) Added: EXT 3 and 4 Support
    Maw343 likes this.
  14. F4280

    F4280 Active Member

    By enabling international data roaming is that going to charge me alot more money or should i just wait until a build comes out with 3g working as normal
  15. geofferey

    geofferey Well-Known Member

    Just a note on mobile data... After you flash the rom mobile data probably doesn't work. I got it to work by enabling "International data roaming" in Settings>Wireless & networks> Mobile networks. I just hope enabling that doesn't incur International data roaming charges ;) I think it's just a bug though.

    Edit: I should have read more lol.

    Busted out with logcat and I'm seeing a bunch of the same error. I'll attach it just in case, idk if it will really help any. Also sometimes apps won't install in the market. & it appears there is no root access... (su binary not found)

    Attached Files:

  16. BobZhome

    BobZhome Well-Known Member

    Thanks for the logcat!
    Try downloading Superuser from market and after install, hit menu > perferences. Down below superuser information, tap on Su binary...it will install/update your SU.
    geofferey likes this.
  17. kappacat

    kappacat Well-Known Member

    Still not having any luck. :/
  18. aperseghin

    aperseghin Active Member

    still waiting ....
    need camera
  19. Delons

    Delons New Member

    I have the LG Vortex as a spare phone (my main is a Xperia Play), I am installing CM7 onto the vortex right now, just booting up as I type :D, and I am willing to post any nightly builds, or anything that is not suited for a normal build on my spare phone :D Add me on skype, del.ons, and we can talk :D
  20. geofferey

    geofferey Well-Known Member

    I was trying that last night and it wasn't working. I re-flashed everything this morning and checked, SU is working. I just wonder what caused it to quit working the first time. Let me know of any ways I can help (i.e. providing bug reports & how you'd like me to do so). I guarantee you I'm gonna test the shit outta your rom(s) ;-) I'm new to this but I'm eager to help out.


    Been playing with the rom all day now. Here are some things I've noticed.

    Market Issues:
    Sometimes when installing certain apps I get errors. I was trying to install Google voice search and this is what I got...

    Error: Package file is invalid.

    A second attempt at installing results in an insufficient space error.

    Error: Error downloading "Voice Search". There is insufficient space on the device.

    I know there is enough space though. I'm attaching a logcat I ran while trying to install Voice Search. There are other apps but I don't remember what they were.

    Funky display glitches:
    Screen randomly goofs & displays static with vertical lines running through it. Only a battery pull will get it back to normal.

    Maybe it's some kind of display driver bug?

    When attempting to use LCD Density to adjust the display density the device froze for a minute or two and then the display went off. When I turned it back on I got the fuzzies and lines again.

    .wav files won't play:

    I don't remember if the original Vortex rom played .wav files, but I definitely can't now. They may just be unsupported idk.

    Did a test on stock rom and .wav files don't play so not an issue.

    Alternate signal display:
    I get some whacky numbers when I enable the alternate cell signal display signal text or signal text with dbm in Settings>CyanogenMod settings>Interface>Status bar tweaks>Alternate signal display

    Attached Files:

  21. BobZhome

    BobZhome Well-Known Member

    The "insufficient space" issue is a Market issue...not rom. It's happening with other phones also. To fix, move the 01mvdalvik file out of init.d, located here: /system/etc/init.d/01mvdalvik, clear market cache and data, reboot recovery, wipe cache/dalvik_cache, reboot.
    The screen issues are a "Work In Progress"...the kernel is still in it early stages, it needs a lot more work. This is going to be a slow process, in that a) it's time consuming b) I have real life(job & family) c) I build for a bunch of other phones.
    The audio/camera maybe a permission issue, that hopefully will get fix with the next build in a few days.
    Logs that show the problems are greatly appreciated. I don't own this phone, so I need detailed feed back in order to try to fix things.
    geofferey likes this.
  22. geofferey

    geofferey Well-Known Member

    Is there a better way to provide you with logs? How would you go about testing & providing logs if you were doing so for another developer? I wanna provide you with the best information possible. Your rom is the first that I have actually tested and provided ANY feedback on, so I'm not sure I know how to go about doing it properly. I appreciate all the hard work that you are putting into this. I couldn't possibly imagine how hard it really is. :D
  23. bolski

    bolski Well-Known Member

    Man, I'm jealous! I just moved from the Vortex to an X2 and you guys now have CM7 for the vortex.

    Of course, no reason for me to go back! ;) Still, it's great to see this phone is getting some love and support. It was my first droid.
  24. BobZhome

    BobZhome Well-Known Member

    Most of time I do a logcat.
    To do logcat, open 'terminal emulator', or 'adb shell' from connected PC. Then type:
    logcat > /sdcard/log.txt

    Press home (not back) button and try to reproduce the problem. When finished, go back into terminal emulator and press vol-down key then 'c' to stop logcat. Then copy the /sdcard/log.txt file to your PC. Then either post the file directly or upload to pastebin.com & copy the link to it here.
    kappacat and geofferey like this.
  25. kappacat

    kappacat Well-Known Member

Share This Page