Root 2.1 -The Easy Way-


Thread Status:
Not open for further replies.
  1. suhel28

    suhel28 Well-Known Member


    This Tutorial was posted on XDA.[COLOR]

    EDIT : NICK has confirmed its working..
    TESTED MYSELF AND ITS WORKING YAY :D

    THE COMPLEX METHOD HAS THE HTC BLACK THEME (AND ITS COOL)
    THIS METHOD HAS THE SONY ERICSSON STOCK THEME

    Download these files:





    X8 Android 1.6







    Unpack it on your computer and delete the "system.sin".
    Unpack "x8rooted.img", "busybox" and "unyaffs" to SDcard.

    You need 1.6 with root on your phone. (see below)

    before you proceed any further make sure your phone is not mounted on your pc i.e. turn off usb data transfer

    STEP - 1
    Use "adb shell" to connect to your phone and become su:

    STEP - 2
    Copy "busybox" and "unyaffs" to /data/local/tmp.

    STEP - 3
    chmod the files to make them executable:

    STEP - 4

    Remount /system as writable:

    STEP - 5

    Switch to busybox shell:

    STEP - 6

    Remove /system. It's normal to get errors because of the "lost+found"-folders. Ignore the errors.

    STEP - 7
    Unpack pre-rooted image to system. It should output "end of image" if it finishes correctly.

    Your phone won't boot anymore now and it will crash as soon as you try to use it - that's normal! Go to next step.

    Just remove the battery and the usb-cable from the phone, then re-attach the battery.
    Flash 2.1-kernel (without system.sin !! kindly add the loader.sin file from 1.6firmware files as its missing in the 2.1 rus firmware ) using the flasher-tool by Bin4ry.

    The phone should now boot, although the first boot can take a little while. If you get into a boot-loop or you just see the white sony ericsson logo (not the green one after the animation) for several minutes, it probably didn't work and you have to start over again by flashing 1.6.


    --------------------------------------------------------------------------------------------


    APP2SD (AGAIN FROM XDA)

    CREATE PARTITIONS

    SD card partitioning - XDA-Developers

    THE PROCESS

    Connect your phone to your pc and mount the sd card.

    Extract all the file from app2sd2.1.zip to the root of your sd card.

    Make sure to unmount the sd card before continue the next step.

    Attached Files:


    Advertisement
    :
    darkdaz, Gompedyret and peeter55 like this.
  2. rosered

    rosered VIP Member VIP Member

    Let me know when it has been tested and I can add it to the sticky.
  3. jporch316

    jporch316 Well-Known Member

    Thats the easy way!!!! Id hate to try the hard way
  4. coman_nick

    coman_nick Well-Known Member

    I'd like tyo add that for step 8 (reflashing the 2.1 kernel) i recieved an error "file loader.sin not found. skip...". Just copy the loader.sin from the 1.6 firmware.

    BTW, this metod works.

    LE: I'd buy you a beer if I could. :)
  5. Blitzkri3g

    Blitzkri3g Well-Known Member

    So with this guide we ll end up with a rooted 2.1 X8 with apps2sd enabled?
    Damn,I feel really lost.I dont have a clue as far as rooting a phone in any way is concerned!
    N.
  6. coman_nick

    coman_nick Well-Known Member

    It was first time for mee too. If you have any problems:
    1: Ask for a solution
    2: Don't worry, there's no posibility to brick your phone (at least that's what I heard)
  7. peeter55

    peeter55 Member

    ok but pls where can i get adb shell?
  8. suhel28

    suhel28 Well-Known Member


    yes the loader.sin is missing in the rus folder.. forgot to mention.. lol

    whats LE???
  9. suhel28

    suhel28 Well-Known Member

    no APP2SD is not available you need to follow the instructions I've posted in the complex method

    PS : ask nick if its working?
  10. coman_nick

    coman_nick Well-Known Member

    LE = Later Edit :)

    Peeter, just search for adb in the files you downloaded here. From what I remember (I'm not at my computer) it should be in superoneclick and in the bin4ry flasher.

    BTW Suhel, could you please post a picture of your HTC BLACK THEME please? I'm seriously curious.
    peeter55 likes this.
  11. suhel28

    suhel28 Well-Known Member


    I'll be going home today and than am gonna post a tutorial on Framework and than I'll give you all the screenshots and stuff
    coman_nick likes this.
  12. coman_nick

    coman_nick Well-Known Member

    A lot of screenshots please :) I already have it but i don't know IF to install it. And trial and error is out of the question because I'm at the office today and don't have admin permission on my pc to use ADB.
  13. suhel28

    suhel28 Well-Known Member

    [​IMG]

    this is not mine got it from xda.. I'm such a copy cat loooooool
  14. coman_nick

    coman_nick Well-Known Member

    well, I can do something like this with LP (except the icons on the status bar). I was actualy interested in the menu items (if it's black background). So if it's not too much, I'll still wait for some pictures from you.
  15. suhel28

    suhel28 Well-Known Member


    yes the background is blackish and all..

    I guess you like black things

    goth or emo :eek: by any chance???

    :D:D:D:D

    :p
  16. coman_nick

    coman_nick Well-Known Member

    :) NoOoOoO! God forbid .. I hate those guys (no offence to others). But however cool stock is, I like to change it just because I can. :) But it HAS to look good.
  17. vince_junior

    vince_junior Well-Known Member

    hi...new here....it will be my first time to root my x8....just have a few questions:
    1. for app2sd, i need to create partition on my sd card?
    2. will the contents of the sd card be erased when i create the partition?
    3. do i need to backup the contents of my sd card?
    2. can i still use the packaged 2gb sd card?

    thanks!
  18. coman_nick

    coman_nick Well-Known Member

    Hi,

    1. yes
    2,3,4 Buy a new card! Seriously! The stock is very slow. From what I know Suhel uses a class 4, which is a little better than stock so ask him if class 4 is ok. Recommended is class 10, WAY better than stock. However, you can go in between (class 6).

    And BTW, did someone who uses app2sd create a swap partition? If you did, do you see any difference?
  19. Blitzkri3g

    Blitzkri3g Well-Known Member

    I just got a class 4 16GB SD Card so I ll try rooting 2.1 tonight!
    Wish me luck! /,,/ :)
    N.
  20. Blitzkri3g

    Blitzkri3g Well-Known Member

    You ll probably lo to death but I really need help.
    So,I have adb files on a dir and open a command prompt.
    Whats next step by step?
    I typed O:\Android\R00t_Related\R00t.The.Easy.Way\adb>adb shell su
    and got in reply that Permission denied.
    So please help me.I obviously dont know what I m doing here... :D
    N.
  21. vince_junior

    vince_junior Well-Known Member

    i think i need more time to study....as i'm still in the office, i decided to just do it next year...lol.....but my main concern now is how to uninstall some pre-installed apps that i don't need, to free up some space....i understand i have to root my phone first to be able to do this.....can anyone please help me.....(i dont know if there's a thread to this before....sorry)....or do i have to go through the same "rooting" process?

    thanks in advance....
  22. emcp

    emcp New Member

    Had a problem, got it fixed, so i might aswell add something informative

    the exact error you will get when removing the system folder is the following

    thanks for the tut
  23. suhel28

    suhel28 Well-Known Member

    Just check your phone when you Su... your phone will be asking permission.. allow it
  24. suhel28

    suhel28 Well-Known Member

    that error is like a false alarm
    :)
  25. Blitzkri3g

    Blitzkri3g Well-Known Member

    OK OK! Ignore my last post. :p
    Got it to boot after flashing the 2.1 Rooted Rom! :D
    Now off we go for the next step!
    JIT Recovery blah blah... ;)
    Thanks for the tutorial and all the help.
    I m still not sure how it worked,but it did.
    The ADB shell part didnt work after the 2-3 times
    and suddenly worked even though I really hadnt change anything.
    Anyway,talk to you all later!
    N.
Loading...
Thread Status:
Not open for further replies.

Share This Page