Root achieved!


  1. ZombieBear

    ZombieBear Well-Known Member

    DISCLAIMER: This is for the original ICS firmware that was on the device when it was first releases. I don't think it'll work on JB. Attempt at your own risk.

    Thanks to the wonderful guys at XDA Developers, you can have full root access on this wonderful device that is the Acer Iconia A700!

    It is not a one click root and definitely NOT for the faint of heart.

    I had to attempt multiple methods and change some of the code on the scripts to get it, but I finally have root on my device.

    Here are the instructions with a copy of the last modded script I ran to finally achieve root:

    Pre-requisites:

    Download and install the A700 drivers from the Acer site (IMPORTANT, the ones Windows installs by default won't work with ADB)

    Install the Android SDK (Android SDK | Android Developers)
    Go to the installation directory
    X86 Systems: C:\Program Files\Android\android-sdk
    64-Bit systems: C:\Program Files (x86)\Android\android-sdk
    Run the SDK Manager (With admin privileges or it won't work)
    Install the Platform-tools component

    Step 1: Unlocking the bootloader
    You will need to unlock your bootloader with the instructions found at:
    Unlock bootloader - xda-developers

    Step 2: Achieving root
    Open up a command line with Admin privileges and navigate to the folder where you unzipped the "A700 Root.zip" file

    Run the command RunToRoot.bat

    The device should reboot a couple of times in the process.

    NOTE: If you just try to run the RunToRoot.bat file without being in a terminal, it will fail as it won't be able to locate the files.

    -----------------------------------------------------------------------

    I take no credit for the methods utilized to root the device, I simply modified the scripts and compiled them in a method that worked in my system and that I could distribute to other people looking for this.
    All credit for the methods used for rooting got to the wonderful people at XDA Developers, particularly those in the thread Full root for A700 and A701 tablets - xda-developers
    Make sure to thank them if you found this useful

    Attached Files:


    Advertisement
    :
    Fiege and Atma like this.
  2. EddyBarzoon

    EddyBarzoon New Member

    Thnxs finally a method that worked on my A700 android 4.04:)
  3. ZombieBear

    ZombieBear Well-Known Member

    No problem man, glad it worked properly
  4. Ianrobbie

    Ianrobbie New Member

    Any idea if this would root my a700 on 4.1.1?
  5. masmgt

    masmgt New Member

    I downloaded the Android SDK package and followed the instructions for unlocking bootloader. The A700 showed on the computer in windows. The DOS command adb reboot-bootloader failed repeatably. No device.

    So, I tried skipping that and going directly to fastboot oem unlock. I got "waiting for device", but nothing I did with the A700 registered.
  6. redbone110

    redbone110 New Member

    I will try this. I hope to get the newest operating system soon
  7. ZombieBear

    ZombieBear Well-Known Member

    Hey guys just a heads up this was when the device was still running ICS. There's guides to root JB on the xda forums, but I haven't bothered to test them, been running the stock JB firmware and had no issues

    I updated the first post to clarify this. I'll see if I can try one of the JB methods at some point and post a new guide
  8. OMIGHTY1

    OMIGHTY1 New Member

    Any way to get this working on JB? I can't boot to anything but fastboot and APX, and I'm running out of options. :p
  9. sbdk

    sbdk New Member

    Hello

    I followed the steps I think ... at least something happened ...

    In the mittle of the screen with green letters, the acer logo.

    And in the top ... Bootloader version JB-653b343 (unlock mode)

    Is there any way to get back on track ...

    PLZ ...
Loading...

Share This Page