1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Root and Unroot for Stock 2.3.6(for devs and power users)


  1. bads3ctor

    bads3ctor Well-Known Member

    I made zips for myself to root and unroot the new TU 2.3.6 stock GB and I was not going to release them but I have decided that they might help other developers so here they are:

    tu_root_ - Minus
    tu_boost_unroot_ - Minus
    tu_sprint_unroot - Minus
    This ^^^ Sprint unroot zip is untested.

    Quick instructions: Odin this: tu_CWM_recovery - Minus
    Make sure you pull the battery right after the phone reboots or your newly flashed CWM will disappear when GB boots all the way.

    Boot into CWM and flash tu_root.zip. Reboot into GB and install Superuser and update su and busybox. This zip also prevents stock GB from overwriting CWM with stock recovery.

    If you want to return back to stock 2.3.6, flash the unroot zip for either Boost or Sprint. YOU MUST HAVE THE STOCK KERNEL FLASHED FOR THIS TO WORK CORRECTLY. It will unroot 2.3.6 and upon reboot, stock recovery will be back. Then if another update comes along you can just flash the ota and it should update fine.

    Advertisement
    :
  2. Seansung

    Seansung Active Member

    s3ctor, will the tu_root return a non rooted 2.3.6 phone to stock or will it keep all apps/data untouched and just root the phone?

    My wifes phone lost root when she updated to 2.3.6 and I have been looking for a way to get her rooted again on 2.3.6 without erasing her apps/data... :cool:
    521solutions likes this.
  3. BLuFeNiX

    BLuFeNiX Well-Known Member

    I'm sure it won't touch anything else. Otherwise it wouldn't be very useful...
  4. bads3ctor

    bads3ctor Well-Known Member

    tu_root will root a Boost or Sprint Stock 2.3.6 and only changes 1 stock file but that 1 stock file(install_recovery.sh) will be enough to not allow an update from the carrier. For this reason, I made the unroot zips...they will return your phone back to a stock state that will allow carrier updates. They delete all the files needed for rooting and then return install_recovery.sh back to stock so on next reboot, CWM will get overwritten back to stock recovery.
    Seansung, smith058 and penguinrepair like this.
  5. fatnickd1

    fatnickd1 Active Member

    Ok, I did the CWM and told it to install the tu-root zip. That all worked fine. I've had superuser on this phone before, because I used one click root. But that was before I had to call boost and have them do a technical ticket to fix my text messaging. They unroted me remotely somehow. I used one click again but forgot to take out the SD card. So, now the Bat I run On one click says it works, but I'm not rotted. I did your thing and the phone starts and says Andriod in the begining, so that worked. All the apps that need root still say that i don't have root. Not sure what to do. Thanks. I don't know how to update the su file and busybox once I flashed the TU-Root zip. Is that causing this?
  6. Rick1488

    Rick1488 Well-Known Member

    will this work on 2.3.4?
  7. bads3ctor

    bads3ctor Well-Known Member

    Run Superuser and there is a place to update su and busybox. It will also tell you if you are rooted or not.

    Hmm...tu_root.zip probably would root 2.3.4 but I'm not sure about the unroot zips. My guess is that it would unroot you but not overwrite CWM on next boot.
  8. Rick1488

    Rick1488 Well-Known Member

    Sorry, I didn't explain I want my device unrooted as I still cant get the ota update as I need to have a bum at a Boost store look at my device to make sure it hasn't been modified before replacement. I guess Samsung sucks as I gave no hint I did anything to it unless I missed something when they had it for repair and sent it back to me as "replace component" but the phone wasn't touched as it still has a shit load of issues.
  9. chrisc_8107

    chrisc_8107 Well-Known Member

    Nothing exists at the root, unroot for boost links.
  10. gpotvin

    gpotvin Active Member

    The links don't work on the phone. You need to dl on a computer and move it to your sd card.
  11. gpotvin

    gpotvin Active Member

    Glad your still with us bads3ctor. We really needed some more devs over here and you have been great :). You brought us a bootable cm7 and much more. Keep up the good work. I will try to help as much as I can with my limited experience.
  12. fatnickd1

    fatnickd1 Active Member

    the tu-root zip says I'm rooted in CWM, but I'm still not showing root with other apps. In superuser I see update SU so I did. Kinda not working. I wound up doing a factory reset, :( and trying your pathway again. Still says I'm rooted after I install the app in CWM, but No dice. it says android still on start up, but not really rooted. I just want Adfree to work right. Please help more. Thanks.
  13. bads3ctor

    bads3ctor Well-Known Member

    If Superuser updated su and busybox successfully then you are rooted. If Superuser says something else during update of su and busybox, then post it's output.
  14. jfcooley

    jfcooley New Member

    double post.
    apologies
  15. jfcooley

    jfcooley New Member

    I am having the same problem with my wifes tu.
    I ran the tu root and cwm says rooted. Once rebooted and trying to update the binary for su i get "failed" and "Legacy" in red.

    Have tried uninstalling and reinstalling su with no affect. Have downloaded and tried the su update fixer with no change as well.a

    su preferences menu shows
    Superuser v3.07 (41)

    Su binary vnull


    when trying to update:
    Downloading manifest....okay
    Parsing manifest....okay
    Latest version = 3.0.3.2
    Checking installed version = legacy
    <tapped to update>
    Fixing database...okay
    checking for busybox...okay
    Checking current install path...failed
    Failed to find currentlyy installed su binary.
    Update cannot continue.

    cwm is installed and remains through reboots.
  16. strtrcr87

    strtrcr87 Member

    i found out what to do, go to the superuser website (androidsu.com/superuser/) and download the zip (Superuser-3.0.7-efghi-signed.zip) then put it on the sd card and boot into cwm and install zip from sd card and that should work.
    ChoDroid and jfcooley like this.
  17. Slikno420

    Slikno420 Well-Known Member

    Do you need the ops file when doing this? Or is the odin file the correct ops file?
  18. ruinevil

    ruinevil Member

    Has nothing to do with Odin or download mode (vol down+camera button+power). This is used in recovery mode (vol down+menu button+power), and loaded from your sdcard.
  19. Slikno420

    Slikno420 Well-Known Member

    So just to make sure I'm understanding this correctly and don't. Screw my phone up in the process of trying thiis, I. The root on my sd card and apply the update?

    Sorry new guy to this, had a motorola triumph that I rooted but I just did the one click and installed cyanogen mod, :( that was so much easier.

    Edit: I forgot to add that I am running a 100% stock unrooted tu.
  20. fatnickd1

    fatnickd1 Active Member

    I got the Same Red Legacy has the Guy with the wife. Only, my update stops two steps after his at md5sum... FAIL. I also did has the one dude said and manually updated the SU now I'm at 3.0.3.2 with no apps that need root recognizing I have it. Everyone hold on it's going to be ok. I have faith in these guys. Thanks again for the work everyone puts into this.
  21. fatnickd1

    fatnickd1 Active Member

    Got it!! Installed the wrong SU update. I have gingerbread. Thanks a million. Woot Woot! Have a good Weekend. again thats androidsu.com and manually install the SU update Zip in CWM. Finally, this odesy is over. :D NO MORE ADDS!:shakehands::rock::hello::car:
  22. Slikno420

    Slikno420 Well-Known Member

    Question, when you odin the file, are you using the one package with a .ops file or how are you doing that exactly?
  23. dalton4life

    dalton4life Member

    Hi.

    I'm having a couple of problems with this. First I can't seem to get into recovery mode all the time. I'm pressing power and volume - and release at Samsung screen, but most of the time it just boots normal.

    Second, when I did get into recovery the zip files would not install. Could someone tell me what's going wrong on both ends? Thanks.
  24. Loota

    Loota Well-Known Member

    I've had that happen with not booting into recovery but I always chalked it up to not pressing the button firmly enough. Everytime I retry it and make sure that I'm pressing firmly it works.

    As for the files not flashing please make sure you are flashing as a zip from your sd card (that's a cwm option) if you are flashing it as a restore it will not work because this is an update zip not a recovery file.
  25. xaelith

    xaelith Well-Known Member

    EDIT: Never mind. Thanks for the video tut, Loota :) A very big Thank you for all your hard work, bads3ctor :D and a Thank you to anyone else who had a hand in this.

    Sorry for the bother, but it's been a while since I've rooted a phone.

    -I put tu_root.zip in the root of the sd card, and before I odin CWM?

    -Is the tu_(sprint/boost)_unroot the stock kernel, or is there another file I need in addition to this?

    -If it hasn't been done already, I'll gladly test it for you :)

    Thanks in advance for any and all help.
Loading...

Share This Page