1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Root and wifi tether


  1. TeachMe

    TeachMe Well-Known Member

    Has anyone rooted this phone and got a wifi tether to work ? I use foxfi with my transform ultra.

    Advertisement
  2. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    double b26 likes this.
  3. TeachMe

    TeachMe Well-Known Member

    Thanks so much what root method did u use ?
  4. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

  5. animania260

    animania260 Well-Known Member

    I can't get the Tether for Root users you pointed to LordVince, to work either. I've tried FoxFi and almost got it working but don't think it supports our device. So I downloaded the app you specified above and the settings you specified (I do get one error on app start saying ad-hoc mode failed but this doesn't seem to be an issue since you have it working in infrastructure mode?)

    It doesn't advertise the SSID and I see no option to advertise, which really isint a problem either... but also doesn't work when I manually add the network.

    Though I have't tried it on Windows or any other device, I was just using Fedora 17 (KDE) to test it out.

    So you did get it to work from the Rush LordVince?

    Edit: I just seen the other thread actually. Probably just something I'm missing.
  6. Lordvincent 90

    Lordvincent 90 ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ Guide

    You have to turn on the 'reload WiFi drivers' option
    animania260 likes this.
  7. animania260

    animania260 Well-Known Member

    Thanks but it's on by default. It's probably just a setting (maybe something linux/fedora doesn't pickup automatcially?) I only tickered with it for a few minutes. Once i mess around with it some more I’ll report back.
  8. Slayer72

    Slayer72 Well-Known Member

  9. animania260

    animania260 Well-Known Member

    I got it to work with the Wifi tether for root users app like above.
    Not sure what the problem was but at first the SSID wasnt getting picked up by the laptop and then I would add it manually and it didint work. Then it did pick up the SSID but I think it detected it as a secured network (i dont set a password on it so its just an open wifi network).

    I use it alot now though no problem. Let me know how it works for you on Mint though as well.
  10. Slayer72

    Slayer72 Well-Known Member

    Ok was also gonna say you need to set the profile to wlan0 and the 2nd selection to auto and it should work fine...
  11. Slayer72

    Slayer72 Well-Known Member

    Ok I can confirm that Wifi Tether does work in Infrastructure mode on Linux Mint here as long as you have the Profile set to ICS/JB (wlan0) and the method set to Auto... working really well here to :D

    For anyone having problems reconnecting to your phone's hotspot through Wifi Tether, try disabling networks and then reenabling networks in Linux and it should connect at that point...

    Hope this is helpful to everyone... :)
  12. double b26

    double b26 Well-Known Member

    first off, what and where is the infrastructure mode option at? or does setting those other two settings make it go into that mode automatically?

    second, i keep getting a 'what the hell!!! your phone took over the wifi and tether shutting down NOW' error after the screen times out and i turn it back on... or just after 5-10 minutes of it setting with screen off, but data in use.

    on a hunch, i turned off the 'Power saving' option in the settings menu (of the rom, not wifi tether app). so far, about 5 minutes, and several screen cycles, it seems to be sticking. we'll see!

    EDIT: Nope! made it about 10 minutes, then the boot again. i noticed that the wifi was showing that it was on again in the drop menu, and i had just turned it off. so i dug around and found the 'connection optimizer' in the advanced wifi menu. shut it off. waiting to see how it goes this time. (power saving still off too)

    EDIT 2: Looks like the Connection Optimizer was the problem. its been up and running for about 15 minutes now, and no problems. ill report back if issues arise!
    Tesla5 likes this.
  13. Slayer72

    Slayer72 Well-Known Member

    Just an FYI, but my phone has power saving enabled as well as the connection optimizer and haven't had any issues using Wifi Tether for an extended amount of time, but hey not every phone is the same, hope you have good results from here on out... :thumbup:
  14. PoPo Is Legit

    PoPo Is Legit Member

    What Ive found with my phone is be sure wifi is disabled before you switch on wifi tether. Also I had to disable access control...Now it works like a dream. (Samsung Rush Boost Mobile)
    Tesla5 likes this.

Share This Page