Root broken after firmware update


  1. xenofan

    xenofan New Member

    Verizon has pushed a firmware (I believe, it was small) update ahead of the ICS release for the Rezound. It updated without a prompt. I know I'm not yet ready for ICS (backing up, restoring stock recovery, etc.), however now my root is broken. Is there an easy way to restore root?

    I used the Scotty's noob guide and so have rooted (well, had) stock w/ amon-ra recovery permanently installed. I tried going through recovery and just installing su/superuser again, but that didn't help. Do I just need to use a newer version of SU?

    Android Version: 2.3.4
    HTC Sense: 3.5
    Software Number: 2.01.605.12
    Kernel Version: 2.6.35.13-gf1931dc
    Baseband version: 0.95.00.1118r, 0.95.00.1223r
    Build Number: 2.01.605.12 CL252791

    Sorry if this is a repost, I couldn't find the answer in the threads I looked through.

    Advertisement
    :
  2. xenofan

    xenofan New Member

    Turns out the answer was there after all. I just needed to flash the newest SuperSU

    [16.07.2012] SuperSU v0.94 - xda-developers

    So anyone with the new firmware but not yet ICS can just do that it seems to regain root.
  3. scotty85

    scotty85 Guides Guide

    dont bother rerooting just yet. you have only had the small "preparation" update,so you are still on GB. you still have the big ICS update to look forward to.

    plus,we have now heard there is another update coming,to unleach the rezounds capabilities as a world phone :)
  4. MamboKing

    MamboKing New Member

    Guys, I have the same issue as Xenofan above...

    I used the Scotty's noob guide and so have rooted (well, had) stock and I believe I had amon-ra recovery permanently installed also.

    Android Version: 2.3.4
    HTC Sense: 3.5
    Software Number: 2.01.605.12
    Kernel Version: 2.6.35.13-gf1931dc
    Baseband version: 0.95.00.1118r, 0.95.00.1223r
    Build Number: 2.01.605.12 CL252791

    Sorry, but I am very new to this, you stated you fixed it by "flashing the newest SuperSU" ... I have no idea how to do this. Can someone help me out. I am NOT interested in ICS yet (waiting for others to use it for a while)... I just need to get Root back. I am currently S-ON.

    Can someone help me get root back again? How do I "Flash the latest SuperSU" if that fixes the problem?

    I would also really like to do this without losing all my data / applications if possible.

    MamboKing

    [16.07.2012] SuperSU v0.94 - xda-developers
  5. scotty85

    scotty85 Guides Guide

    if you used my guide,you just need to folow steps 2 and 3 again.but this time use the superuser file linked above instead of the one you used before.(actually since youre still on GB the one you used before prolly will still work,so you prolly could reflash it)

    be aware that your phone will continue trying to update itself.

    what you may want to do:
    -follow step 2 directions to temporarily launch amon recovery.
    -flash superuser
    -make a nandroid backup
    -reboot
    -allow the ICS and worldphone updates
    -after the world phone update,you follow step 2 directions for temporaryily launching amon again,if you really dont want to stay on ICS(its important that you dont do this from a permanent installed recovery)
    -restore your backup
    -flash the "new firmware patch"
    -reboot

    you will then be on the new firmware,but running your current gingerbread backup,and should be safe from updates :)

    you may find ICS to be quite acceptable. i personally prefer it over GB. if not,you can always revert back to your backup :)
    phxfireguy likes this.
  6. phxfireguy

    phxfireguy Well-Known Member

    Thanks Scotty! You truly are a Godsend! I flashed mine back to Ginger after the update due to multiple issues after the update. Thanks Again!
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    glad to help,happy things are better for you now :cool:
    phxfireguy likes this.
  8. thornev

    thornev Well-Known Member

    I just upgraded from CleanROM to the latest stock ICS. I rooted (unlocked successfully and then used AmonRa to install superuser), then installed SuperSU per above, and TiBu claims it still cannot get root privileges. What am I doing wrong?

    Also, after powering down, VOL DOWN + Power doesn't take me into Fastboot or recovery. Why is that?

    I am S-Off.
  9. scotty85

    scotty85 Guides Guide

    you prolly have "fastboot" checked in settings/power,wich will prevent hboot from powered off unless you pull the battery for a few seconds. uncheck it and it should act normally.

    you arent doing anything wrong with root and titanium. amon is not installing an ICS compatible superuser. flash superSU in recovery,and you will be rooted :)

    you may have to wipe data in titanium if you still get errors after installing the new superuser.
    thornev likes this.
  10. thornev

    thornev Well-Known Member

    Scotty - Thanks. I did install superSU from the store (no downloadable file from the link you provide) and I did uncheck Fastboot in Settings. However, superSU says it needs to update and it fails to update. Maybe that's a clue? I tried uninstalling the superuser that Amon installed and updating superSU, but the update still fails. Hmmm. superuser won't uninstall ! Had to disable in Apps. Still can't get superSU to update. And TiBu still can't get root rights.

    I didn't do a battery pull. Instead I've been powering off by holding down the Power button. Maybe I didn't do these things in the correct order? Did a battery pull and now I can get into Fastboot.
  11. thornev

    thornev Well-Known Member

    I decided to start the update process from scratch i.e. re-installing the stock ICS via PH98IMG.zip. My steps:

    1. adb reboot bootloader
    2. hboot finds PH98IMG.zip and installs.
    3. reboot
    4. skip setup.
    5. unlock and reboot. (didn't have to re-unlock, this step skipped)
    6. enable USB debugging, disable Fastboot in Settings.
    7. boot Amon recovery.
    8. install superSU zip, not from Play Store.
    9. reboot.

    Will report back here the outcome.... BINGO ! It was indeed that I had to install superSU zip from my SD card. Scotty scores again !
  12. scotty85

    scotty85 Guides Guide

    Installing.from.the market won't work,as you do not have a matching binary. You'll need to.download and.flash in recovery.

    The link.is there,I promise... It's labled "clockwork installable zip" .right under the market link
    thornev likes this.
  13. thornev

    thornev Well-Known Member

    I saw the Clockworkmod installable. Since I had Amon installed I ignored it. Thanks, Scotty.
  14. scotty85

    scotty85 Guides Guide

    Anytime sir :) it would definately be less confusing if he woukd have called it a "recovery flashable zip"

    After its installed and.working,you.shoukd be able to.update it from the market with no.prollem.
Loading...

Share This Page