Root Droid 1 2.2.1


  1. I have a Droid 1 that was rooted by a friend. Then I got the ota 2.2.1 update. My root is now broken. I still have superuser on my phone. I tried to root 2.2.1 with superoneclick and nothing changed, I still cannot use my rooted apps. I tried using the new z4root and it keeps freezing, saying "the application z4root has stopped unexpectedly.Please try again." I've tried serveral time, reboot, and still nothing. I'm not techy so I need some major help.

    Advertisement
  2. teddyearp

    teddyearp A guide with guides Guide

    Either one of those should work. Make sure you have usb debugging enabled.

    menu -> settings -> applications -> developement

    good luck

  3. It is and has been enabled
  4. dasanman69

    dasanman69 Well-Known Member

    Try unrooting with superoneclick first then rooting. Even though you lost root with the update it didn't undo or get rid of su and that might be your problem.
  5. I tried using superoneclick to undo it and nothing. And I don't know how to get rid of superuser, it doesnt uninstall like normal apps
  6. teddyearp

    teddyearp A guide with guides Guide

    Well then I've got two guides that will do it for you the 'manual' way. One is actually here at this site, so that in essence makes it three. Anyways, here's the one that uses RSD Lite 4.6:

    Root Droid 1 - regardless of OS version - Droid Forum - Verizon Droid & the Motorola Droid Forum

    And then I have one that uses the same hack that z4root and superoneroot use, but you apply it yourself manually:

    Root the A855 without RSD Lite + make it ROM ready

    I suggest you read which ever one a few times to get the feel of it, then if you still have questions ask. Finally when you're ready, print it out so you can check off the steps as you go.

    good luck
  7. Funintegras

    Funintegras Active Member

  8. KSutherland

    KSutherland Member

    I just tried rooting and Super One Click didn't work for me but SOUP OR ROOT did yay, I'm rooted, now what, .... lol
  9. icecold

    icecold Well-Known Member

    If you don't want to use the RSD Lite method of flashing a .sbf file, you could try flashing a stock image from ROM Manager. Some people have had issues of it not removing the SuperUser icon, but since you plan on re-rooting I don't think it should be an issue.

Share This Page