Root failed after step 15, adb shell


Last Updated:

  1. brandonpaz

    brandonpaz Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    73
    Likes Received:
    4
    So I decided to manually root my phone, initially I had a device come up and everything was really smooth until step 15

    1: Code:
    cd C:\android-sdk-windows\tools
    2: Code:
    adb devices
    If you've been following this guide you will see your phone's serial number. If you get "device not found" error, you either need to make sure you the drivers were properly installed or make sure you enable USB debugging AFTER you connect the USB cable. Continue on once you get the proper phone serial output.

    3: Code:
    adb push asroot2 /data/local/
    4: Code:
    adb shell
    5: Code:
    chmod 0755 /data/local/asroot2
    6: Code:
    /data/local/asroot2 /system/bin/sh
    You should see an output that says:
    $ /data/local/asroot2 /system/bin/sh
    [+] Using newer pope_inode_info layout
    Opening: /proc/857/fd/3
    SUCCESS: Enjoy the shell.
    #​
    Now for a few last commands.

    7: Code:
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system
    8: Code:
    cd /system/bin
    9: Code:
    cat sh > su
    10: Code:
    chmod 4755 su
    You are now officially rooted. A few more steps and you will have flashed the recovery image.

    11: Code:
    exit
    12: Code:
    exit
    13: Code:
    adb push recovery-RA-heroc-v1.5.2.img /sdcard
    Pushing is equivalent of copy the file to the root of your sdcard. By the time you finished reading this it should be done. You'll know its done because the ouput will say something like transferred X bytes in X secs.

    14: Code:
    adb shell reboot
    This will cause the phone to restart automatically. Wait till it is fully booted to continue.

    15: Code:
    adb shell
    Now I receive the following Error:
    error: device not found

    I tried to reboot the phone but there was not change.

    I tried the following
    C:\android-sdk-windows\tools>adb kill-server

    C:\android-sdk-windows\tools>adb devices
    adb server is out of date. killing...
    * daemon started successfully *
    List of devices attached

    I was hoping to get my original device listed, but I still have nothing.


    Thanks much in advance, and Yes I did search the forums.

    I appreciate the help

    Brandon
     

    Advertisement
  2. brandonpaz

    brandonpaz Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    73
    Likes Received:
    4
    Sorry to bother you all, I figured it out, after the reboot it turned off USB debugging and that was the cause of the issue. I turned it on and once again I could pull up my device. I tried to delete this post.

    thx all
     
    mysticmead likes this.
  3. mysticmead

    mysticmead Well-Known Member

    Joined:
    Nov 29, 2009
    Messages:
    1,348
    Likes Received:
    175
    glad you got it figured out. also glad that you posted the fix so it might help others in the future.
     
  4. tech1greek

    tech1greek Active Member

    Joined:
    Apr 27, 2010
    Messages:
    33
    Likes Received:
    2
    I ran into the same scenario, perhaps the sticky should be updated as well. Requires a little troubleshooting which is an acquired talent. ;)
     
  5. ccapasso

    ccapasso Well-Known Member

    Joined:
    Jan 12, 2010
    Messages:
    1,127
    Likes Received:
    278

    It is in there :). Just not right after step 15, it is actually stated to make sure that USB Debugging Is still enabled. However, I'll go ahead and add it in as a tip :p
     
  6. brandonpaz

    brandonpaz Well-Known Member This Topic's Starter

    Joined:
    Apr 29, 2010
    Messages:
    73
    Likes Received:
    4
    Thanks all, Hopefully my misfortune will help out some others.

    paz
     
  7. Jero

    Jero Member

    Joined:
    Jan 27, 2010
    Messages:
    23
    Likes Received:
    0
    I just got stuck on Step: 18...

    It says:

    C:\android-sdk-windows\tools>adb shell
    # su
    su
    # cd /sdcard/
    cd /sdcard/
    # flash_image recovery recovery-RA-heroc-v1.5.2.img
    flash_image recovery recovery-RA-heroc-v1.5.2.img
    flash_image: not found
    #

    Any ideas? The flash image is in the tools folder.

    Help!
     
  8. ccapasso

    ccapasso Well-Known Member

    Joined:
    Jan 12, 2010
    Messages:
    1,127
    Likes Received:
    278
    Please don't do this. There is absolutely no need to make repetitive posts about the same thing. I answered your question already in the post you made.
     

Share This Page

Loading...