Root for ALL/SBF Flash/Unlocking Bootloader - Updated 25-July2011 05:18 PST


  1. james27007

    james27007 Look into my Eye VIP Member

    OK I think I see the confusion. Most android phones have memory in 2 places, the internal phone (which you cannot really access without root and you cannot edit) and the external sdcard (the sdcard you put into the phone). Well on the Atrix, you have 3 locations. The internal phone where the system and data files are (again which you cannot really access without root and you cannot edit also you are not backing up these); the internal sdcard, this is also internal memory but is memory set aside like an sdcard, this was done so AT&T did not need to include sdcards with the phone and then you have the external sdcard, this is one your purchased and put into the phone. Gingerbreak erases the internal and external sdcards, it does not touch the internal phone memory. If you open the app called "files" you will see Internal phone storage (that is the internal sdcard not the phone's system or data files) and SD card which is the sdcard you purchased and put into the phone. So you are backingup your sdcards not the phone

    Since Gingerbreak will not touch the internal memory (well it does add root) your settings and everything is ok. The issue is if you have apps installed on your sdcard, they will not work until you put the files back on the internal sdcard.
    ultradroid likes this.
  2. Kilgore Trout

    Kilgore Trout Active Member

    Stupid question I'm sure, but why does it say an external sd card is needed? I don't see where it is used in the instructions.


    I know these are about as simple instructions as you can get, but I'm still kind of nervous and feel like I might do something stupid.

    Edit: Never mind. Rooted succesfully and easily. Also I didn't loose any data which is a plus.
    james27007 likes this.
  3. ultradroid

    ultradroid So many android phones... VIP Member

    Damn J - you really know your stuff! I never *knew* that until I read your excellent explanation. Thanks for the insight, much appreciated! :):)

    -Mike
    james27007 likes this.
  4. camp0s

    camp0s New Member

    Wow, needless to say, that info was truly what I was looking for! Thanks for encouraging other user to ask!!

    I know I could go a little off topic, but I'd like to say that I'm not succesfull running Gingerbreak on my Android 2.3.1 MID816 tablet. It runs forever, but isn't able to root the tablet.

    I think I'm missing "su" program from system/bin/ or system/xbin.. what do you think? all the other method that rely on a .bat file signal that "su" is not found when working via ADB on the tablet shell.

    Have you got other info to spare?

    Tnx.
  5. james27007

    james27007 Look into my Eye VIP Member

    Just to make sure, you do have USB debugging enabled and you have the gingerbreak app installed? First try uninstalling it, rebooting the tablet, install again, reboot one more time. Then try running gingerbreak.

    If this does not work since I do not have an MID816 so I do not know if the following works or not. Also I hate to have you check out another site but it is the only thing I could find HOW DO I ROOT THE MID816 2.3 VERSION - SlateDroid.com this is the only thread that says it will root . Let me know if it works out.
    camp0s likes this.
  6. camp0s

    camp0s New Member

    Hi, ys, Gingerbreak is installed, and USB debug is on (I can see when I connect the usb to pc, in the notification area).

    Gingerbreak is just spinning the icon forever, but nothing is happening :\

    I also follower your instruction to remove, reboot, install, reboot, apply root for gingerbreak but nothing more has happened so far.

    I'm going to ask a few question on the other forum, thanks for pointing it out! :)
    james27007 likes this.
  7. brawndo

    brawndo Active Member

    Took me literally ten minutes to root with this method and enable sideloading. And I also only lost my SD card stuff. Hellz yeah.


    edit: nevermind I lost my internal memory, not my SD card data. All of that stuff was saved.
  8. irieone

    irieone Well-Known Member

    I think I want to root my phone. I want to overclock and all that, I am not vary smart when it comes to this kind of stuff so I don't want to F myself. Can I unroot back to stock if I get over my head with it??
  9. james27007

    james27007 Look into my Eye VIP Member

    Yes, there is an unroot option, but unrooting will not undo any other mods you do; so make sure you undo any mods before you unroot.
  10. kilasix9

    kilasix9 Well-Known Member

    Glad it worked for you. :cool:
  11. aklbeach

    aklbeach Member

    so a quick question since this requires an sd card to do. How big does the card have to be. i have an old 1 gig card is that big enough
  12. james27007

    james27007 Look into my Eye VIP Member

    I have not tried it that small (did you ever think we would consider 1 GB small? lol) anyways, as far as I know even the 512MB cards work. If it does, please let us know
  13. aklbeach

    aklbeach Member

    well i don't think i'm going to try the 1 gig. Because it is just an extra card i have. i already backed up up my 32 gig. I was going to use the other one but i'm not sure do I need to use the same card in my phone as the one that i use to root it. do i also need to remove the sim card for the process. here goes nothing
  14. aklbeach

    aklbeach Member

    Alright Great Success. I have root verified with busy box. now still running 2.2.2 4.1.83. Another question. I would like to get ginger bread, should i get it here ( Download Android 2.3.4 Gingerbread for Motorola Atrix 4G - BriefMobile ) Or should I wait for the update that is coming this month. And if I get it from the update, will I lose root. And if I lose root will I be able to get it back.
  15. aklbeach

    aklbeach Member


    Hey I downloaded that sq lite and I looked through the files and didn't find that .mksito file. I would really like to get to enable the non market apps any help with that.
  16. james27007

    james27007 Look into my Eye VIP Member

    There are threads over at XDA on how to get root and such with that build. But to be safe, look here: http://forum.xda-developers.com/showthread.php?t=1159385 that is the best version that I can see

    Look for "Settings Storage" com.motorola.android.providers.settings (it has a gear icon next to it) then click settings.db and then settings. Then look for line 107 and change from 1 to 0
  17. aklbeach

    aklbeach Member

    well i found those files but when i click on them i just got a file path message and all I could do is click on it and say ok which brought me back to the previous screen. oh well I just downloaded an app that gave me the option for non market apps and it worked.

    But I'm still wondering is should I wait for att to push this update out soon for gingerbread or just do it on my own. And if I get it from them will I lose root and can i get it back
  18. pinballd

    pinballd New Member

    Newbie to the forum,first ever post, hope I'm in the right place,just dumped my iphone for an Atrix it is a branded AT&T ,so it was unlocked then rooted ok but I still cannot share my carrier (FIDO) data connection to work on the phone itself.I tried configuring the APN to the carriers specs but it appears the phone's AT&T OS is blocking me from accessing my FIDO carrier data connection.
    anyone know what I need to do so I can use the data network on my phone & share my internet data connection via bluetooth or wifi to my samsung galaxy tab?
    thanks to all , Pinballd
  19. fugitive

    fugitive New Member

    Hi everyone ..
    I have a friend who has an AT&T atrix that he bricked .. How? well, he got the latest Gingerbread update .. but that didn't have arabic, so he needed root, then he couldn't so he tried Downgrading to the older version where he knew how to root ==> Bricked it. :(

    So here is my first question, that would seem quite dumb .. is there any known normal solution? he gets the black screen with failed to read something at 0x00.. or so .. then the phone turns off right away ..

    My second question is, if there is no Straight forward solution, I was thinking about something deeper, like replacing the bootloader memory altogether (if I could locate it, and was able to Remove it, find another Similar memory, write another Bootloader on that new Memory .. ohh, too much Ifs :( ) ??

    it seems pretty hard, at least lacking the appropriate hardware tools to do so; the ones on the production line of Motorola .. you know :)
    The reason I am thinking this is because I believe Moto can NOT do anything in this phase, except if they send the mobile back to production; can they ?!!

    he will try to get it to the support in US soon (of course you guessed am not in US, right ;) ) ..
    well, waiting for your reply :)
  20. jared1234

    jared1234 Well-Known Member


    You could always try to flash a different radio! Try flashing 1.77.30P from xda and then re enter your apn settings
  21. james27007

    james27007 Look into my Eye VIP Member

    As far as I know, you cannot fix that kind of a brick, more information here: [WARNING] Hard Brick with Official 4.5.91 Update - xda-developers
    fugitive likes this.
  22. fugitive

    fugitive New Member

  23. james27007

    james27007 Look into my Eye VIP Member

    As far as I know AT&T knows to look for that issue and knows it is from hacking (which voids the warranty anyways). I would keep an eye on XDA to see if there ever come up with a fix.
  24. tea1988

    tea1988 New Member

    wont let me past step 1, tried to navigate to c:/moto-fastboot-win32, not recognized as valid internal or external command
  25. speedyrev

    speedyrev New Member

    Could use some help. I have the phone in fastboot mode, hooked up usb to a windows vista computer. When I type in the first line to flash the preinstall, I get...
    <waiting for device>

    What am I missing?

    ***Edit*** I had to uninstall the motorola software, then go to the motorola website and download the latest drivers. - fixed!
    james27007 likes this.

Share This Page