Root for Huawei Ascend Y H866C


  1. TnPizzaMan

    TnPizzaMan New Member

    Ok, so more searching into this has produced something interesting. While looking up any possible way to further identify similar model phones in hopes of piecing together a root method for the H866C, I found my way to the fcc.gov site where a search of the FCCID number QISM866 (found under the battery of the H866C) turned up something interesting (click HERE to perform your own search for QISM866 as I was unable to link directly to the search results) apparently the H866C and the M866 have the same exact FCCID! Those more versed in such please correct me, but I assume that means they are basically the same phone.

    Now I have to ask - is the root process dependant on the software or the hardware? Or both? Does the root process depend on what phone is being rooted or the carrier specfic software or a combination of these?

    Attached Files:

  2. anathematized1

    anathematized1 Active Member

    Proof of my prior statement.

    I can quickly give you more information on the phone...

    From "About Phone":
    Model: H866C
    Android version: 2.3.6
    Baseband version: 109808
    Kernel version: 2.6.38.3-perf android@localhost #1
    From inside the battery area:
    Tracfone Wireless, INC.
    Model: Huawei H866C
    FCC ID: QISM866
    Date: 15-09-2012
    Part No.: GPHUH866CB
    It is sold in the store as "Huawei Ascend Y100".
  3. TnPizzaMan

    TnPizzaMan New Member

    well im not really sure what it proves, but its stands to reason that if the root process is hardware specific, then the end may be in sight (and there was much rejoycing). However if its more software or carrier dependent or a combination of things, then I understand giantpune's point of needing the device in hand. If you stop and think that the phone i basicaly a handheld computer running a linux distro, then it could take all sorts of sortware - but weather it will still work as a phone with your carrier may be a different animal all together. - im kinda guessing on all this, so am I on the right track in my assumptions? anyone?
  4. anathematized1

    anathematized1 Active Member

    I would think rooting would have to do more with specifically how the operating system is set up, which would be done in relation to hardware.

    I have the Android SDK/Eclipse, I can try and see if it will let me see into the system itself...

    It won't let me run a system trace on my phone. I can't obtain the UI hierarchy because the phone doesn't have a high enough API (level 16 required). I can use the file explorer and it does show permissions, I'm pulling the files now... I dunno if it'll block my ability to pull from the system folders, but at the very least I can see what the permissions are and the structure...

    EDIT:
    I was able to pull all the files I think. 86.4 MB total in size, but I don't know what of these files would even be relevant...
  5. anathematized1

    anathematized1 Active Member

    So, would that work at all, having all that information PLUS all the files from the phone? Could somebody be able to build a root just with that?

    I mean it may as well be as good as having the phone and if you have the FREE Android SKD/Eclipse, you can emulate the phone exactly...
  6. diceman1000

    diceman1000 Well-Known Member

    have you guys tried the rooting method for the ascend Q?
  7. anathematized1

    anathematized1 Active Member

    There is no root method (at least that I can find) for the Ascend Q (M660), which isn't even CLOSE to the same thing as the Ascend Y100 (H866)...

    What do people normally need to develop a rooting method for these phones, because, as I said before, I pulled ALL the system files from my phone using the Android SDK...
  8. scoc1973

    scoc1973 Member

    anyone found anything on rooting this phone? h866c? its trash without root! any advice pklease!!!!
  9. taylorb1031

    taylorb1031 New Member

    I have been watching this thread hoping someone would find a way to root this phone but it looks like it may not happen for a while.
    Anyway why does the poot method not work on this phone it works on the ascend 2 from straight talk which was also impossible to root because of the same signature error.
  10. anathematized1

    anathematized1 Active Member

    Because it's a different signature I would imagine. I've not heard of this method but I found it and will test now...

    EDIT:
    Tested, doesn't work. Poot, after finally updating and installing everything, gives a "fatal error" and closes, won't even give the button to "poot" the phone.
  11. barak1001

    barak1001 New Member

    Not sure what is happening on your phone, but Poot doesn't give a fatal error on my h866c. It gives error code 87 and fails to root the phone, but it never crashes.
  12. anathematized1

    anathematized1 Active Member

    Either way, it doesn't work.

    Also, I do have all the system files pulled from the phone still.... does anyone know if this is enough to build a root method from?
  13. barak1001

    barak1001 New Member

    The Guy you were arguing with earlier (GiantPune) wrote the poot one click root method. I'm almost positive he's the only person to reply so far that has a clue as far as the answers you are looking for. Too bad you chased him off!
  14. anathematized1

    anathematized1 Active Member

    I wasn't arguing and if he ran off, that's his deal.

    You don't go in acting pretentious as if everyone is supposed to know exactly what the process is for something so esoteric. That's like a surgeon getting pissed that you don't know some minor detail of their job.

    I'm sure he's not the only person who knows how to root phones.
  15. phaedruscny

    phaedruscny Member

    Certainly he's not the only one, but he was the one who got the earlier Huwaei m865 rooted,which had been quite difficult for many others.... I'd have to agree that he was probably our best hope.
  16. anathematized1

    anathematized1 Active Member

    I doubt that.

    First, I doubt I "ran that guy off" or whatever.

    Second, I don't think anyone is really paying much attention to this topic except those who have this particular phone because I've asked two or three times now whether or not simply having all the system files from the phone would be enough to make a root and anyone who at least knows something about rooting beyond how to use a guide to root your phone or why you should root would have been able to answer that question and nobody has.

    Third, there are TONS of people doing this stuff on a bunch of different forums.

    Fourth, if nothing is happening, I'm going to find out exactly what rooting is (as in the fine details) and figure it out myself (though that may take a while).

    The reason that the m865 took so long to get a root method for is because, relative to other Android phones, hardly anyone uses it.
  17. phaedruscny

    phaedruscny Member

    Be that as it may, giantpune is active on this particular forum, and here we are... On this forum... Anyhow, you certainly live up to your name, as I believe you have quite well cursed this thread.
  18. raymealer

    raymealer Well-Known Member

    has anyone gotten closer to a working root
  19. trippseventeen

    trippseventeen Active Member

    i have tried everything,im trashing the project in favor of samsung devices,much simpler:)
  20. Gmash

    Gmash Well-Known Member

    Did you install superuser and reboot the phone? I got an error message on my Mercury but it was still rooted. You have to get superuser from Google play for it to work.
  21. Gmash

    Gmash Well-Known Member

  22. scoc1973

    scoc1973 Member

    Tried (Article : How to Root Any Android Device Manually) yet? anyone..
  23. rezario55

    rezario55 Member

    tried it up to the part that requires linux, downloaded ubuntu and got completely lost.
  24. Scarsketch

    Scarsketch Well-Known Member


    great link there bud. as soon as i get a live run distro ill work on rooting the h866c! Im versed in linux and pretty sure i can get the h866c rooted. hit me up for any questions

    it is not a lengthly process however i need to get back to missouri to get the live run booted. anyone willing to pay for postage i can help them out with this root.
  25. zeon

    zeon New Member

    I've tried to root via linux and when in recovery mode on the phone it does not allow to move them files into system because there is no download mode. Anyone else have any ideas?
Loading...

Share This Page