Root Help


  1. EequalsMChammr

    EequalsMChammr New Member

    I have a Droid X. I've successfully rooted it, installed ROM Toolbox, Bootstrap Recovery (System Recovery), ROM manager, and the Liberty 3 mod. I wiped my data and cache and flashed the mod. However, when I tried to boot into recovery mode to install it, I ended up at the Motorola M which didn't go away. I wasn't able to get into the 2e recovery menu like I should've and I don't know why. It stated I needed a Superuser binary update, but Superuser couldn't connect. Any help would be much appreciated

    Advertisement
    :
  2. Goose306

    Goose306 Active Member

    Are you stuck at the Red M now? Can you get in to any recovery at all?

    What recovery were you using? Was it the Droid 2 Bootstrap or the Droid X Bootstrap?
  3. EequalsMChammr

    EequalsMChammr New Member

    As far as I know, it was the droid x bootstrap. A friend used it on his droid x2 to get into the 2e recovery. The only one I can get into is the 3e recovery mode. When I tried, I ended up getting stuck at the red M until I pulled the battery
  4. trophynuts

    trophynuts Well-Known Member

    Installing a custom Gingergread ROM (This will work for 2nd-Init GB Kernel ROM's as well)
    -Go to Settings -> Applications -> and check the box next to "Unknown Sources" and then press OK on the warning that comes up. (this allows you to install non-market 3rd party apps on your phone)
    -Put Droid 2 Bootstrapper and the ROM.zip file that you want to install on the root of your SD Card (main SD CARD directory, not in a folder)
    -Install Droid 2 Bootstrapper
    -Open Droid 2 Bootstrapper and select "Bootstrap Recovery"
    -It will request Superuser Permission, allow it and then select "Reboot Recovery"
    -Phone will reboot, use your volume buttons to move up and down in the menus and the camera button to select. Back button will move you to the previous menu.
    -Wipe data/cache (always do when installing a new ROM)
    -Then select install from zip
    -Select zip from sdcard
    -Select the ROM zip that you downloaded and it will install (about 10 mins)
    -Once you reboot into the ROM proceed to setup your phone as you want.


    you can use the DX bootstrap but you have to uncheck usb debugging.
  5. Goose306

    Goose306 Active Member

    Droid X2 recovery doesn't work on the DX, the X2 recovery is a special recovery that had to be made for *that* device only.

    Having that installed on your X may have jacked some stuff up. You want to use Droid 2 Bootstrap in the Play Market if your on Gingerbread.

    https://play.google.com/store/apps/details?id=com.koushikdutta.droid2.bootstrap

    Install, choose Bootstrap Recovery then Reboot Recovery (assuming you are on stock Gingerbread, correct?)

    If that doesn't work that 2e Recovery probably caused some issues in the bootstrap that an SBF would be needed to take care of.
Loading...

Share This Page