Root Instructions for Samsung Galaxy Prevail 2


Last Updated:

  1. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    First, a shout out to Toxx Synn who provided this solution, I'm just providing a walkthrough for the masses :)

    First, turn on Unknown Sources:
    Go to Settings > Security and scroll down:
    [​IMG]

    Second, install Framaroot on your phone:
    https://www.dropbox.com/s/d0pamxnyxoogqnh/Framaroot-1.5.1.apk

    Third, open the Framaroot app.
    Then, pick the 2nd root method (this worked for me)
    [​IMG]

    Then, Reboot your phone and when your back at your homescreen, install SuperSU from the Play Store:
    https://play.google.com/store/apps/details?id=eu.chainfire.supersu

    I hope this helps anyone searching for how to root this device
     

    Advertisement
    DaisFlaque, kdzzzy, Slayer72 and 8 others like this.
  2. creed10

    creed10 Well-Known Member

    Joined:
    Apr 4, 2012
    Messages:
    421
    Likes Received:
    60
    yep. tried it myself. fast, reliable... can't get much easier :D
     
  3. rbheromax

    rbheromax Well-Known Member

    Joined:
    Sep 22, 2012
    Messages:
    1,927
    Likes Received:
    440
    Mod sticky this :D
     
    Slayer72 likes this.
  4. beercorpse87

    beercorpse87 Member

    Joined:
    Jan 24, 2013
    Messages:
    14
    Likes Received:
    2
    This is the one i used good stuff.now to wait for cwm. :p
     
    Slayer72 likes this.
  5. STEELER70

    STEELER70 Member

    Joined:
    Feb 12, 2012
    Messages:
    13
    Likes Received:
    3
    Yes it says root successful cause i used the root checker pro but it also says super user and superSU not installed. So which superSU app do i now use? Cause i saw no Super User capabilities granted? And i lost my factory installed YouTube app when i unrooted it using the framaroot app 1.5.1 and rebooted again. No YouTube! Where the heck did it go???
     
  6. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    Download SuperSU from the play store.
    Dunno what to tell you about your youtube app, just DL that from the play store too
     
    Slayer72 likes this.
  7. downthemachine

    downthemachine Developer Incognito VIP Member

    Joined:
    Dec 30, 2011
    Messages:
    2,940
    Likes Received:
    1,725
    kdzzzy, Slayer72, HwDzBeAzT and 2 others like this.
  8. McSwain

    McSwain New Member

    Joined:
    Aug 20, 2013
    Messages:
    1
    Likes Received:
    0
    My first and previous smartphone was the Prevail. Loved it. I Had problems with charging and the Prevail 2 was available. I bought it on the 29th or 30th of July and was rooted a week later. I used Framaroot 1.5.3 apk.
    I opened it. Selected the Gandalph exploit and rebooted. Then I went back a second time and selected SuperSU, and rebooted again.
    I show no SuperSU, but all root apps that I have downloaded have worked. Titanium Back Up was first.
    Patiently awaiting the works of this staff and cwm. Found a download for this particular phone at their site, but for some reason I'm unable to put it on my phone.
    Thanks!!!!!!!
     
  9. EnthusedLearner

    EnthusedLearner New Member

    Joined:
    Aug 30, 2013
    Messages:
    1
    Likes Received:
    0
    I followed step by step, got to the superSu app, it tells me I need a binary updated? Then superSu says it fails. What am I doing wrong?
     
  10. hitesh123

    hitesh123 Well-Known Member

    Joined:
    Aug 7, 2013
    Messages:
    362
    Likes Received:
    81
    From Framaroot app you can install superSU
    same process for RING !
     
  11. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    you're not rebooting before installing SuperSU and trying to update the binary
     
  12. bill236

    bill236 Active Member

    Joined:
    Nov 15, 2011
    Messages:
    36
    Likes Received:
    5
    I have rooted 3 prevails, love the hell out of them , mine just died, charger failure, got the Prevail 2 and want to root it as well, when you say download it to your phone, go to the web and download or download to PC and copy it over to the phone? did the phone part and sd card and can't find the apk anywhere, type in the web address and do iy that way? I'm really new to all this, I need WiFi, I use opengarden, love it works great, but need root access, please any help at all would be great. thanks.
     
  13. wolfemcbane

    wolfemcbane Active Member Contributor

    Joined:
    Nov 20, 2012
    Messages:
    39
    Likes Received:
    4
    Nope you don't have to use a pc at all for this one just get the frameroot apk and run it unknown sources checked and poof root. We just need a good rom or even better cwmod
     
    bill236 likes this.
  14. bill236

    bill236 Active Member

    Joined:
    Nov 15, 2011
    Messages:
    36
    Likes Received:
    5
    I did the download and hit install, how long should it take to install, this has been running for about 30 minutes, says it's installing, unsure of how long I should let it go before I try it again. Thanks for the info, is anyone working on a rom or cwmod?
     
  15. wolfemcbane

    wolfemcbane Active Member Contributor

    Joined:
    Nov 20, 2012
    Messages:
    39
    Likes Received:
    4
    Maybe 20 seconds?? I remember there being two options for installation try both of them? Make sure unknown sources and usb debugging are enabled. Otherwise maybe it is a bad apk download try clearing the data, uninstalling, redownloading, and installing the apk with the above settings for sure applied. Should work..

    Btw just in case:
    If you dunno what I mean, go to home screen, click bottom left (3-rowed looking) menu button
    Click settings, scroll to security click it and make sure the unknown sources box is checked.

    Now back arrow key back to settings... scroll down to developer options click it, enable developer settings via top right button on screen then scroll down to usb debugging. Not to talk down to you but sometimes its the simplest answer to a problem
     
    bill236 likes this.
  16. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    Joined:
    May 13, 2010
    Messages:
    23,597
    Likes Received:
    14,436
    hey guys,

    i know y'all excited about rooting your phone, but lets keep this thread on rooting your phone. if you are rooted and want to post questions after the fact then lets just create a new thread.....i had to do some cleaning up and keep things on topic.

    if you have any questions please let me know.

    thanx,
    ocnbrze
     
    kdzzzy and Koumajutsu like this.
  17. showzen

    showzen New Member

    Joined:
    Nov 20, 2013
    Messages:
    1
    Likes Received:
    0
    Can someone please reup the apk link as it is no longer working. Thanks in advance.
     
  18. soto arias

    soto arias New Member

    Joined:
    Dec 9, 2013
    Messages:
    1
    Likes Received:
    0
    Por me telefono no puede istalar root para abrir una aplicasion de whatapp
     
  19. hitesh123

    hitesh123 Well-Known Member

    Joined:
    Aug 7, 2013
    Messages:
    362
    Likes Received:
    81
  20. Slayer72

    Slayer72 Well-Known Member Contributor

    Joined:
    Dec 22, 2011
    Messages:
    2,666
    Likes Received:
    955
    Just a heads up as far as the CWM for Prevail 2 on the Rom Manager app/CWM website, DO NOT try to install that on your Prevail 2, that one is for the Samsung Galaxy Rush which I do own, the reason for it being named that on the CWM site is because that is what Samsung code named the Rush, so please DO NOT try installing that on your Prevail 2 to avoid possible brick...

    I'll make a new thread explaining this and hopefully a Mod can sticky it... :p
     
  21. TishaB

    TishaB Member

    Joined:
    Jul 19, 2014
    Messages:
    7
    Likes Received:
    1
    this just froze my phone completely and I followed the instructions to a tee. it turns on and then the touch does not work it just sets frozen on my home screen???????????????
     
  22. Quadraphone

    Quadraphone Member

    Joined:
    Jun 10, 2014
    Messages:
    12
    Likes Received:
    2
    Hi bill236!

    After installing Framaroot 1.9.3, you need to select the Gandalf exploit, followed by a reboot.

    Secondly, you need to then install SuperSU from the Google Play store. A reboot following this step probably wouldn't be a bad idea.
     
  23. mikeybotta44

    mikeybotta44 New Member

    Joined:
    Oct 28, 2014
    Messages:
    1
    Likes Received:
    0
    Okay, so the original link shows Framaroot 1.5.1. The second link shows like 1.6.1 and then the guy above me is saying 1.9.3.

    Which one is it? Does it matter? I am totally lost because of this. :confused:
     
  24. hitesh123

    hitesh123 Well-Known Member

    Joined:
    Aug 7, 2013
    Messages:
    362
    Likes Received:
    81
    You can use any version, which ever you get just use it, it won't brake anything
     
  25. mirandarose777

    mirandarose777 New Member

    Joined:
    Jan 7, 2015
    Messages:
    2
    Likes Received:
    1
    this isnt working for me
     
    adinayisrael likes this.

Share This Page

Loading...