[ROOT] Kindle Fire HD 7"


  1. PRallday168

    PRallday168 Well-Known Member

    This is a guide on how to root the 7.1.5-7.2.2-7.2.3-7.3.0 updated versions of the KFHD.



    ALL CREDITS GIVEN ON BOTTOM OF OP :)



    Downloads are at bottom aswell :)





    [​IMG] I am in no way responsible for what you do to your phone. Use at your own risk!







    Make sure you have the Kindle Drivers.



    Bin4ry's Tool has ADB so no need to install seperate.




    Make sure you your Device has Enable ADB on.

    Settings>Security>Enable ADB.








    1.install the drivers for the Kindle


    2.unzip Root_with_Restore_by_Bin4ry_v17


    3.run the RunMe.bat


    4.choose the normal method


    5.if it says it didnt work its fine it will still root.


    6.there will be a part where you have to select restore so pay attention to that.


    7.after that your device will be slow after it reboots, this is normal.


    8.once the device is rebooted run the RootQemu.bat file and choose Root


    9.it will connect through ADB and reboot your device


    10.after it reboots it says to press any key to continue.


    11.keep doing this until it says completed.


    12.Your device will be rooted after the proccess and once the final reboot is done
    you should have SuperUser and access to system files.





    DOWNLOADS



    QemuRoot: https://dl.dropbox.com/u/88552195/QemuRoot_v1.0.zip



    ADB Driver Kindle HD: https://dl.dropbox.com/u/88552195/Kindle_Fire_HD_ADB_Drivers/Kindle Fire ADB drivers.exe



    Alternative Kindle Fire HD Drivers: https://dl.dropbox.com/u/88552195/kindle_fire_usb_driver.rar



    Bin4ry's Root Tool: https://dl.dropbox.com/u/88552195/Root_with_Restore_by_Bin4ry_v17.zip



    Thanks to

    sparkym3 for his root tool


    Bin4ry for his root tool


    natorus87 for finding this method out for us


    ENJOY!

    Advertisement
    :
  2. KX4SAM

    KX4SAM Well-Known Member

    I keep getting permission errors.
  3. PRallday168

    PRallday168 Well-Known Member

    did your kfhd update ? version 7.2.2 or 7.2.3 if it did then this root no longer works. ill link the root thread for 7.2.2 and 7.2.3
  4. PRallday168

    PRallday168 Well-Known Member

    working on a step by step guide to root the kindle HD 7.1.5,7.2.2,and 7.2.3! will update tonight.
  5. PRallday168

    PRallday168 Well-Known Member

    OP Updated :D
  6. sooxny

    sooxny New Member

    Everything went smoothly until QemuRoot Step 4 -Rooting...

    It stops at 2996 KB/s (380532 bytes in 0.124s)

    theres no progress... what's wrong?
  7. PRallday168

    PRallday168 Well-Known Member


    what software version are you running on the kindle fire ?
  8. ezryder

    ezryder Member

    Worked!! Awesome - thanks!
  9. PRallday168

    PRallday168 Well-Known Member

    no problem!! glad it worked for you.! :) mind telling me what version you rooted ? i want to know because alot of people are having trouble with different versions and different methods of rooting
  10. TurtleRunner

    TurtleRunner Well-Known Member

    Thanks OP, its time to get my friends HD to play with.
  11. PRallday168

    PRallday168 Well-Known Member

    haha! be careful, might want to get your friend a factory cable just in case you brick his HD ;)
  12. elfrider

    elfrider New Member

    I've followed the above instructions to the letter but have been unable to root my kindle fire hd 7" running version 7.2.3. I run the runme.bat file (step 3), select option 1 but it just says ' connect device in usb debugging mode now' and sits there without any further prompts. The device has adb enabled, I've installed the kindle fire drivers, have java se7 installed and have android sdk installed with ' Google usb drivers' installed through it. I've tried it on a laptop running xp and Windows 7, both just sit at the same point in root_with_restore v17. I would really appreciate any ideas on this one, thanks.
  13. PRallday168

    PRallday168 Well-Known Member

    check and see if your pc reads your kindle fire hd by going to device manager under kindle it should say android composite adb interface. also people have been having problems with 3.0 usb ports, make sure your plugged into a 2.0 usb port.
  14. Inksaver

    Inksaver Well-Known Member

    I have used Bin4ry's Root Tool successfully to root my Sony Xperia Tipo phone

    However I get the same problem as elfrider on my Kindle with version 7.2.3 firmware.

    If you put bin4ry tool in an easy location e.g. c:\root (make a new folder) then run a cmd prompt as administrator and then:

    cd c:\root
    stuff\adb devices

    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    emulator-5554 offline

    I can only get a device listed at all by running device manager, deleting both kindle fire->android composite ADB Interface and portable devices->Kindle, re-boot, reinistall adb driver, connect kindle.

    Perhaps the keyword here is "offline"
  15. azwei

    azwei New Member

    I was also having trouble getting adb to see the device, even though Composite ADB Interface was there in the Device Manager. After much searching, I found that I needed to put 0x1949 in C:\Users\<my name>\.android\adb_usb.ini. Neither the file nor the directory existed on my system, so I created them both and put that number on a line by itself, saved the file, unplugged/replugged the Fire, and it worked!
  16. Inksaver

    Inksaver Well-Known Member

    Azwei you are a hero!

    Now playing minecraft (previously purchased on Google play store) on my Kindle Fire, which has SuperUser status!

    A couple of factors here:

    1) to produce the .android folder, Create new folder and name it ".android." (note the dots at beginning and end) otherwise you get an error regarding filenames needed. The final dot is removed by windows.

    2) the emulator-5554 offline message I was getting is due to having BlueStacks android emulator installed on my PC. It also causes multiple errors when trying to root the kindle. Solution either uninstall BlueStacks or use a different PC.

    I ran the bin4ry tool and it worked as expected, with the need to confirm a data restore on the Kindle itself, and it re-booted as expected.
    The Qemu tool did not seem to run correctly, but after a reboot, the SuperUser app was installed, so something must have worked.

    I followed this guide to install Google Play http://www.androidauthority.com/kindle-fire-hd-7-inch-install-google-play-store-123353/

    Thanks to all involved. Merry Xmas
  17. tearshade

    tearshade New Member

    For some reason the runme.bat isn't working.


    • I've tried running it regularly, and it says to connect it to usb using normal mode. I connect it and nothing happens.

    • I've tried running it as an administrator using normal mode, it goes through the regular steps but while it does it says "cannot find the path specified"

    • I've also tried running the .bat file through both the desktop, C drive itself, another of my drives, and even the kindle fire itself. No luck

    I've gone through this topic a bunch of times, doing everything everyone else has said with no positive results. I got the Kindle Fire for X-mas.

    My pc specs are:
    WIndows 7 Pro 64-bit
    AMD Phenom II X4 925
    ASRock m3a770de
    8 gb A-Data DDR3 1600 RAM
    Radeon 6870
    Boot drive is 120gb OCZ Agility 3
    Other drives are 320gb Western Digital, and 1tb Seagate

    Kindle Fire HD 7"
    System Version 7.2.3
    using cord it came with
    never been rooted

    This isn't my first time rooting/jailbreaking. I've already done 2 of my android phones and my iPhone 3GS. The iPhone was the most pain to do, and this seems to be the second lol
  18. Inksaver

    Inksaver Well-Known Member

    What do you get if you use a cmd prompt as I did in post 14:
    (Folder Location of adb.exe)\adb devices
  19. Ethix

    Ethix New Member

    Hey Inksaver.

    Congratulations on your Success. Unfortunately, ive been getting confused!

    id say im fairly good with computers, managed to successfully complete a number of workarounds and lift restrictions on devices. however this is getting me!

    i badly want to access my google play store like yourself.

    would you be a legend and possibly give a step-by-step, in laymans, on how you achieved your success haha..

    would be greatful i really would, same as you :)

    not sure where im going wrong, could you elaborate on the folders, and also elaborate on PRallday186's OP a little..

    for example,' install drivers for the kindle' where?

    also 'azwei' posted this:
    " I found that I needed to put 0x1949 in C:\Users\<my name>\.android\adb_usb.ini. Neither the file nor the directory existed on my system, so I created them both and put that number on a line by itself,"


    would you please do a fresh step by step to stop the confusion, got my kindle fire hd for crimbo.. and im not keen on the restrictions.

    managed to get adw lancher ex running on it.. altho.. ive not worked out how to change backgrounds yet.

    feel free to pm me, and ill be happy to paypal you a few quid for your time and effort.

    Sam :)
  20. tearshade

    tearshade New Member

    Here's what I get:
    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    C:\Users\John>cd c:\root

    c:\root>stuff\adb devices
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached
    D025A0A024360KLP device

    Funny thing is after I did that, the root worked! Thanks man, you're a savior.
  21. Inksaver

    Inksaver Well-Known Member

    @tearshade Glad you got it sorted

    @Ethix As requested I am currently writing a full idiots guide starting from the very beginning right through to installing the play store. I will post here ASAP

    Watch this space

    My (hobby) CV:
    z80 assembly language learned in 1981 to allow me to transfer software on cassette tape (Sinclair ZX81, Spectrum) to 5 1/4 inch discs
    CanDo programming (a precursor to Visual Studio) on the Commodore Amiga
    Visual Studio 6 (Visual Basic and C++) on Windows95
    Database programming
    Now getting to grips with Visual Studio .net and Java
  22. Inksaver

    Inksaver Well-Known Member

  23. sli4

    sli4 New Member

    Ok, I'm dying with this ADB business.

    I've followed every guide I could find on these forums and others.

    I'm running win7 have adb enabled on kindle fire 7 hd and for some reason every time I plug the kindle in device manager shows:
    "portable decices> Kindle"
    if I manually update drivers I can force it to switch to "kindle> "android adb interface"" drivers BUT can not get it to install the composite device as everyone else can.
    **in the idiots guide above, I can do all the prep but as soon as the steps say "plug in device" I get brick walled because I only get one or the other of the 2 items I should see in device manager (therefore - I can not use the rooting tools since my kindle wont show up properly in my devices/adb devices check)**
    it seems to always install EITHER portable device>kindle OR the android adb interface - I can't get both to show up as it says they should in some of the descriptions.

    Tried:
    -creating/editing the ".android" folder and ini file.
    - getting sdk manager and using the drivers from there. I've tried drivers from links in these forums and from Amazon help several times.
    -forcing installation of adb or mtp drivers
    -switching from usb hub/extender to usb2 directly in computer

    I'm assuming I wont see any devices listed under adb devices in cmd prompt until I get it to load the drivers as composite device.
    I go this to work on my father's XP computer for his nook, but can't figure it out for the Kindle on my Win7 set up.

    who has some great ideas?
  24. PRallday168

    PRallday168 Well-Known Member

    sorry to hear your troubles! try these alternative kindle drivers. make sure to uninstall the old ones by right clicking the device that pops up when you connect the kindle, both &quot;kindle&quot; and &quot;android adb interface&quot; and clicking uninstall,. reboot your pc and install these drivers here: https://dl.dropbox.com/u/88552195/kindle_fire_usb_driver.rar then connect the kindle and go back to device manager to see if Android Composite Adb Interface pops up.
  25. LoneStarRobin

    LoneStarRobin New Member

    PLEASE HELP! I am completely illeterate with all things technical. I have a Kindle Fire HD running version 8.1.4

    I want to be able to install google play games and adobe flash. I need, I'm begging for, step-by-step instructions for the technically impaired.

    Otherwise, I'm hating my fire. :-(
Loading...

Share This Page