:ROOT: Kindle Fire HD 8.9 Guide


Last Updated:

  1. imSHAD

    imSHAD Well-Known Member

    Ok first off I take no credit to any of this. Just sharing.

    All thanks to Bin4ry for his auto-root program and mdblaze on the xda forums for being a test subject.

    ::NECESSARY FILES::
    Bin4ry Tool
    Kindle Fire HD 8.9 Drivers
    NOTE: Make sure all the files from Bin4ry toolkit is extracted into 1 folder.

    1.Make sure your Fire has ADB enabled and Installation of 3rd party applications enabled.
    1. 3rd Party Applications: Setting\device\Allow Installaion [ON]
    2. ADB: Settings\Security\Enable ADB [ON]

    2. Uninstall your Fire's drivers making it an unknown device on your computer again. NOTE: If you have yet to connect your Fire to your computer you may skip this step.

    3. Install the Fire's drivers from the download and connect the device.

    4. Open CMD as administration (right-click\run as administrator)

    5. Now in command prompt you want to navigate to where you saved the bin4ry tool.
    For example I saved mine on my desktop so in the CMD window i typed
    C:\Users\Username\Desktop\Root <-- I named the folder it was in "Root"

    6. now Type in "stuff\adb devices" this is just to make sure your device is connected

    7. Type "RunMe" this will run the automated root tool. Type "2" for special mode since we are doing this on a tablet and "1" for root.

    8. The rest of the steps will be given in the command prompt window.

    SideNote: At one point the tool reboots your device and waits for it to reconnect. For my device it would turn back on but never reconnect. Just unplug it and plug it back in once it boots up if this happens to you too.

    IMPORTANT NOTE: YOU WILL RECEIVE ERRORS AND FAILURES BUT DON'T MIND THOSE> JUST KEEP PLOWING THROUGH AND YOU WILL BE ROOTED.

    Advertisement
  2. enenxx

    enenxx New Member

    i got it running until the last part.. when it reboot and boot up it doesnt detect, and when i plug out and plug in again it still couldnt detect, and suddenly it says done. When i see my device theres no superuser installed. :(
    Any idea how to check whether is it rooted?
    My device is kindle fire hd 8.9 running on version 8.1.3
  3. david688

    david688 New Member

  4. Lizzord30

    Lizzord30 Well-Known Member

    Is this confermed to work with 8.1.4? I was unable to get it rooted. It would connect and i would select special2 then root1 and would say tablet s then wont do anything after that.
  5. PRallday168

    PRallday168 Well-Known Member

  6. Lizzord30

    Lizzord30 Well-Known Member

    I was able to get it working! Had to use a different driver when the one linked here, and use option 1 not 2. I tried option one and it didnt work right at the end it didnt restart i manualy rested and it didnt have Root, When I did a factory reset and tried option 1 and this time it worked!
  7. PRallday168

    PRallday168 Well-Known Member

    glad you figured it out! :D
  8. Lizzord30

    Lizzord30 Well-Known Member

    Me too!! Its sooooo much better rooted! I really thought I would use it a while just to see how the custom Interface is from the Kindle..... But its not really that good, and amazon store sucks compared to Google Play. Really having a device unrooted is like owning a car but not having the keys to drive it :D:D:D With Nova Launcher on it, and google apps, its so much better! Altho I am having a wifi issue but not sure its related to rooting since I kinda had it before from time to time. It would connect for a while but then connect but not have internet, or cant connect just keeping trying to connect and maybe not getting a IP from the router.

    If anyone has the same problem with the drivers installing correctly these are the ones I used from this webpage that worked for me! The ones provided on this Tutorial didnt work for me.
    How To: Setup ADB on Windows 7 64bit (Should also work on 32bit)
  9. slim6596

    slim6596 Well-Known Member

    I got the drivers installed and adb working, but it can't find my Kindle. It doesn't show as being connected. Do I need to do a factory reset to get adb to see my device?
  10. scottmorse

    scottmorse New Member

    So, I rooted my Kindle Fire HD 8.9 with bin4ry's tool. It was a rough ride...I'm not as savvy as most of you. Root checker says I'm rooted. Good. I have superuser installed. I installed Go Launcher. But, it's still the same device. I can't do any more than I could before. Everything looks the same...acts the same. Still can't access Google play. What am I missing. Do I need a ROM? Help.
  11. PRallday168

    PRallday168 Well-Known Member

    The developers for this device are mostly on XDA. go here to this forum and ull find all the help you need! http://forum.xda-developers.com/forumdisplay.php?f=1999

Share This Page