1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Root Motorola Devour (EASY WAY)


  1. blazen-moto

    blazen-moto Well-Known Member

    I have several friends who have been asking how to root their devour.
    Its surprising enough that they still have the phone but the share my deep affection for the "silver brick."

    Ill just outline how to do it for those who don't want to go through the long laborious process.
    I have to warn you that you wont get the deep satisfaction that I got going about it the "long way" like I did.

    1) search the app "Universal Androot.apk V. 1.6.2 beta 5" on your devour's google browser.
    2) find a credible link and download and install the apk.
    (It should look something like an orange un-locked lock on your desktop)
    3) Open the app. It looks like the attached picture.
    4) Make sure Superuser for Android 1.5/1.6 is selected and soft root is not checked. also be sure to check generate log in /sdcard. Trust me. everything will run smoothly if you do.
    5) Finally, hit Go Root and let it do its thing.

    When you are finished you should see the superuser icon in you apps list.

    Enjoy your root.

    If you know how to install apks from the sd (which you should), here is a link for your computer: Software2Tech.com Download Universal Androot apk

    DONT WORRY!!! THE DEVOUR IS NOT CONFIRMED ON THE ROOTED LIST FOR THIS APP BUT IT DOES WORK!!!

    ~Moto

    Attached Files:

    • jpg.jpg
      jpg.jpg
      File size:
      21.4 KB
      Views:
      40

    Advertisement
    devour863 and kron0Trippr like this.
  2. kron0Trippr

    kron0Trippr Member

    thanks for this, sending it off to my friend who has a devour
  3. erickrocks1126

    erickrocks1126 Active Member

    Thanks for this, it worked. Has anyone done this and then done the permanent Motoblur bypass (instructions listed in another Devour thread)? The instructions to permanent bypass Motoblur say to do the manual root procedures except steps 26 and on. I'm not sure how far in those procedures that this Androot goes in the rooting process. Sorry for the newbish post, but indeed I am a new to Android/rooting and am trying to learn.
  4. p_025

    p_025 Well-Known Member

    As long as this process never restarts the phone it might be easier. After getting root, try typing "su" into the adb shell. If it works you'll get a # prompt. Then run the "mount -o etc" then the "rm" commands. If this thing does restart the phone, it'll perform its factory reset and you may lose root before you manage to delete the blur files.
  5. erickrocks1126

    erickrocks1126 Active Member

    Thanks, I'll give it a shot!

    EDIT: Just finished rooting using the Androot. Worked, but...when I try to use rootshell in adb I get "rootshell: not found". I'm assuming then that this Androot did the "rm...rootshell", which if I understand correctly in the manual root process for steps 26 and on is to remove rootshell. So...I'm guessing to be able to do this permanent motoblur bypass I then need to do the manual root instead and then do the process in this thread(?).
  6. erickrocks1126

    erickrocks1126 Active Member

    Update to last post: did manual root and then the steps to permanently bypass Motoblur. All seems to be working so far!! Thanks to all on the forum that posted these procedures to root and permanent bypass the annoying Motoblur!
  7. p_025

    p_025 Well-Known Member

    Like I said in my post above, use the "su" command, not rootshell. Androot isn't going to leave that kind of thing lying around. Rootshell is a serious security flaw if not removed, since it grants superuser permissions without the dialog box asking if you want to allow it.
  8. erickrocks1126

    erickrocks1126 Active Member

    p_025 -- thanks! I'll have to go back and finish the rootshell remove then. When you say that keeping rootshell is a security flaw, do you mean someone can just access my phone? I don't have a contract on the phone, only using it as a mini-tablet. Sorry for the newb questions...new to Android, first time rooting, and still on the learning curve ;-)
  9. p_025

    p_025 Well-Known Member

    If you're using Androot then don't worry, rootshell won't be on there. By security risk I mean apps could use it to gain root access to your phone without your consent or knowledge, which depending on the maliciousness of the app, this could be bad ****ing news. "su" is generally much safer, but is still risky to the inexperienced root user. Be wary of what you grant root access to.
  10. erickrocks1126

    erickrocks1126 Active Member

    Thanks again! As i've been exploring this more I see what you mean above. Also went back in and removed rootshell since I did the manual root.

    Right now I'm only downloading apps that are "safe" based on this and other forums, and reviews I've found on themed Google search of "Best apps after rooting". Even then it's only at the recommendation of "reputable" online sources like CNET or PCMag.

    Thanks again for all the info! Much appreciated!

Share This Page