1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Root my Samsung Galaxy GT-B5510 - Android 2.3.6


  1. iFLUSH

    iFLUSH Member

    Hello Android boys,

    I got a qeustion, i wanna root my Samsung Galaxy GT-B5510 with Android 2.3.6

    I tried so many things that i found on the internet and nothing worked, i hope you guys can help me!

    THNX!

    iFLSUH

    Advertisement
    :
  2. StoneBoyTony

    StoneBoyTony Well-Known Member

    Today I'll release signed update.zip including your phone
  3. iFLUSH

    iFLUSH Member

    Where can i find it?

    Greetz,
    iFLUSH
  4. StoneBoyTony

    StoneBoyTony Well-Known Member

  5. iFLUSH

    iFLUSH Member

  6. StoneBoyTony

    StoneBoyTony Well-Known Member

    You keep them press all together and don't relase them untill you see recovery mode. Home button on your phone is the one with the House.
  7. iFLUSH

    iFLUSH Member

    i will make a movie for you, maybe you can tell me what i do wrong.
  8. StoneBoyTony

    StoneBoyTony Well-Known Member

    This are the buttons you need to press and hold them to enter recovery mode.

    [​IMG]
  9. iFLUSH

    iFLUSH Member

  10. iFLUSH

    iFLUSH Member

    omfg, i iam using the wrong home button..

    ok i will try it!
  11. iFLUSH

    iFLUSH Member

    it worked, THNX!
    StoneBoyTony likes this.
  12. StoneBoyTony

    StoneBoyTony Well-Known Member

    Heheheh...I was having my fingers crossed...hope it will work. Now becouse you where the first test pilot now I can post the tutorial for your phone model. And one more thing avoiding the application ROM Manager many phones are bricked from that app. Good luck ;)
  13. tripsigg

    tripsigg New Member

    I was able to root my Chinese market Samsung B5510 with the tutorial. It took me several hours to do it. Getting into recovery mode was DIFFICULT and I started to believe it didn't exist on Chinese Samsung phones.

    Since I found this thread when looking at how to root my phone, I will leave my instructions here since it was slightly different.

    I had to press the power key first, take finger off power key and then hold Volume Up and Home button. Pressing them all at the same time did not work for me. I accidentally discovered this. I followed videos online and everything, but they were wrong for my phone.

    Secondly, releasing the volume up key before the home key results in it rebooting in reocvery mode. (That's why I got some much experience entering recovery mode! :rolleyes: ) Take finger off of the home key first and then Volume Up key.

    Once I got it into recovery mode and not rebooting, it took less than a minute to root the phone and reboot. :D
  14. korerek

    korerek New Member

    thanks it worked on my b5510:)
  15. Nicarmcel

    Nicarmcel New Member

    Hi guys
    i have been in all steps but its asking a code which i dont know can somebody help me?
  16. tschul

    tschul New Member

    Hi guys,

    ***sorry, I own the 5512 (wrong thread) in case there has been a firmware upgrade for 5510 too, please read on ***

    I followed the steps a couple of months ago and everything worked just fine. Now Samsung released this firmware upgrade which I managed to install after a couple of hours.

    Now, when I want to boot into recovery, there is a screen "Volume down to restart, volume up to install custom OS".

    And then it is stuck in ODIN MODE displaying "downloading, do not shut down target". Has anyone figured out how to get it rooted again?

    Thanks, cheers
Loading...

Share This Page