Root not working


  1. sega dude

    sega dude Well-Known Member

    I am running TG-Reloaded 2012-03-25. New root apps are not detecting the root. Existing apps I gave root access in the past still detect the root but not new apps? Is superuser not working right? Am I doing something wrong?

    Advertisement
    :
  2. dsmryder

    dsmryder Well-Known Member Contributor

    have you updated your super user binaries?
    I haven't been on reloaded in a long time, but I think it's still in the app drawer. Open it up and hit the menu button, scroll down to the bottom and look for the part to look for updates.
  3. sega dude

    sega dude Well-Known Member

    That worked. Turned out I was running a legacy binary. Thanks!
  4. anonymous420

    anonymous420 Well-Known Member

    just ran into the same issue except i just did a fresh install wiped everything im on CM9 i came off CM7 (to take a peek to see how CM9 is doing awesome job BTW MTDEVs) i boot it up after the reboot as i was going threw the restore process i downloaded TB installed tried to run it and will ask for root access over and over(seems like settings arent sticking) but app never loaded now either A. Fix Superuser (which im sure is the issue)B. install ALL the apps again(not want to do that) ill try to update the binary see what happens any help/advice will be apriciated
    edit:how do you update the binary on CM9 ? i clear cache and data from superuser now TB loads but it asked for permission from SU every time i checked the remember tab but every single time it needs permission the window pops out seems like settings aren't sticking weird should i update superuser? ill try that next
  5. nannycrick

    nannycrick Well-Known Member

    Had that same problem with superuser. You may want to try downloading SuperSu from Google Play. It works the same as superuser, but with alot less hassle. I believe when you install it, you should uninstall superuser app > use stock system Settings and don't wipe the cache. SuperSU is simplified, and works better for UNOFFICIAL build roms. MIUI is a port of a port, and has it's own issues. Mine is running MIUI 2.4.20 w/mOCK Kernel 1.7.14 & SuperSU Pro v0.96. It's working without FC's or "lost root".
    If you've lost root, then make a manual backup of your sd card in your computer, and then re-flash the rom. MAKE sure you hit factory reset, then wipe cache & dalvik, just to be sure the system is clean. Re-flash the rom after. This should wipe any conflicting files out. I had to do it twice. When it reboots, it should be fully rooted. you may also have to re-download some of your apps from Google Play. My Apps>All should have the master list of everything you've downloaded. Load "fresh installs" for major system oriented apps. Sometimes MIUI will FC an app if it's reinstalled from the sd card, so flash a new version instead. Your phone should run without FC's and keep "full root" from there.
Loading...

Share This Page