[ROOT] One-click root for LG Lucid :: 4/18/12


Last Updated: 2014-06-16 03:08:28
  1. Bloobs

    Bloobs Member

    First time short time...

    Thanks to all for the great work, the root finished flawlessly :D

    Advertisement
  2. Haybist

    Haybist New Member

    Ok, I may have the virgin root you/we need. I'm guessing that's a dump of my phone pre-rooting for others to use?

    Please understand this is my first Verizon smartphone, and I'm VERY nervous about bricking it.

    Is this as simple as it looks? Also, if you need the virgin root, I can supply it. However, I would like detailed instructions for this as well as the root.

    Thanks,
    Nervous Matt
  3. blumeany

    blumeany Well-Known Member

    So I guess I get to be the poster child for f'ing things up. :ciao:

    Got my new phone, rooted it. Unfortunately, I didn't let the OTA install beforehand, so every time I power my phone back up it downloads the update and tries to install (annoyingly ringing repeatedly to remind me that it's going to reboot and install in a few minutes). Install fails every time though. :confused:

    Aye. :D
  4. moserine

    moserine New Member

    Tried to run a virgin dump on the lucid I just got today--looks like it did not run cleanly:

    (Image has to be in a second post, see below)

    nothing in the one click folder, nothing special in /sdcard/
  5. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    bah! it seems my commands are screwy :/

    well anytime someone has a new one stop on by teh irc and ill manually root ya and grab the files please :)
  6. Haybist

    Haybist New Member


    The irc? I have a new one.
  7. bonezzz

    bonezzz New Member

    is there a dump of the default firmware to reup the default firmware? thx
  8. Grizzy78

    Grizzy78 New Member

    Can we get a script to un-root please!!:eek:
  9. Shedevil737

    Shedevil737 New Member

    Help Please.
    Running OSX and terminal just continues to give "./adb.osx: No such file or directory" for most of the lines of code and does not seem to actually run any of the program.
  10. blumeany

    blumeany Well-Known Member

    Anyone have a clean image of the Lucid yet? I'd like to re-image my phone so I can install the silly OTA :D
  11. avelis26

    avelis26 Well-Known Member

    I might have something you can use. I made a system img and nandroid backup just after ota but with root. Ill upload it tmrw. Good night
  12. blumeany

    blumeany Well-Known Member

    That would be awesome! Thanks in advance!
  13. avelis26

    avelis26 Well-Known Member

    blumeany and x-amp like this.
  14. blumeany

    blumeany Well-Known Member

  15. avelis26

    avelis26 Well-Known Member

    Let me know how it goes because I'm worried the file is corrupt. :-(
  16. blumeany

    blumeany Well-Known Member

    Well, I tried copying it to my phone using the method that Shabby showed me. What basically happened was that all my settings remained, the bloat apps were back, but the OTA still hadn't installed and continued to fail. I figure it *may* have been because I didn't wipe it first, which I may try today. Didn't brick it or anything though. :)
  17. blumeany

    blumeany Well-Known Member

    Ok, so here's the command I'm using to push it to the phone:

    dd if=/sdcard/lucid.img of=/dev/block/mmcblk0p26


    (I renamed the file for brevity)

    Doesn't seem to do much. Even when I wipe the phone in CWM and reboot, start from scratch and run that command, it still comes up that I need to install the OTA and nothing has changed. Not sure if maybe I need to be writing to a different location or what.
  18. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    sorry for misisng ya on irc, no system is mmcblk0p26 writing anywhere else with result in the fastest booting phone youll ever have (anywhere from 1-15 seconds depending on what partition you overwrite). its obviously detecting somethign is off with the ota check
  19. avelis26

    avelis26 Well-Known Member

    I figured out how to COMPLETELY return to stock, un-root, and un-brick the phone :)

    The night started with me wanting to remove the stock lock screen and replace it with the new ICS lock screen... well I got it working, sorta. It worked once then every time I tried to unlock the phone after that, the backlight would turn on but no screen, no lock screen, nothing... just back light.

    I rebooted into recovery with ADB and formatted /system, /data, /sdcard, /_ExternalSD, /persist, and /cache. I'm thinking one of those steps was bad because then I tried to push my img file to _ExternalSD and after waiting over an hour it was still going. So I pulled the battery and obviously from this point on I would not be able to boot to system.

    I returned to recovery holding down VOLDOWN + POWER for 5 seconds until the factory reset screen came up. I hit POWER twice and that brought me to recovery. I used adb shell to try and push the img again only to find out I couldn't mount /sdcard anymore and by extention /_ExternalSD. Don't ask me why... not sure. I pulled the external SD out and reformatted in windows and put the img file on manually.

    Back to recovery but no matter what I did... I couldn't get internal or external storage to mount. I tried
    Code (Text):
    1. adb shell dd if=C:\vs840_files\lucid.img of=/dev/block/mmcblk0p26
    but ADB didn't like that.

    So at this point I had a semi working recovery that couldn't repair system, and a system that wouldn't boot because I wiped /system. So now I begin hours of research trying to find the proper software to re-install firmware via download mode. I've used the LG Mobile Support Tool before with other LG phones but not for download mode... only type of phone I've ever been able to use "Download Mode" is Samsung phones and ODIN.

    I tried it anyway and it WORKED... the LG Mobile Support Tool connected to my LG Lucid in Download Mode, completely fixed my phone :)... un-root, stock, complete factory reset.

    I will say blumeany that after doing this, I checked for OTA and my phone is all ready up to date, so I'm not sure if it will fix your issue but its certainly worth a shot :)

    Here is the link to the driver and tool I used to fix my phone:
    http://www.lg.com/us/support-mobile/lg-LGVS840
    Make sure to click on the "SOFTWARE UPDATE" tab.

    Anyway, feel free to PM me or gmail, or gtalk, or IRC if you want more info (although after this book I wrote, I think you should have all the info you need lol)

    graham.pinkston@gmail.com
  20. blumeany

    blumeany Well-Known Member

    See my experience in the unroot thread ^^ This is confirmed!
  21. kaihamilton

    kaihamilton New Member

    Just wanted to verify that your problems were solved on the phone you installed Clockwork Mod. Please get back to me if you can, your help will be much appreciated. I want to make sure that the lg support tool will fix my phone if anything goes wrong while my phone is rooted...

    Also the link for the LG Mobile Support Tool at http://www.lg.com/us/support-mobile/lg-LGVS840
    seems to be removed, if someone would temporarily upload the tool or supply an alternate link to it I would appreciate it very much. Thanx!
  22. blumeany

    blumeany Well-Known Member

    Wow, that's bogus, it looks like they took it down. Try downloading it here:

    https://docs.google.com/open?id=0Bx0oyZ35z1xQMFc3THBQcWdIcTQ

    And yes, re-imaging the phone successfully returned me back to stock. Be sure to click the option to install the drivers before connecting your phone. Read my post in the other thread for my step-by-step details. Basically, the first time I attempted this, it failed and I had given up. When another poster came out and said they were successful with it, I tried again and it worked.
  23. bkrahmer

    bkrahmer New Member

    I just wanted to say thanks for the great rooting tool. I picked up my Lucid today, and wanted to keep my tethering if I need it in a pinch (previously had a rooted Optimus V). I did have a couple issues. One issue was complaints about permissions, so I did a 'sudo su -' before attempting to execute run.sh. Secondly, it couldn't find an adb, so I downloaded the android sdk, installed the required platform tools, and made a symbolic link to the installed adb as adb.linux. I'm not sure if copying the file would have sufficed. After installing the WiFi Tether app and configuring it, my laptop wouldn't connect properly. After a bit of digging, I found that other hacks are required to utilize WEP. I found it much easier to just disable encryption, and use the access list feature instead. I hope somebody finds this helpful.

    brian
  24. deuxphoria

    deuxphoria New Member

    thank you for such a convenient package. i do want to add that i had to choose 'internet' for the usb connection mode in order for the usb debugging to start. usb debugging did not begin under either charge or mass storage mode even though i had usb debugging enabled under settings -> applications -> development.

Share This Page