[Root] One Click Root for Samsung Admire (SCH-R720) :: Windows/Mac/Linux :: 9/12/2011

Last Updated:

  1. Jaymoney

    Jaymoney Member

    I got this error as well - but then i Installed SuperUser and everything is working fine. I have root access and can remove bloatware and tether the phone.

    Download a root checker from the app store to see if you have root access. Thats what I did and it said I had it. Got Titanium Backup running on the phone right now with no issues.

  2. bgdad1972

    bgdad1972 New Member

    How do you remove the bloatware? I have it rooted
  3. marixxaa

    marixxaa Well-Known Member

    Got root, deleted bloatware. Thanks :) a lot... I'm hoping we can get a recovery rom to flash
  4. Jaymoney

    Jaymoney Member

    You need to install superuser, and then install titanium backup.
    bgdad1972 likes this.
  5. Taic00

    Taic00 Member

    Hi Guys, I'm a noob so I hope you'll bear with me. I ran the run.bat on y'day and it says the phone was rooted. I installed the superuser.apk today and it also says the phone is rooted. I still cannot delete the bloatware using Astro file manager, do I need to run the .bat file again or is there something else I haven't done correctly? Thanks in advance for all help.
  6. bgdad1972

    bgdad1972 New Member

    thanks alot that worked great!
  7. xFlow

    xFlow Member

    Nevermind, fixed it, thanks for your contribution !
  8. Taic00

    Taic00 Member

    Problem solved after installing Titanium Backup, thanks for the help.;)
  9. jov0219

    jov0219 New Member

    i tryed this dose not work i to know how to do step by step
  10. crono209

    crono209 Well-Known Member

    omg thanks all u guys... rooted with no problem at all... but did u guys get 3G after rooting? is that what this rooting process does? cuz after i rooted my phone all a sudden i have 3G. yes i made sure wifi was off and everything and it runs pretty quick, way faster then 1x.
  11. anthonysing74

    anthonysing74 New Member

    ok so i download the root link to my admire set it to usb debugging mode plugged it into my mac and clicked on the zip file it made another file named admire so i tried running the files but it jus opens a text page so i unplugged my phone and installed the superuser app that was included with the root zip file then tried running admire root sh, su, adb osx but my phone keep saying no aplication can proform this task this is my first time trying to root a phone and i really need sum help
  12. nycnyc

    nycnyc Well-Known Member

    I think I'm having problems with the USB driver. Uninstalling it and I'll be right back once I do. But right now my laptop's card reader tells me to reformat any card I insert into it and it doesn't recognize any of the devices I connect via USB.
  13. Jaymoney

    Jaymoney Member

    It sounds like you are trying to root the phone on a Mac.

    I tried rooting via a mac and i had problems. If you have a windows PC, use the windows version.. thats what I did and it rooted the phone no problem.

    If my friend refused to let me root the phone on his PC, i was going to attempt to run the windows exploit via play on mac or another win32 emulator.... no idea if that would have worked or not.
  14. puddlesyj

    puddlesyj Member

    I am so happy to have root. Thanks so much BUT I am having a big problem.

    I rooted, and then I have tried multiple programs. However they claim I do not have busy box installed. I have attempted to install multiple versions of busybox and all have failed.

    I have used root checker and it says it cannot find busybox, yet titanium backup claims I have 1.18.4-tiitanium. Something is wrong. No program that requires busybox will run.
  15. puddlesyj

    puddlesyj Member

    Okay, so I messed with it some more and found that I can use a root file explorer to assure that the /system/bin folder had proper permissions.

    I have now installed properly and have no problems.
    sandpipershore likes this.
  16. ajshaw77droid

    ajshaw77droid Member

    Now that its rooted, what's the best ROM for the Admire? CM7.1?
  17. alacran1980

    alacran1980 New Member

    anyone can help me? im install superuser fix update from market click on check for updates and off and now I have only black screen

    my phone samsung admire
  18. Ancient

    Ancient Member

    i enabled USB storage to get my pc to see my phone
    and debugg is enabled
    i installed the file drivers for Windows users

    when my pc finnaly could see my phone after turnning on usb storage tethering

    i run the Batch file and it starts soon after the phone restarts Pc MS dos screen disappears
    phone turnns back on to SAMSUNG screen & just continues to vabrate this continues for 5 10 15 mins+
    i noticed that its not doing anything else & i a sume that appon the phones restart the connection between it and the pc was cut....

    please help this is where i am stuck... it seems that it looses connection to the phone while it is vibrating...

    Also was i supposed to run the Run batch file from my PC or from the phone.?

    i am a noobie at these things any help is greatly appreciated.
  19. rhandall

    rhandall Active Member

  20. rhandall

    rhandall Active Member

    Having exact some problem as you bro just did it today ****KKK!
  21. Ancient

    Ancient Member

    well.hopefully we get the solution soon bro i got my fingers crossed mean while i just bare it
  22. rhandall

    rhandall Active Member

    lmao i don't understand, before i had a lg optimus m with 2.2.2 fw and i did it the longway and downgraded it then i would root it and now i go and try to root this phone and this shit happens -.-. Bro try to like post a warning about the phone turning off while in usb and it losing connection to prevent other people from bricking their phone. But if anything i can return to metro piece of shit and get another one
  23. Jaymoney

    Jaymoney Member

    What does the program indicate? Does it end with the message "enjoy your rooted phone"?
  24. Ancient

    Ancient Member

    no it just ends.. i tryed to reinstall the drivers again using the link provided now... it doesnt even get past

    [* daemon not running. starting it now *
    * daemon started successfully *
    error: unknown host service
    [*] Triggering core dump..."
    [1] Segmentation fault app_process /dev...]

    after that it just shuts off.
    and the phone is left vibrating until i shut it off and then back on...
  25. aaronmy

    aaronmy Well-Known Member

    its suppose to do that. after that it should say something about be patient the phone will boot loop a couple times and vibrate. After that it wil be done

Share This Page