[Root] One Click Root for Samsung Admire (SCH-R720) :: Windows/Mac/Linux :: 9/12/2011


Last Updated:

  1. rhandall

    rhandall Active Member

    for me the box thingy disappeared and the phone is just left vibrating now

    Advertisement
  2. rhandall

    rhandall Active Member

    guys for those that were having the loop error like me, just connect your phone through usb even if your computer does not acknowledge it, and then run the .bat file from your computer and tadah! i am now rooted
  3. OnyxJay

    OnyxJay Active Member

    Thank you so much for this! But now I have a question. How do I unroot my phone if I have to turn it in for warranty reasons? From reading around I see the only real way to do it would be to load up a stock ROM for this phone (and stupid me, I didn't make a backup of the vanilla ROM.) Can anyone help me out? I'm a noob, but pretty technically minded, so if I am pointed in a direction with good directions, I shouldn't have too much difficulty.

    Thanks!
  4. Ancient

    Ancient Member

    you not listenning to me that black box window "Dos" i believe it is called
    just closed its self when my phone restarts...

    i neever get to see it say enjoy your rooted phone because it turns off in the middle of the process...:confused:
  5. Ancient

    Ancient Member


    so you can drag the Admire folder to your PC desktop & connect the phone & run the bat file from the PC long as the phone is connected via USB cable ???


    ok i,ma try that....:rolleyes:
  6. Ancient

    Ancient Member

    ok i got to see the whole process it went quick...

    * daemon not running. starting it now *
    * daemon started successfully *
    error: unknown host service
    "
    [*] Triggering core dump..."
    [1] Segmentation fault app_process /dev...
    "
    [*] Rebooting phone. It may buzz a lot and loop on boot. Don't panic."
    remount succeeded
    312 KB/s (26264 bytes in 0.082s)
    link failed File exists
    "
    [*] Installing Superuser.apk. If this hangs, just cancel it with Ctrl+C after a
    few seconds,"
    "
    [*] and you'll be finished rooting your phone. Reboot and enjoy."
    260 KB/s (196521 bytes in 0.736s)
    Error: Could not access the Package Manager. Is the system running?
    "
    [*] Persistence complete, enjoy your rooted phone!"
    Press any key to exit the script.
    Press any key to continue . . .


    so i believe it is finnally done... how ever when i in super user Titanium back up and Busy Box which req. Root* Access it informs me that the phone is still not rooted...

    Any ideas on my next step i know i close....

    lol almost there....:rolleyes:
  7. Ancient

    Ancient Member

    :cool:thanks rhandall for the tip

    so step by step for the Windows version users

    1.) installed USB drivers

    2.) download Admire zip & extract to PC [ Desk top ] or perferred location

    3.) connect phone via Usb cord. [no need to turn on Usb storage from the phone]

    4.) Run from your PC the Run.bat file [wait for the Process to finish]

    [​IMG]

    5.) When promted hit any key to continue "do so"

    now you have a rooted phone congrats :D

    What to do next after you Rooted your phone

    1.) installed Superuser

    2.) Install Titanium Backup



    Thats all i know for now... i plan to keep learnning as i am new to this my self.


    i hope this help alot of you & saves you some head ache.:eek:
  8. dixie460

    dixie460 Well-Known Member

    I had originally posted here asking for help gettin the phone to identify itself to my computer, so I'm editing now to potentially help other out. My problem was that I connected the admire to my computer and it would charge, but refused to acknowledge it was connected to another device. I found that the reason it didn't work was because I was using an LG cable... It was the one that ships with the Optimus M that I keep plugged into my Linux machine, and didn't think twice about plugging another device into it. I mean, it has a USB "Standard A" connector on the computer end and a USB "Micro B" connector on the phone end, and the Admire has what looks like a Micro B USB port (like the Optimus) so why not?

    Well, it didn't work. The LG cable provided power to the Admire, but NO data connection. So I posted on here for help, then thought about it... and decided to try the cable that came in the box with the Admire... it works fine! Must be proprietary or something...

    So, for future reference: the Samsung Admire cable will work fine on the Optimus M (power and data) but the Optimus M cable will NOT work on the Admire (gives power only, NO data)
  9. rhandall

    rhandall Active Member

    bro don't worry about it, i traded my rooted optimus m to metro and traded it for my admire. Those idiots at metro piece of shit wont notice the difference from a rooted or unrooted phone. Especially since my guy who i talked to was columbian who speaks spanish.
  10. joseandres20fl

    joseandres20fl New Member

    Hi I just got an admire samsung phone. from MEtro... I been trying to install games like
    ganstar, fifa10 , modern combat and every time its start downloading the update it charges and everything but most of the time freeze or text overlap through images.. Any types do I need scummvm-android (by that way what is that for and the plug ins...) HELP PLEASE..
  11. rhandall

    rhandall Active Member

    fix your grammar because I do not understand you.
  12. mechanicbrian0

    mechanicbrian0 New Member

    how do i install superuser on the admire?
  13. GJC

    GJC Active Member

    how do i install superuser on the admire. I did want to install with android market place from my phone but says "Market needs background data to be enabled. Help please. Forget it I forgot to sync my gmail account.
  14. alpha18

    alpha18 Member

    hmm why when i uninstall the metro bloatware my phone resets? is it normal or something isnt going right
  15. crono209

    crono209 Well-Known Member


    there are many ways, either connect your sd to your computer then moving the superuser.apk from your pc to your sd card then finding the app through your file manager and install it. or get dropbox on your computer and placing/upload the apk on dropbox folder after u have installed it into your computer. then go on dropbox on your phone and download the apk.
    hope this helps somehow
  16. GJC

    GJC Active Member

    Thank you crono209. Your post helped me understand different ways to installed apk's.
  17. asheehanjr

    asheehanjr Well-Known Member

    I was wondering, when you traded your LG Optimus M (which I have) was it a full trade or did you need to pay cash to make up the difference? I was thinking about trading my Optimus my self for the Admire when the root came out. I don't know how the trading process works with Metro. Thanks for your help.

    -Andy
  18. dixie460

    dixie460 Well-Known Member

    You probably removed something you shouldn't have BUT before we go there, what do you mean by resets? Is there a Force Close happening, or is the phone actually rebooting? I just rooted my girlfriend's admire last night, and after deleting one of the bloatware apk's (can't remember what it was, but I knew it didn't need to be on the phone) I got a Force Close every 5 seconds from some com.blah.whatever process. I had this happen when trying to delete Boingo Wifi from my old Ascend too, so I rebooted and the problem went away.

    If the phone is rebooting then I'd say you deleted something that the phone needs to run.
  19. alpha18

    alpha18 Member

    i just deleted all the metrocrap off it and everytime i rebooted itself i didnt delate anything that i dont see on my home screen
  20. ajoe.tapia

    ajoe.tapia Member

    I tried on two different computers and i'm getting the same exact message!

    Anyone have this problem and solution??

  21. nesram26

    nesram26 New Member

    hey guys ive tryed evrything I.ve seen on here. my titanium backup still says i could not acquier root privileges. I have downloaded busybox and it says that busybox has not downloaded because it was not allowed root access. i also downloaded superuser and it does nothing. can you please help. thanks.
  22. Jaymoney

    Jaymoney Member


    I think its because these are system apps. My phone did the exact same thing when i Un-bloated it.
  23. GJC

    GJC Active Member

    I have rooted the Admire, installed superuser elite and titanium backup Pro successfully; However, I used root check application and confirmed that my phone was rooted but busybox could not be found in the system directory. titanium backup, however, confirmed the root access: OK (busybox 1.18.4 - titanium from app installed) - I found with a root file manager that titanium busybox is installed in the application data directory. Should I be concerned about this and go ahead and install busybox from the market place anyway ? the free Superuser is working but some of the paid Elite's features are not and I just wonder if this busybox error situation found by root check application might be the cause. Thanks in advance for your input on this matter. [​IMG][​IMG]
  24. locklady

    locklady Active Member

    after i tried to install busybox with this installer https://market.android.com/details?id=stericson.busybox&hl=en i was having the same issue after rooting my phone with 1.) busybox could not be found 2.) applications not being granted root access apparently that first busybox installer doesn't have enough versions to choose from and every time i tried one of them it seemed to remove root or cause errors. then i found this installer (it is different because it have many more versions of busybox to choose from) https://market.android.com/details?id=com.jrummy.busybox.installer&feature=related_apps busybox version 1.18.0 worked for me from that installer (all the other version caused the same kind of errors) and now when checking with root checker all is good! and perms are given to any app that requests it :)
  25. locklady

    locklady Active Member

    I installed busybox version 1.18.0 to the system/xbin directory. i don't know if it makes a difference but thought id mention it.

Share This Page