1. Good things coming in just a couple hours, stay tuned!
    Dismiss Notice

[ROOT] Steps to root the Huawei Mercury


Last Updated:

  1. d34thbl00m

    d34thbl00m Member

    Thank you Ziggy for the walkthrough on the Linux stuff...because of this and PlayfulGod's instruction I was able to successfully complete root. Thanks again! Now if only I can get this MMS issue solved my phone will be perfect....

    Advertisement
    NeoZiggy likes this.
  2. NeoZiggy

    NeoZiggy Well-Known Member

    MMS issue? Have you started a topic for this problem? Could you provide a link or start a topic in the Huawei Mercury forum? I'm interested to know because the phone has working MMS with Cricket by default. I know the info to get MMS working on flashed phones is online.
  3. ciabatoni

    ciabatoni Well-Known Member

    Was the MMS ever working? Or is this something that just happened after you completed the root for this phone? Details would be awesome!!!
  4. PlayfulGod

    PlayfulGod Well-Known Member Developer

    I've almost got everything config'd to build CWM, just need to research how recovery n boot are booting because it appears to be dual booting them both from the same partition and i want to make sure they will flash correctly n not mess one or the other up.

    Another good reason a dev needs the phone in hand lol. But I will be working on it again this week.

    If anyone else is working on this n would like to compare notes, I have no problem working or helping someone else. ;)
  5. Dhustler

    Dhustler New Member

    can someone just tell me exacly witch one is the system, i sent su and busy box to the bin, and Superuser to app, I tride different bin ones and all without luck, all i need to know is where the system app and bin your talking about, are they under same location, their is one like this and I tried it, no go, i'm using ubuntu 10.4, i have no problem with it, just where the file should go, i'm under sudo nautilus so i have root privlages, someone please helpo me i'm so close, don't know why its not working, i sent them to the one where app and bin are under same location, ive already tried the other ones then sent them to trash can
  6. ciabatoni

    ciabatoni Well-Known Member

    I dual booted unbuntu 11.10 with my secondary laptop running vista, and it now says its missing the NTLDR files for boot manager. I straightened the problem out but I dont understand why that happen. I didnt do a permanent install for ubuntu, it was just a temp to see how it works. If I do unbuntu permanently will I always have this problem when I go to boot up my laptop??? Also does anyone have a link to ubuntu 11.04? Thanx in advance!!!
  7. refriedbeans

    refriedbeans Member

    did you use the wubi installer? If you did, that may be the problem. Wubi installs ubuntu INSIDE of windows instead of actually allocating space for the linux.

    Ubuntu linux is a very rock solid system and great for newcomers. Linux Mint is even more user friendly (an ubuntu derivative). Put in the live cd and *reboot* your system with the cd in the tray and try out the distro. If you like it, install it. You shouldn't have any issues that way.
  8. Gmash

    Gmash Well-Known Member

    Glad to see we have quite a few smart, tech savvy people on here. I hope you guys will stick around. I'm sure when more people start getting this phone, there will be a lot of people needing some help.
    NeoZiggy likes this.
  9. ciabatoni

    ciabatoni Well-Known Member

    NO wubi installer, I usd a live usb amd IO went into my bios and turned off the HDD so it would boot from the usb. I then selected temp so it didnt make a partition for it. When I was done browsing I clicked shut down, When I fired back up after turning the HDD back on it said file corrupted. Then I shut down and rebooted and it was fine again. But still, I just wanna make sure I dont go thru that everytime I dual boot or if I make a permanent partition...Can I still do a manual root with linux mint??? Thanx for all the input and suggestions...
  10. NeoZiggy

    NeoZiggy Well-Known Member

    Ok, for some darn reason I am having trouble rooting this thing!
    I copy the files with ADB using PlayfulGod's script, boot into linux, put the phone in download mode, open terminal, type sudo nautilus then move the files to the correct locations (the folder with app and bin (also has xbin but I'm not using that)). I also tried to manualy change the file permitions to root-root to see if that would work. But Superuser still says it does not have root permisions to update the SU binaries and BusyBox installer can't complete either. I checked with a terminal emulator on the phone and the permitions seem to be correct.

    IDK what the problem is here and it's driving me crazy! Am I missing someting?
  11. NeoZiggy

    NeoZiggy Well-Known Member

    When I type "adb shell" then "su" the phones says 'Shell has been granted Superuser permitions' but the prompt doesn't change from $ to #.
  12. ciabatoni

    ciabatoni Well-Known Member

    {{you can get the terminal emulator from the market}}

    This solution may Help, this is how everyone else Ive read up on, said they ROOTED when they ran into the same problem your having...

    ~~~~solution~~~~

    1. After completing all steps, open ur Terminal Emulator in phone then run:
    cd /system/bin
    ls -l
    Check the owner of su file in the list it'l b at the end, If Its user is 'shell' then U'll not have root.
    Here's Solution:
    1. Follow same step till the end like you've been:
    2. After chmod of all files done, open terminal do:
    sudo -s
    cd /media/system/bin
    chown root su
    3. If you do it successfully U'll have root!!, the summary of this method is U'll change user of su from 'shell' to 'root' you can check it on Terminal emulator.

    Let me know if this HELPED!!!
    NeoZiggy likes this.
  13. NeoZiggy

    NeoZiggy Well-Known Member

    The owner of su (and busybox] is already root-root. Everything else in the directory is root-shell. I also checked Superuser.apk and it is root-root as well. SU, Busybox, and Superuser have RW-RW permitions instead of RW-RO (read/write, readonly].

    I'm going to delete everything, drink a Monster, then try it again from scratch.


    UPDATE:
    Still not working.
    I put the phone in download mode, deleted the files and rebooted the phone. I reran the adb script to push files, booted to linux, opened terminal, typed "sudo -s" then "sudo nautilus" and then moved the files to the right spots using cut and paste. Exited nautilus. Then using terminal I went to '/media/57[blah]_/bin', chmod'ed su and busybox manualy to the permitions used in the script. Typed 'chown root su'. Then I went to '/media/57[blah]_/app' and chmod'ed Superuser.apk. I rebooted the phone and I still do not have root.

    Does the fact that everyone is seeing "system" while I see some long name with a mix of letters and numbers make a difference... I see like 4 or 5 different ones but only one has 'app' and 'bin' so I am assuming that is 'system'.

    *getting the noose ready* :(
  14. ciabatoni

    ciabatoni Well-Known Member

    Is there anyway you can post a pic of what your seeing instead of system?
  15. NeoZiggy

    NeoZiggy Well-Known Member

    Here is a SS of the directory list of media. As you can see the phone's partitions show as long names. The one with one underscore is 'system'. I show a list of that directory as well:
    [​IMG]


    Here is a SS of the Nautilus window. The 'sudo nautilus' window is in front, behind it is the one that pops up when the phone is plugged in:
    [​IMG]


    And finally here is a SS of 'ls -l' in the /bin directory. I had just changed su's permitions to root-root because before this it was root-2000 like the other files. After I did this I redid 'chown root su', but the phone still doesn't have root though:
    [​IMG]


    I'm running Ubuntu 10.04 off of a USB stick, but that shouldn't matter....
  16. ciabatoni

    ciabatoni Well-Known Member

    Take a look here and see if this works for you!!!
    [Tutorial] [ROOT] How to Root the Cricket Huawei Mercury M886

    Let me know if it helps...
    NeoZiggy likes this.
  17. NeoZiggy

    NeoZiggy Well-Known Member

    I had come across that page yesterday and manually changed the file ownership before by right clicking and selecting properties. I will try it again later when I get home and use the terminal with out GUI.

    Just to confirm, you have root and used the files in Mercury-root.zip above? Both su and busybox are in bin and not xbin?
    Perhaps it's the folder's permissions on my phone? I just don't get it...
  18. ciabatoni

    ciabatoni Well-Known Member

    Are you doing the first few steps manually, or are you using playfulgod's "root mercury zip" that pushes the 3 files automatically? If your doing it one way, maybe try it the other way..
  19. NeoZiggy

    NeoZiggy Well-Known Member

    This time I did it all manually. It seems su isn't getting the right permissions. It has "-rwxr-xr-x" instead of "-rwsr-sr-x" even though I did CHMOD and CHOWN.

    I was assuming it could be the directory on the phone. I just noticed that both BIN and XBIN are 'root.shell' and not 'root.root' like every other directory. I'm going to change them and hopefully this will fix the issue.

    UPDATE:
    I fixed the permissions for su by simply doing "chown root.root bin" then "chmod 6755 bin/su".
  20. NeoZiggy

    NeoZiggy Well-Known Member

    I HAVE ROOT! :D

    Finally....

    So somewhere along the line the folder's permissions got screwed up. This could have been from me trying some kind of "one click" or playing around in the GUI trying to change permissions.

    Let it be said that 'chown root.root bin' [and maybe 'chown root.root xbin'] followed by 'chmod 6755 bin/su' may be needed for some people.
    refriedbeans likes this.
  21. Gmash

    Gmash Well-Known Member

    Congrats! Hopefully I will get there one day lol.
    NeoZiggy likes this.
  22. refriedbeans

    refriedbeans Member

    Yes you can do it with mint. Mint is basically the ubuntu source code with a face lift. If you have a nice size HDD, I would recommend going with either ubuntu or mint as a dual boot option. You could do all your everyday online activities without worry of a virus :D and use windows when it's needed.

    I'm still having trouble rooting my mercury as well. I'll post again as soon as I figure it out.
  23. refriedbeans

    refriedbeans Member

    Was your phone in download mode or did you do this from adb?
  24. NeoZiggy

    NeoZiggy Well-Known Member

    I put my phone into download made and opened Terminal in Ubuntu. You wouldn't be able to do those commands from ADB if you didn't have root already.

    I checked to see what the permissions where for the directory after I noticed su wasn't taking the CHMOD command. I had a sneeking suspition that it was the directory. I think this just happened in my case because I had been trying other options. No where did I see any mention of this problem for others, but it could be a problem if they tried other rooting methods unsuccessfully.

    I would suggest people just get on Linux and skip using ADB from windows since linux is required right now anyway.
    refriedbeans likes this.
  25. refriedbeans

    refriedbeans Member

    Yeah I figured that out shortly after. Felt dumb for a minute there.. oh well. The good news is, I FINALLY got root after piddling with all the file permissions. (All was done from the terminal, no scripts [still appreciate all your efforts PG :D])

    I gotta run but as soon as I get a chance, I'll type out the process as clear as possible of how I obtained root. Thx for everybody's help!
    NeoZiggy likes this.

Share This Page