Root Stock ICS With S-Off


  1. MegaVortex

    MegaVortex Member

    I have S-Off on my Rezound and just got the ICS update. I was previously rooted before the update. How do I get root in the official ICS? I do not want to unlock the bootloader, as I have heard that is not a good idea. I followed the instructions in http://androidforums.com/rezound-al...ys-noob-friendly-root-guide-start-finish.html using steps 2 & 3, but when I type in the command, this is what I get:

    Code:
    c:\mini-adb_vigor>fastboot boot recovery-ra-vigor-3.15-gnm.img
            downloading 'boot.img'... OKAY [  1.447s]
                           booting... FAILED (remote: not allowed)
    finished. total time: 1.449s

    Advertisement
  2. undone98

    undone98 Well-Known Member

    I had this happen to me when i s-off'd but i was too lazy to look for a solution so i just unlocked my bootloader and then flashed the recovery

    so if you dont mind your bootloader saying unlocked there's a possible solution
  3. MegaVortex

    MegaVortex Member

    Well, after seeing this said
    in this thread (http://androidforums.com/rezound-all-things-root/538377-dont-unlock-after-s-off.html):
    I guess I'll just unlock again. Screw the warranty!! lol
  4. MegaVortex

    MegaVortex Member

    Ok, so I followed the old instructions, yet I still don't have root. How do I get root??

    EDIT: I got it, but am drunk. Will post how I did it tomorrow in case anyone else needs help. lol
  5. DaveHiro

    DaveHiro Member

    Oh for the love of pete... I can't get root .. sober up a little and help a fellow out!

    :D
  6. scotty85

    scotty85 Guides Guide

    my goodness,you guys are making this complicated. :eek:

    there are other ways to flash recovery when s-off:
    1)as a PH98IMG in hboot
    2)by installing juopunuts bears patched hboots,wich will allow you to use the fastboot boot and fastboot flash comands

    when you have recovery,you just flash superuser as you did before. however,use this one for ICS: [16.07.2012] SuperSU v0.94 - xda-developers

    PH98IMG for amon 3.15:
    PH98IMG-amon-3.15.zip
    md5: PH98IMG-amon-3.15.zip 07f9510e9299c381ad18001d9fba4563

    juopunut bear patched hboots:
    http://unlimited.io/hboot-downloads/
    DaveHiro likes this.
  7. DaveHiro

    DaveHiro Member

    Scotty, as always, YOU ARE AWESOME.

    What was driving me crazy is that the unlock, and ra recovery install worked just fine, and installing the signed superuser files (3.07) seemed to work FINE... but weren't granting root apparently.

    Rather than reinstall the JPBear HBoot, i just flashed the SuperSU zip and now it's all working great! bloatware is on the way out!
    scotty85 likes this.
  8. scotty85

    scotty85 Guides Guide

    one of my favorite things to do with my sensation is flash other carrier/regional RUUs. ive used superSU to root several stock ICS builds,and even to fix the superuser issues on a couple of rezound custom roms.

    glad you got your root,sorry i didnt catch you before you unlocked again. :(

    for what its worth if you do need to make a warranty claim,you can relock,run ruu,s-on,reunlock and root,s-off again. at this point your back to locked so you can then ruu and s-on,and be 100% stock.

    so there are some extra steps,butlocked is technically still possible :)

    i got my rezound used,so i could care less about warranty.i re-unlocked mine imediately :D
    DaveHiro likes this.
  9. DaveHiro

    DaveHiro Member

    Oh, I don't mind that I'm unlocked again. Thanks to your instructions I've gone from 1) stock to 2) rooted and debloated to 3) S-off to 4) nil's business sense to 5) stock ruu to 6) rooted and debloated again but with ra recovery installed to 7) stock ruu to take the ics update to (finally for today) 8) stock ics, rooted and freshly debloated!

    I haven't gone s-on yet... but I don't foresee wanting to, but I've only had the Rezound for a month :)
    scotty85 likes this.
  10. tentoil

    tentoil Member

    Hello Scotty first of all please forgive my nubidity. I have read almost all of your posts and reposts on the subject have an issue i am hoping you can help me with. I used jpbear to s-off my phone then flashed the global 4.03.605.2 now i am locked and trying to flash ineffabillis but have read your post as to not being able to do this because now i am locked and can't use the fastboot boot commands. Question won't putting jpbear back on revert the global rom back to that for the jpbear? if the recommendation was to install the global one first then wouldn't this negate that? In short, forgive me again but please explain how i can now flash this rom. it fails recovery i assume because i am locked.So if you could send me a link as to where to go to find the answer or tell me what i might be doing wrong i would appreciate it.:(
  11. scotty85

    scotty85 Guides Guide

    Post 6 has the info you need.

    Simply permantly install amon permently by flashing it as a ph98img in hboot,or you can reinstall the jpbear hboot by flashing it as a ph98img.

    If you don't wish to permantly install recovery,reinstall jpbear hboot,and then you can fastboot boot recovery again.

    With s off,recovery can write the boot image,so you can permantly install it if you want... Booting it into memory is no longer needed to make it work properly :)
    tentoil likes this.
  12. tentoil

    tentoil Member

    You are truly awesome. ok i'll stop praising you bet you get that a bit. The issue i am having and if anyone else has had this and might know the answer i would appreciate it. i permanently flashed recovery and have been trying to flash the rom Ineffabilis Deus v1.2 [8/27/12] Sense 3.6 | Beats | Tweaks | 4.03.605.2 | Global. i first tried to flash in in recovery with its original file name. did wipes then flashed the file and post said that it would wipe the phone and install so back up(which i did). when the phone rebooted it just updated like 60 files and then went about its business the same. i just can't figure out how to get this rom to flash. i flashed the zip file as Ineff_Deux_1.2_Flashable_Boot.img and it didn't work. then i changed the file name to PH98IMG and still not changing rom. am i just dumb or am i missing something
  13. scotty85

    scotty85 Guides Guide

    so the rom is not chagning? give me link to the thread youre using,ill have a look :)
    tentoil likes this.
  14. tentoil

    tentoil Member

    this is the link i started with
    [ROM] Ineffabilis Deus v1.2 [8/27/12] Sense 3.6 | Beats | Tweaks | 4.03.605.2 | Global

    First i went and flashed 4.03.605.2 RUU as stated on site.
    This part went over without a hitch. Got global access. then got


    v1.2 (8/27/12) (Current)

    Ineffabilis-Deus-v1.2-signed.zip - 691.3 Mb

    flashed it hboot and the PH98IMG showed but it showed a quick download of the rom and then told me to reboot. then nothing. everything stayed the same as it was when i got the global one. Then i tried doing it straight through recovery. wiped then flashed it from recovery. still nothing changed in my operation. can't figure out where i am going wrong. i've done the process you have laid out pretty well at least 12 times in the last two days. lots of re installing apps and resetting up my phone. Or it could be after reading all the abilities this rom will give me i just don't know what i should be seeing when i start it back up. Anything you could find out or other way to get it to work i would appreciate it.
  15. scotty85

    scotty85 Guides Guide

    Looks like that Rom is set up for s off flashing,so you should be fine to do a full.wipe,then flash.

    You can also wipe system,and boot, with amon,so you can be 100% sure that the Rom has changed if it boots ;)

    If for some reason the Rom werent updating the partitions like it should,you'd hang on the HTC splash screen after a boot/system wipeif it weren't installing.

    Looks like this rom is more less stock,and using a stock kernel so maybe what you're booting into is the new rom :)
  16. tentoil

    tentoil Member

    Thanks Scotty but i tried it this way and wiped everything and flashed the zip file . it said it was moving the PH98IMG to the sd card. when it came back to the hboot screen and started to install the PH98IMG. now on reboot i am stuck on the splash screen. How do i get this PH98IMG deleted so i can recover
  17. scotty85

    scotty85 Guides Guide

    easiest way is to place the sd card in a card reader,then plug into the pc. in a pinch you could always put it in a different phone,as long as you can either plug the phone in to the pc,or manipulate the files from the booted device.

    thats very odd that a rom that claims to be "for s-off only!" created a boot image file and put it on your sd card :eek:

    maybe you should give up on that one for now... try a flashing a few others and see how the process goes. :)
  18. tentoil

    tentoil Member

    I think after all this i will be trying another rom for sure. Thanks wish me luck. Thanks for the help luckily had wife's phone so i could do the sd card swap and delete the files. doing nandroid back up now so we'll see how it all turns out.
    scotty85 likes this.

Share This Page