Root stuck "waiting for device"


  1. Aremihc

    Aremihc Well-Known Member

    I'm having issues rooting. I get adb to reboot into fastboot, but then adb can't find the device or get the identifier token. Help?

    Advertisement
  2. thornev

    thornev Well-Known Member

    scotty85 likes this.
  3. Aremihc

    Aremihc Well-Known Member

    I'm following Scotty's guide. I've used adb to reboot into Fastboot, but then Fastboot Devices returns nothing and the token command says "waiting for device" I do hear the device connect sound, but I get no charging light. Phone says fastbootusb thanks.
  4. bryan.allen

    bryan.allen Well-Known Member

    Exact same thing happening to me.
  5. thornev

    thornev Well-Known Member

    So you're on Step 2 of Scotty's guide. Presumably you did everything in step 1 with no problems. Previously "adb devices" responded with info about your phone, you used adb to reboot the bootloader and the phone says "FASTBOOT USB" in red at the top on a white screen. "fastboot devices" returned nothing so you moved on to "fastboot oem ..." and that command did nothing? I'm not sure you could get thus far if you didn't, but let me ask... Did you:

    - install on your PC the HTC USB drivers?
    - disable HTC Sync on your PC?
    - Enable USB Debugging on your phone?
    - Disable Fastboot on your phone?
    scotty85 likes this.
  6. Aremihc

    Aremihc Well-Known Member

    Could you clarify disabling fastboot on the phone? Thanks
  7. rootbrain

    rootbrain Well-Known Member

    It's under settings -> Power, make sure fastboot is disabled (unchecked)
  8. Aremihc

    Aremihc Well-Known Member

    Changed the fastboot setting, still nothing
  9. thornev

    thornev Well-Known Member

    I can't make sense out of how "adb fastboot" works and "fastboot devices" doesn't work. How can one command see your phone and the other one cannot? (rhetorical question to myself) When I get some time tonight, I will put my phone in fastboot and see if the command works for me. Oh wait, I can't do that as I'm already unlocked.
  10. Aremihc

    Aremihc Well-Known Member

    No clue... but I pulled out my netbook and started over and it worked. I assume it is a driver issue on my main PC...
  11. scotty85

    scotty85 Guides Guide

    you never stated in your other thread where you were getting your adb/fastboot tools. if you havent figured it out yet,id suggest using my mini-adb file,and you can see this post for more info.

    its actually very logical. "bootloader" and "booted to the OS with usb debugging checked" are 2 different modes,and thus require their own drivers,either of wich could get goofed up or not installed. also,if you look in your folder that you used to unlock, youll see that adb and fastboot are 2 seperate utilitys contained within. just becasue youre using them in the same command window doesnt mean that they are the same ;) if either the adb or fastboot utilitys are missing,it will not work,while the other will.

    you can put your phone in fastboot, and "fastboot devices" will return a serial number if you are unlocked or not. if you want to play with it,fastboot getvar all will tell you your main version number,as well as some other bits of inf. fastboot reboot-bootloader will reboot the bootloader(sometimes needed after changing bootloaders on s-off phones,or after running RUUs) fastboot boot <recoveryname>.img will boot your recovery even if its permanently installed. fastboot reboot will boot your phone back into the OS.

    last and not least,you can see lists of available commands to us(tho some of them you should mess with :eek:) with fastboot ? and fastboot oem ?

    glad its working for you now. driver issues are often straightened out with reboots,or starting afresh on a virgin PC :D
  12. MiketheChap

    MiketheChap New Member

    I have this issue as well. Running Windows 7. I get to the place where I am trying to get the token ID. Using ADB it reboots fine to the bootloader. It says locked near the top of the screen, Fastboot several lines down, then it says Bootloader. After that it just hangs on "Waiting for Device". Several times using the ADB DEVICES command, it does give me my device number, so I think the drivers must be working right (if it's responding to the adb commands). I have tried manually following the way HTC says to do it, the Super Tool. and a variant of your instructions but can't get past that point. I'd be grateful for any help.

    USB debugging is turned off, fastboot is turned off.

    Mike
  13. scotty85

    scotty85 Guides Guide

    usb debugging must be turned on.

    after turning usb debugging on,unchecking "fastboot" in settings/power,plug in the phone and select charge only mode.

    now open your cmd window. if adb devices is returning the serial number,then adb reboot bootloader. this will take you to fastboot,wich is the screen you want to be on for using fastboot commands in the cmd window.

    do NOT push the power button to select bootloader,as this will take you to hboot,and the fastboot comands will not work there.

    after your phone boots to fastboot(wich may take several seconds) try fastboot devices if you get a serial number then,youre good to go. :cool:

    if not,then it must be some sort of driver issue.

    as said above,disable/uninstall htc sync and any other programs capable of communicating with your phone. with your phone plugged in and in fastboot mode,locate the phone in device manager. try installing the drivers manually,as described here: public:windows_hboot_driver_install [RootWiki] tho keep in mind that guide is for older,mtd devices. you want your phone to be in fastboot,not hboot.

    id use these drivers: http://downloads.unrevoked.com/HTCDriver3.0.0.007.exe
    they are a .exe file,so if you havent tried it allready,just try running the .exe and then repeat the steps above to see if you now ger a serial number from fastboot devices if that doesnt work,you can extract that file and direct windows to that unzipped folder when manually undating them with device manager.

    hope that helps :)
    MiketheChap likes this.
  14. 2011mazdaspeed

    2011mazdaspeed Well-Known Member

    i usually dont post when people have issues cuz its something they didnt read, BUT i did root mine and my father in laws rezound with no issues, now just did my mother in law, and SAME PC , had issues like ur having - i used the mini-adb.zip file in tut and for some reason, had no issues getting it to see the device and DONE. so try that. i didnt turn fastboot off, left it on but i did turn on USB debugging

    hope this helps
  15. blu422

    blu422 Member

    ignorethis
  16. Backslider

    Backslider New Member

    Old thread but, this is what worked for me.

    Look at your USB ports. I noticed one of mine has a black plastic tab rather than blue (Sony Vaio). I plugged into the one with the black tab, waited (it takes a while for the phone to load), then all went as planned.

    I assume that the black tabbed port is USB2.
    scotty85 likes this.

Share This Page