Root success on PCD/Alcatel/Virgin Mobile Venture (aka JukeB)


  1. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    well in the CWM thread i mention there is a flash_iumage gui app that you could use. i dont know if it works as no one has tested it yet.

    you could downlaod the image and use that app to flash it
  2. jonjonn420

    jonjonn420 Member

    The flashimageGUI.apk says the venture is not supported..but I tried rom manager and installed the optimus m+ option but I'm not sure it worked I boot to recovery but it goes to the "alert" or "warning" screen
  3. b_randon14

    b_randon14 Well-Known Member Developer

    never use rommanger on an unsupported phone. You flashed an optimus m recovery image to your phone.

    On your phone, download the recovery image to your phone(from this forum) and the flash_image.bin to your phone.

    Move the flash_image.bin to /system/bin by using root explorer or something, rename it to flash_image and give it 755 permission(read on all write on owner, execute on all) the move the CWM-Recovery.img to /system and rename it to recovery.img and give it read write permissions on all.

    Then using a terminal emulator app type:

    Code (Text):
    su
    /system/bin/flash_image recovery /system/recovery.img
     
    Then you should have the venture recovery image on your phone.
    jonjonn420 likes this.
  4. jonjonn420

    jonjonn420 Member

    I need the image download link or a link to the thread...helps??
  5. b_randon14

    b_randon14 Well-Known Member Developer

    You need to download the CWM-Recovery.img that is found in the cwm thread. There is a link to both the recovery image and the flash_image on that thread!
  6. jonjonn420

    jonjonn420 Member

    T
    The image download link fails and the recover "here" link gives me a txt file...
  7. divinebovine

    divinebovine Well-Known Member Contributor

    I just tried them both, they both work for me. Not sure why one failed, but the one coming in as a txt file can probably be fixed by trying a different browser. May I suggest Opera@USB?
  8. jonjonn420

    jonjonn420 Member

    .
    I used dolphin browser and it wored..but when I typed "system/recovery.img" it couldn't find anything

    $ export PATH=/data/local/bin:$PATH
    $ system/recovery.img
    L not found
    mem=458M: not found
    ANDROID!z4Ppz4z40?70: not found
    70: not found
    : not found
    system/recovery.img: 12: Syntax error: ")" unexpected
    $ 1;2c
  9. divinebovine

    divinebovine Well-Known Member Contributor

    If I understand what you posted correctly: You don't run the image from a command line. You write the image to your flash memory then boot from it. See post #28 above.
  10. jonjonn420

    jonjonn420 Member

    I'm sorry for being a noob but I'm not following what you mean ...please help and elaborate..I've been stuck to this forum for days
  11. divinebovine

    divinebovine Well-Known Member Contributor

    Just a reminder: All the stuff we're doing here (rooting, imaging, etc) could easily break your phone. Do not forget that. Anyway...

    In your post it looks like you tried to run the recovery image as if it's a program. It's not. It's a filesystem image. That means that it's basically a bit-by-bit recording of a whole partition. It is an entire operating system (albeit a small one for a special purpose) and, once it's been "flashed" (written to the appropriate flash memory partition), you run it by rebooting the phone into it. You need to use a special program to replace your existing recovery image with the new one. Instructions are in the recovery image thread:
    http://androidforums.com/venture-al...very-cwm-virgin-mobile-venture-6-0-1-2-a.html
  12. jonjonn420

    jonjonn420 Member

    I followed the last instruction and this is what I got from terminal emulator

    $ export PATH=/data/local/bin:$PATH
    $ cal/tmp/flash_image recovery /data/local/tmp/recovery.img
    failed with error: -1
    error writing recovery$
    $

    I gave flash_image these permissions
    Read-all. Write-user. Execute-all

    And I gave recovery.img these permissions
    Read-all. Write-all. And I left the execute permissions like this---group and others checked and user unchecked
  13. b_randon14

    b_randon14 Well-Known Member Developer

    Run that command as root l, like type su in first to obtain root then use flash image to flash the recovery. Flash image has to be ran by a root user so you must type su beforehand.
  14. jonjonn420

    jonjonn420 Member

    Ohh ok I did that and this is what I got but when I turn my phone off and use power vol down and vol up its boots to a black screen...

    $ export PATH=/data/local/bin:$PATH
    $ su
    # cal/tmp/flash_image recovery /data/local/tmp/recovery.img
    mtd: successfully wrote block at 1950c00000000
    mtd: successfully wrote block at 1950c00040000
    mtd: successfully wrote block at 1950c00080000
    mtd: successfully wrote block at 1950c000c0000
    mtd: successfully wrote block at 1950c00100000
    mtd: successfully wrote block at 1950c00140000
    mtd: successfully wrote block at 1950c00180000
    mtd: successfully wrote block at 1950c001c0000
    mtd: successfully wrote block at 1950c00200000
    mtd: successfully wrote block at 1950c00240000
    mtd: successfully wrote block at 1950c00280000
    mtd: successfully wrote block at 1950c002c0000
    mtd: successfully wrote block at 1950c00300000
    mtd: successfully wrote block at 1950c00340000
    mtd: successfully wrote block at 1950c00380000
    mtd: successfully wrote block at 1950c003c0000
    mtd: successfully wrote block at 1950c00400000
    mtd: successfully wrote block at 1950c00440000
    mtd: successfully wrote block at 1950c00480000
    mtd: successfully wrote block at 1950c004c0000
    wrote recovery partition
    #
    roadkill42 likes this.
  15. divinebovine

    divinebovine Well-Known Member Contributor

    Nevermind, I was too slow.
  16. divinebovine

    divinebovine Well-Known Member Contributor

    Not sure where you're getting the volume down/up thing, but the Venture boots to recovery by holding the Home button as you power it on.
    jonjonn420 likes this.
  17. jonjonn420

    jonjonn420 Member

    Ohh I feel like a dummy now.. thanks a lot tho for all the helps now we can get to roms and kernels :)
  18. b_randon14

    b_randon14 Well-Known Member Developer

    Booting to recovery is just power and home and hold it until the splash image shows up.

    But yeah that output mean it flashed it right!
  19. reedkritt

    reedkritt New Member

    thank you very much for all ur hard work as we know rooting a android isnt just for tethering i have a virgin venture it worked on and was able to set it up the way i wanted and it worked on my At&T Fusion go phone so this does work on other phones other then virgin and was able to integrate googlevoice sms into my go phones stock sms sender,reciever and install grooveip for google voice once again thank you very much
    also i paid 100 bucks for my virgin venture and just noticed that its on sale at bestbuy for 39.99 for anyone that is intrested in this phone the viirgin venture specially since it can be rooted and plans go as low as 35.00 a month for 300 voice mins unlimited text and data and web but the 300 voice mins can always be substutied with google voice have 300 voice for family and give ur friends ur googlevoice number so that u dont kill all ur mins or set it up like i got with grooveip to prompt me whenever i make a call
  20. pbj101977

    pbj101977 New Member

    Big thanks! Root on my venture also!
  21. SimsKITblue

    SimsKITblue Member

    First of all THANK YOU for all you guys hard work. I am better modding my PC then my phone I will leave that to you.

    I rooted my phone only to delete google books and other junk. I did that but didn't gain any free space. It said 46MB free in ROM manager by Jrummy from the play market but when I checked the regular stock screen it said 21MB. WTF? Did I delete it wrong or does this app just not work properly? Can I restore the apps and then uninstall again with another app manager program? I used root uninstall instead of manual uninstall but when I tried it still wouldn't let me uninstall manually even after I changed the permissions. I did a fast boot and still no change. I powered off waited five minutes and powered it back on.
  22. Curtis1973

    Curtis1973 Well-Known Member Contributor

    try ICS themed venture ROM. only 70mb total. all bloat removed.
  23. randolfini

    randolfini Member

    How does this actually root my phone? What is Poot and what is Ministro II? Why do I need them? What did I download? What did Ministro II download and why? Did anything change on my phone other than gaining root access? I'm new to this so I'd like to understand the process of what happened and how. Sorry if these are dumb questions.
  24. Dracable

    Dracable Well-Known Member Contributor

    ministro just downloaded xtra library files that it needed. poot is a home-baked tool that manipulates an exploit in the venture to obtain root access. nothing has changed on ur phone besides root being granted. you must download superuser for root to work correctly tho. superuser is the tool that grants root access to your apps. after finished with rooting, you can safely delete ministro and poot, but u need to keep superuser! hope this explains it for u! any other questions, feel free to ask! :D
    randolfini likes this.
  25. divinebovine

    divinebovine Well-Known Member Contributor

    ^To expand on that:

    Poot breaks the security that prevents root access. Ministro provides libraries that Poot needs; libraries are prefabricated pieces of programming that can be re-used by other programs. It's essentially tools that Poot uses.

    Once the security is broken, SuperUser handles requests for root access, prompting you for permission and then granting or denying that permission to an app that requested it. BusyBox is a collection of small command-line tools that you can't use without rooting, but will need after rooting. Even if you don't directly run them it is likely that apps running as root will need them to do anything useful.
    randolfini and Dracable like this.
Loading...

Share This Page