Root? SuperUser? Help


Last Updated:

  1. drocket

    drocket Member

    Ok, let me start by saying I am a COMPLETE NOOB to this. The only thing I have ever hacked was my PSP. With that being said, I have looked at various sites and tuts, but have no clue whats what. The only thing I want to do is be able to run apk I download from the net, but still want to be able to use MarketPlace. Currently I have tried to install a custom game I DL'ed and get a security warning "For security,your phone is set to block installation........not sourced in the market place."

    I dont want to make my phone look any different(at least not yet) or change the speed(again at least not yet, though it does have a bit of lag) At the moment I just want to start off slow, and be able to use custom apps not from the market place.

    I have searched, but have not found an "easy noob" tutorial. I have seen "easy tutorials", but then again what might be "easy" for geek, is not easy for the rest of us.

    Forgot to mention this is the AT&T version SAMSUNG SGH-I897

    Advertisement
  2. snapper.fishes

    snapper.fishes Well-Known Member

    You don't need to root you phone for that (unless if AT&T has locked that function). Go to settings, applications, and tick the first option (should be something along the line of accept apps from unknown option.)

    Not quite sure what you are supposed to do if it s blocked by AT&T.
  3. drocket

    drocket Member

    It seems they have blocked this. Under Apps in settins I have these options

    Manage Applications--- List all the apps that are installed
    Running services
    Developement---USB Debugging,Stay Awake,Allow Mock locations
    USB Settings

    So I guess my question and needs would be "How do I gain Super User access?".

    ATT have taken a page from CRAPPLE, and make you pay and buy everything, and I asked for the the package they tried to sell me 2 months ago(unlimited data), and they said they no longer offer it.
  4. gerberman

    gerberman Well-Known Member

    Mine has the accept apps from unknown source option too, looks like your only choice is too root/upgrade firmware.
    If AT&T have locked this option I`m sure loads of other people must have had the same prob maybe try a search for AT&T and see what others have done.


    **** Just found this no root needed http://forum.androidcentral.com/showthread.php?p=236589#post236589

    runs on your pc and can install an android app right to your phone AT&T locked or not ****
  5. drocket

    drocket Member

    Thanks for the info. But ATM I keep getting "loader.bat is not an internal program." I think my pc is screwie... It took over a minute to open any folder once I connect my usb. I think it may be an autoplay problem, but I also have other issues. I may need to do a fresh install of windows.

    I am sure the program runs flawless on a "clean and good machine". But I really do need to do a fresh install.

    [​IMG]

    Attached Files:

  6. snapper.fishes

    snapper.fishes Well-Known Member

    Where are you running the program from. Sometimes you get problem if you try to run it from desktop since the reference link to desktop is pretty darn long. Try running it in the root of your C: instead.
  7. drocket

    drocket Member

    I think it had something to do with 2 SU accounts on the phone.... I deleted both, and reinstalled and it works.

    Also had another error where it said duplicate something... cant remember what exactly, but showed 2 instencec of the phone in adb... So further looking into it, it reminded me of a problem with Battlefield 2 not exiting properly, and would still show in task manager after i closed it, and that is what happened with adb, in fact it always does it, so I just set affinity to 1 processor.

Share This Page