1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Root the Reverb (no PC Required)


Last Updated:

  1. speny333

    speny333 New Member This Topic's Starter

    Joined:
    Oct 21, 2012
    Messages:
    2
    Likes Received:
    22
    I was able to root my SPH-M950 (Reverb) VM with no PC and it was totally painless:

    1 - Download Ministro II.apk (see attached) let it update.
    2 - Download Poot.apk, run it and "press here to poot"
    3 - Go to the App store to get SuperUser.

    Thats it! Enjoy!
     

    Advertisement
  2. cobretti

    cobretti Well-Known Member

    Joined:
    Feb 19, 2012
    Messages:
    81
    Likes Received:
    26
    Excellent. Run them just like he said. Update SU binary. Voila. SuperSU didn't work.
    So simple, MAD PROPS TO SPENY333!

    Edit:

     
  3. jagx

    jagx Member

    Joined:
    Nov 11, 2012
    Messages:
    11
    Likes Received:
    3
    I just rooted, tested a couple of apps that require root access and it is all working fine.

    Thank you very much for this information.
     
  4. cpk

    cpk Member

    Joined:
    Nov 24, 2012
    Messages:
    11
    Likes Received:
    0
    I get can't open files after I download. What am I doing wrong?
     
  5. cpk

    cpk Member

    Joined:
    Nov 24, 2012
    Messages:
    11
    Likes Received:
    0
    Never mind. I got it. Thanks!!!!
     
  6. christiansoto

    christiansoto Well-Known Member

    Joined:
    Aug 29, 2011
    Messages:
    157
    Likes Received:
    16
    Can someone get stock recovery
     
  7. christiansoto

    christiansoto Well-Known Member

    Joined:
    Aug 29, 2011
    Messages:
    157
    Likes Received:
    16
    Does not work
     
  8. learning2

    learning2 Well-Known Member

    Joined:
    Sep 30, 2011
    Messages:
    56
    Likes Received:
    15
  9. cobretti

    cobretti Well-Known Member

    Joined:
    Feb 19, 2012
    Messages:
    81
    Likes Received:
    26
  10. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    I have an optimus elite also, guess I should have thought of this. As for the poot apk, giantpune@ he had done wonders for the elite. You might think he's a god fit the elite.lol
     
  11. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    Ok, I just rooted and I'm also getting nagged to install a system update, that started earlier today. I don't want to lose root so I don't have plans to update until someone smarter than me looks at it. I did see that Swype is in it and Google quick search. Here's a copy of the updatehttp://www.sendspace.com/pro/dl/r0vgj4
     
  12. learning2

    learning2 Well-Known Member

    Joined:
    Sep 30, 2011
    Messages:
    56
    Likes Received:
    15
    The files were posted with no credit to the developer or pointer to the original source. While adding (what I hope was useful) info, I didn't want to imply that I had tested the files, since my phone hasn't arrived yet.
     
  13. cobretti

    cobretti Well-Known Member

    Joined:
    Feb 19, 2012
    Messages:
    81
    Likes Received:
    26
    Update then root. I updated as soon as it came over the wire. You'll be fine. I'm pretty sure you're gonna get sick of the "update push"! Once you're rooted again, trash the parts you don't want.
     
    dobbs69 likes this.
  14. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    EThat's the problem, I've already rooted and deleted the zip in the cache. I saved a copy of it, I guess I could put it back, just didn't know if being rooted prior to updating would cause problems

    Edit: ok, made the jump and kept root. Don't know of it helped but I downloaded ota root keeper and made a copy of su. Restored su after update.
     
  15. MetalLink

    MetalLink Well-Known Member

    Joined:
    Mar 30, 2012
    Messages:
    54
    Likes Received:
    9
    This doesn't sound like it enables creating Nandroid backups yet, or am I mistaken?
     
  16. vport

    vport New Member

    Joined:
    Nov 25, 2012
    Messages:
    2
    Likes Received:
    0
    I get cannot open can someone help me what am I doing wrong
     
  17. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    What are you trying to open
     
  18. mistichunter

    mistichunter Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    133
    Likes Received:
    17
    hey guys i get an error saing cant root . doesnt work for me.
     
  19. Apk07

    Apk07 Member

    Joined:
    Nov 10, 2010
    Messages:
    7
    Likes Received:
    1
    No offense but can someone who actually got this working provide proof? A video maybe? I hate to sound all suspicious, but the people claiming it worked have like 11 posts and under
     
  20. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    Well i have alot more than 11 post and i have no reason to lie. Don't have the means to produce a video, however i can provide you with my steps i took.

    1. Download the mistro ll and poot apk.
    2. Installed mistro ll first, then poot apk
    3. Ran poot and screen popped up needing to download libs
    4. I accepted and poot screen had two buttons , one to root and one to check root
    5.i pushed root
    6. When it finished it popped up an error and said i needed to reboot.
    7.i rebooted and installed supperuser, then I installed titanium and es explorer to confirm that i had root.
     
    nad1157 likes this.
  21. mistichunter

    mistichunter Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    133
    Likes Received:
    17
    hey man thanks i worked for me the second time. make sure put ur second root step on top edit the first one.0

    AND GUYS YES IT WORKS I TRIED IT AGAIN. IT WORKS. THE FIRST STEPS ARE WRONG. IM GONNA DO A VIDEO AND GIVE PROPS TO THIS GUY.
     
  22. mistichunter

    mistichunter Well-Known Member

    Joined:
    Feb 6, 2012
    Messages:
    133
    Likes Received:
    17
  23. MetalLink

    MetalLink Well-Known Member

    Joined:
    Mar 30, 2012
    Messages:
    54
    Likes Received:
    9
    Yup, this worked. Next step is to see if I can get Google Now on the device. Should be fun.

    But I'm still holding out for someone to get a recovery on here where I can make Nandroid backups, and of course, flash a non-TouchWiz version of Android. :p
     

    Attached Files:

  24. duhduh52991

    duhduh52991 Member

    Joined:
    Nov 25, 2012
    Messages:
    21
    Likes Received:
    3
    does anyone know how i can reinstall all the drivers for the reverb beats audio screwed it up factory reset didnt work
     
  25. norcalscot

    norcalscot Member

    Joined:
    Oct 26, 2012
    Messages:
    12
    Likes Received:
    4
    I'm a new user, but after watching mistichunter's video I decided to try out the rooting technique mentioned in this thread even though I had some concerns given the low post count of many of the contributors.

    My first attempt failed, complaining about a running daemon process. After rebooting my phone and using task manager to kill all running processes I tried to "poot" it a second time. This time it worked!

    I installed Super User, and Root Check, and it is indeed rooted. I then installed Titanium Backup and I'm about to try and remove the Virgin and Samsung bloatware that came with the phone.

    I would still advise caution at this point as we have no way to make complete backups yet, so if you wield your super powers unwisely you could mess up your phone and have no way to recover it...
     

Share This Page

Loading...