Root the Reverb (no PC Required)

Last Updated:

  1. mistichunter

    mistichunter Well-Known Member

    I just posted the video for people that never hage rooted a phone .

  2. jagx

    jagx Member

    I know it is hard to accept when a user with just one post gave you the solution (partly, no recovery yet) many people were looking for the past weeks, but it only proves that sometimes people just want to contribute and help. I think this is what these forums are for...
  3. norcalscot

    norcalscot Member

    There's always an exception to the rule :p

    I usually exercise caution when trying out things on a new device - people often post "guaranteed" solutions as a way to get others to be their guinea pigs...

    At least now we know the posted method works. I was able to uninstall Mobile ID, which kept pestering me to install it. Worth the price of admission for that alone ;)
  4. Apk07

    Apk07 Member

    Yeah I didn't mean to sound rude or call anyone a liar, I was just being cautious as a handful of popular developers took a few stabs at this phone and didn't get very far, but then this super simple solution randomly pops up from a new user. If it truly works then the OP deserves plenty of praise :eek:
  5. vport

    vport New Member

    How do u get poot file to open
  6. mistichunter

    mistichunter Well-Known Member

    hey VPORT just download poot.apk to ur phones sd card do that after uve installed ministro on ur phone. go to my files icon on the apps icon in your reverb . select it poot.apk and clik "install"

    after that open poot and "accept" to dowload binaries.

    next select "click here to poot"
    u will get an erro 64 saying to reboot ur phone . reboot ur phone install superuser.

    run superuser and select "info" after that select "outdated binaries" and check it
    next clik on top of outdated binaries and clik to update another screen come ups select "update" . after that u will get a bunch of green letters saying "okay" that means ur phone is being rooted.

    next download root cheker and install it. open root cheker and clik on "allow" from superuser '

    next select "check root access". thats how u do the steps in rooting the phone.
    ricsam, vport and kzrdrnc like this.
  7. cpk

    cpk Member

    I have root but TB says unable to access root. Am I doing something wrong?
  8. mistichunter

    mistichunter Well-Known Member

    1 download ministro
    2 download and "install poot.apk" poot and "download binaries"
    4. clik on "clik here to poot" on poot menu
    5."restart phone" do <<<this after selecting "clik here to poot"
    6 download and install superuser
    7 open superuser and "select info"
    8. check "outated libraries" and select red or green letters on top and clik on "update" .
    9.. clik on "allow" for superuser request
    10. you will get a bunch of "green okays" and install root cheker
    12. open root cheker
    13 clik on "check root access" and clik on "allow" request from superuser
    after that u should get a message like this


    make sure uve done ti this way. cause if u dont it wont work.
    shyFluttershy, amh045 and dru42 like this.
  9. mistichunter

    mistichunter Well-Known Member

    guys can u make this last instructions i typed a sticky they work perfectly. speny333 ur steps are kinda confusing for alot of people ive broken it down for 12 steps. follow them and u wont have issues rooting the phone tomorrow i will post a better updated version of my video
    kzrdrnc and sheureka like this.
  10. kzrdrnc

    kzrdrnc Well-Known Member

    Thanks for the easy layout info!
    I ordered a couple of this these phones yesterday for me and the wife.
    Now Ill have root thanks again. :D
  11. mistichunter

    mistichunter Well-Known Member

    no problem were here to help
    cpk likes this.
  12. cobretti

    cobretti Well-Known Member

    How can this be so confusing? The OP's instructions are fine! We need videos and walkthroughs? No wonder the jobs are leaving our shores by the droves. Are some of you folks the reason McDonald's put pictures on their registers? APPS TO EXPLOIT ROOT. Doesn't get easier than that.
  13. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    If you guys want cwm someone needs to provide the stock untainted recovery.
    bunanson likes this.
  14. kzrdrnc

    kzrdrnc Well-Known Member

    More work in progress, with all these new phones coming on line in the next few weeks were going to need it.:D
  15. learning2

    learning2 Well-Known Member

    This kind of put-down is absolutely not necessary. Everyone is a beginner at some time, and some people are more nervous about rooting than others.
  16. blue_cat

    blue_cat Member

    I've been trying to do that, but the mtd table in my phone is empty. All that it has is "dev: size erasesize name" without any of the info. Unless I somehow unknowingly erased that, I think the phone came like that. Is there any other way to copy the recovery?

    Edit: I tried using romdump to dump the partitions, but when it finished, the recovery partition was missing. I'm guessing that's because of the missing info in my mtd table, though.
  17. superboy4444

    superboy4444 Well-Known Member Developer

  18. bunanson

    bunanson Well-Known Member

    I know a bit about push/pull/adb/recovery/lock/unlock bootloader/twrp/cwm, not too much, just a bit. If with enough guidence, I would try to extract a stock ROM from my reverb. And hope that would stimulate some custom ROM in return,


  19. blue_cat

    blue_cat Member

    Hi, could you enter the following command into a terminal emulator (you can get one from the market) and tell me what the results are?

    cat /proc/mtd

    Note: This won't do anything to your phone. It will just list the contents of a file. The same thing could be achieved using a root file browser.

  20. cobretti

    cobretti Well-Known Member

    I ran that cmnd.
    Dev: size erasesize name
  21. cobretti

    cobretti Well-Known Member

    I apologize. I was out of line. :(
    kzrdrnc and learning2 like this.
  22. Jimmy422

    Jimmy422 Well-Known Member

    Could somebody that has root use Titanium Backup to get me a backed up copy of the stock "Google Books" application? I deleted it and then lost the backup (stupid, I know), and now I can't update my Reverb.
  23. superboy4444

    superboy4444 Well-Known Member Developer

    How to get Google Now on ICS - YouTube got it!
  24. MetalLink

    MetalLink Well-Known Member

    Yeah, same thing as cobretti. See: screenshot.
  25. xclusive585

    xclusive585 New Member

    Can't provide "proof" but I sure can +1 that this works. I rooted TWO Virgin Galaxy Reverbs last night. When I did the wifes there was an "error" upon completion, but the built in root check verified root, and upon restarting I was able to have root access with ES file explorer.. [Now to figure out the boot screens on this thing. I can disable em, but not change em. :-(]
    speny333 likes this.

Share This Page