[ROOT] Ultimate DROID3 Root/ROM Thread


  1. Knitewulf

    Knitewulf Well-Known Member

  2. imnotmikal

    imnotmikal Well-Known Member Developer

    Thanks, I will update links in the next couple of days.

    Side note: added IRC information to the OP. Come hang out with us!
  3. RyanGSams

    RyanGSams Active Member

  4. imnotmikal

    imnotmikal Well-Known Member Developer

    I still haven't got around to updating the OP, but I promise I will do it soon.

    Also, as per AF's admins request, Wireless Tether discussion as been removed.

    Feel free to contact me if you need help.
    inm@android.net
  5. cableguynoe

    cableguynoe Well-Known Member

    I just had the same problem. Seems like it only did a factory reset. But i am still rooted and still running Liberty.
    Anyone know what the problem might be?
    These are the instuctions I followed:
    The one step I was a little confused about was step 3. Is says to extract the SBF contents into files folder. Well,i just dragged the whole file into that folder because it wasn't something that I could extract. At least I dont think I could.
    it ends with .rar. Can that be extracted? Maybe that's where I went wrong.
  6. doogald

    doogald Guides Guide

    Yep, .rar file are similar to zip files - just a different format. I don't use Windows much anymore, but I believe that 7-zip is the thing that many people use: 7-Zip (though perhaps other Windows users have a better tool.)

    http://www.7-zip.org/
    cableguynoe likes this.
  7. derricomonico

    derricomonico New Member

    I'm having the same problem. My machine plays the notification sound that something has been plugged in but the batch file can't seem to find my device. No USB hub, straight connection. Any other thoughts?

    I eventually got it to respond, think it was just dumb luck that it finally saw the phone but, of course, my battery went low and it failed during flash. Charging now...

    So I charged the phone all night w/ my wall charger and it still says low battery. During the batch file's processing, four lines say: "(remote: Battery Low)".

    Can it no longer charge because the flash initially failed?

    I also tried the RSD Lite method and get the following error: "Failed flashing process. Failed flashing process. 1/18 flash mbm "allow-mbmloader-flashing-mbm.bin" -> Phone returned FAIL.;phone connected".

    I'm running out of ideas.

    RESOLVED: 1/31/12 7:45pm Eastern - turns out that it was simple the charging issue. The phone can't charge if the phone gets completely wiped. Good times. I had to find a battery w/ enough charge to get it done. I'm back up! Thanks!
  8. imnotmikal

    imnotmikal Well-Known Member Developer

    Alright, it's been long enough.

    I'll be editing and updating the OP tomorrow around 5PM EST during class, and should be done by 9PM EST at the very latest (that's assuming I don't finish in class, figuring in dinner and driving time)

    I will also personally contact each of you members who have posted, if you haven't solved you problems already.

    Thanks for being patient,
    Michael Adcock
  9. cableguynoe

    cableguynoe Well-Known Member

    Thank you. 7-zip worked like a charm. For some reason the unzipper I was using wasn't unzipping the .rar file.
  10. WarMace

    WarMace Well-Known Member

    Safestrap link is broken. Seems to be a formatting issue.

    Edit: Is 1.0 the latest version? It does not seem to install on my Droid3
  11. doogald

    doogald Guides Guide

    I downloaded and installed it a few days ago, and it was fine. The latest release is 1.08; you can find it directly here: Hash of Codes: Downloads

    (Look for the Droid 3 download.)

    Read the instructions carefully... ( Hash of Codes: HOW-TO Safestrap )
  12. imnotmikal

    imnotmikal Well-Known Member Developer

    Link fixed, sorry about that.
  13. tirral

    tirral New Member

    Thanks for compiling this excellent guide! Just a couple of things from the perspective of someone who is just now rooting his D3:

    1. Safestrap seems to have moved from blogspot - the new How-To Safestrap link is here

    2. I have read (on this forum) that the current OTA version, 5.7.906, is not rootable using psouza4's one-click root. So for new rooters, this may not be the best method. Could the OP be updated to include the option of using Motofail to root?

    Again, I really appreciate the resource!
  14. doogald

    doogald Guides Guide

    While I agree with you, just a quick note that 906 is not yet officially released by OTA. Apparently some people have received phones with 906 installed when they have done warranty exchanges, but it has not been released with an OTA update yet.
  15. tirral

    tirral New Member

    Oh, thanks for the clarification. I just assumed it had been pushed out OTA, since it came on the Droid3 that I just got from Amazon (upgraded my OG Droid).
  16. redsox985

    redsox985 Well-Known Member

    It hasn't been pushed OTA yet, but according to Tier 2 Moto Tech Support (I'll elaborate here later), it is the latest build and is official. Why it hasn't been pushed OTA yet was a mystery to them, but it is the latest, as confirmed by Moto.

    **Side story*** My phone is unable to receive signed radio images aside from the 5.6.890 image (5.7.894, 5.7.902, 5.7.905, & 5.7.906 all fail) and flashing through stock recovery encounters a flash failure when flashing the radio and bricks my phone. There's 1 other user on XDA with this same issue. I've spent a great amount of time on GTalk with a few hard core Android-ers, including Cell Zealot, all of whom have been baffled and said talking to Moto is all they could think of. I need to call them back and talk to Tier 3 (highest level of support) because Tier 2 hasn't been able to help me.
  17. doogald

    doogald Guides Guide

    Perhaps some of the flash storage sectors are bad, and there is not enough space to flash the new image? That would be a lot easier to detect (and possibly fix) if there was an engineering bootloader...
  18. redsox985

    redsox985 Well-Known Member

    Flashing any leak results in a brick, then FXZ'ing to 890 fixes it, so somehow, that radio image is able to write.
  19. chadwick108

    chadwick108 Well-Known Member

    I recently received replacement device that update was pushed to I can verify that motofail Will work on the update to root. Also used same package to root razor.
  20. RyanGSams

    RyanGSams Active Member

    I am not trying to unroot my D3, but neither of the 2 ways works for me. I tried Pete's Motorola Root tools, and it says Error: file /restore/ backup missing or incomplete. Where do i get that? and the Unbricking/SBFing way, i get my phone into AP fastboot, and click the Click Here file, but says that it cannot load any of the files. Any help would be appreciated.
  21. doogald

    doogald Guides Guide


    When you clicked "Unroot my phone" in Pete's, did you click "Yes" or "No" when it asked to restore system files? If you answered "Yes", try answering "No". If you have removed any of the system apps, so that you need to restore them, you need to click the "Help" menu and choose to download the appropriate system files. Then you need to expand those files that you downloaded to a folder called "support_files" in the folder that has the Pete's Tools.

    But, try clicking no.
  22. neron87

    neron87 Member

    vzw sent me a ota update so I took it... now im no longer rooted and petes tool will not work. what's the fix?
  23. doogald

    doogald Guides Guide

    You can root with the Motofail method for the Droid 4. It works fine with the Droid 3 with the 906 update.

    You can find it here: Security Research by Dan Rosenberg
    neron87 likes this.
  24. RyanGSams

    RyanGSams Active Member

    I didn't need the system files. It says it was successful unrooted, but it still has a custom rom on it. Shouldn't it be completely stock?



  25. doogald

    doogald Guides Guide

    Do you have a Nandroid of the system files before you installed the custom ROM? If so, you can re-root (or just start the custom Recovery - it's probably still there) and then Nandroid restore that old backup (though I would Nandroid restore what you have now, just in case.)

    If not, your best bet may be to use RSDLite to install stock.
Loading...

Share This Page