[ROOT] Ultimate DROID3 Root/ROM Thread


  1. Chef21157

    Chef21157 New Member


    +1 Here, I have tried every conceivable combination of options between my phone [and how it connects to my computer] to no avail. Please Help!!!

    I have an up to date Droid3 with Android 2.3.4, and system version 5.7.906.xt862.Verizon.en.US .

    All the drivers are up to date on my computer and I used Psouza4's one click method. The error that came back said that it could "not be done with this method, try rebooting, and hopefully you don't have a system version that this exploit has been fixed".

    If anyone here has had this problem and knows what I am doing wrong and/or how to fix it I would be truly Grateful!!!

    Thanks in Advance!!!:D
  2. doogald

    doogald Guides Guide

    You cannot root system version 906 with Pete's one-click method. You need to use Dan Rosenberg's MotoFail method for the Droid 4 (which also roots the Droid 3).

    See Security Research by Dan Rosenberg
    gexnefx likes this.
  3. Chef21157

    Chef21157 New Member

    As I am glad I thanked you all in advance, Motofail did in fact work. And great for that matter, took less time than I was expecting... Thanks again!!!
    gexnefx likes this.
  4. gexnefx

    gexnefx Member

    MotoFail worked for me as well. All: THANKS!
  5. jbirdp

    jbirdp New Member

    Can you tell me where I can locate the .sbf file
  6. doogald

    doogald Guides Guide

    Welcome to Android Forums!

    Which version of the Droid 3 are you running? Is it a Verizon phone? Do you know which software version that you have? (If you can, you can find out at settings->about phone - System Version.)
  7. jazz53

    jazz53 Well-Known Member

    Motofail not working for me.
    Get
    'adb' is not recognized as an internal or external command, operable program or batch file.

    I extracted motofail.zip to a folder connected D3 in pc mode and ran run.bat.

    It says device found, then all errors: 'adb' is not recognized as an internal or external command, operable program or batch file.

    What did I miss?
    What do I do next?
  8. jazz53

    jazz53 Well-Known Member

    OK, I think I got this one to work.
    http://www.corusa.com/public/motofail.exe

    Followed these directions

    1. On your Motorola Droid 3, go to Settings > Application > Developmentand enable USB debugging mode.
    2. Connect the Droid 3 to your computer via USB cable. Your phone should be recognized by your computer if you have correctly followed the Requirementssection given above!
    3. On your phone, pull down the notification center, tap on the USB connection, and select Charge Only mode.
    4. If you are using Windows 7, right-click on the downloaded motofail.exe and select Run as Administrator. If you have Windows XP, you can right away double-click and execute the tool.
    [​IMG]Now simply press any key to begin rooting your Droid 3. Once rooting is done, you will get message Exploit complete!. Disconnect the USB connection and enjoy the rooted Droid 3. The rooting tool also installs the Superuser app using which you can control and manage the superuser rights to the apps that you install on your phone.
  9. jazz53

    jazz53 Well-Known Member

    OK installed Safestrap v1.08 and enabled it.
    now my D3 will not boot. Am I missing something?

    How do I create a nandroid in case things go for a real shit?
  10. doogald

    doogald Guides Guide

    Did you have another bootstrap/recovery installed before you installed Safestrap?

    When you restart after installing Safestrap recovery, it puts up an obvious splash screen that tells you to press "Menu" to enter Safestrap Recovery, Press "search" to boot the phone normally, or wait 10 seconds to boot the phone normally. From Safestrap Recovery after pressing "menu" you get an equivalent to the Clockwork Recovery menu, where you can create Nandroid backups, etc.

    Safestrap's instructions make it clear that if you have another bootstrap/recovery installed you should not install Safestrap until you remove the other.
  11. jazz53

    jazz53 Well-Known Member

    I do not believe I have another bootstrap loader installed.
    Safestrap is the only app loaded after rooting except root checker.
    Are any of these not compatible?
    Superuser
    Clickfree
    SMS backup and restore
    Root Check Basic
    ES File explorer
    App Backup and restore

    I got my ph to boot after disabling Safe System.
  12. jazz53

    jazz53 Well-Known Member

    For more information about the Safestrap, click here.

    Link not working
    page not found 404
  13. doogald

    doogald Guides Guide

    jazz53 likes this.
  14. jazz53

    jazz53 Well-Known Member

    I used droid3 v1.08
    When I created a backup, it did not back up apps.
    I have software ver .906 on my D3. Do I have to use the D4 ver 2 of safestrap? (like I had to use D4 root)
  15. doogald

    doogald Guides Guide

    Explain what you mean by "when I created a backup, it did not back up apps."

    Nandroid backup is equivalent to making a Ghost image of a Windows PC - when you restore a Nandroid backup, it brings your phone back to the *exact* state that it was in at the time that you ran the backup. If you are looking for an app to backup your apps and data, so that they can be restored easily, I suggest that you get Titanium Backup Pro (pay for the pro version - it is much more functional *for restores* than the free version is.)

    And you *definitely* want the Droid 3 version of Safestrap - I actually hope that the D4 version would fail if you tried to install it, but I do not know.

    Safestrap in a quick explanation: toggling safe system allows you to set aside your stock, rooted Droid 3 system so that you can install custom ROMs in an environment that will not mess up stock, making it easier to recover if you run into a problem with the custom ROM.

    So, in Safestrap, you will do something like this after the first install:

    - Download a custom ROM zip file to your internal storage or SD card
    - Download and install Safestrap
    - Install recovery
    - Restart the phone, to verify that Safestrap starts and the phone still boots
    - Shut down phone and start Safestrap Recovery when prompted
    - Backup stock
    - Toggle safe system

    You only do those steps once.

    From this point on, the steps are about the same:

    - Start in Safestrap
    - Wipe data/factory reset
    - Some people go into the Mounts menu and format /system. I don't usually do this, because most custom ROMs do this anyway, but it doesn't hurt
    - Flash a zip file. Choose the file that you downloaded above from internal/SD card
    - Power off from the menu
    - Restart
    jazz53 likes this.
  16. redsox985

    redsox985 Well-Known Member

    Rooting won't remove a previously installed BootStrapper. A nandroid won't back up "apps" expicitly, but it backs up /data and /system, both of which have an /app sub-partition.
    jazz53 likes this.
  17. LFerryT

    LFerryT New Member

    hi all, i was update my droid 3 up to .906. Now i want root it (never root before), can i use this tool?
  18. doogald

    doogald Guides Guide

    If you are 906 the Pete Souza one click no longer works. Dan Rosenberg's motofail method works, though.

    See Security Research by Dan Rosenberg
  19. lambodiablo

    lambodiablo New Member

    Hi All,

    I am new to the website and rooting. I have downloaded the SBF file 5.6.890 to flash my droid 3 using RSDLite 5.5. But when I proceed with the flashing it fails on step 6. I have tried two different SBF files. Both had the same result.

    Has anyone else had their flashing fail on step 6?

    Thanks!
  20. doogald

    doogald Guides Guide

    If your phone updated with the latest OTA in May, you will not be able to flash 5.6.890. However, you do not need to flash with RSDLite in order to root the phone. So, I'm wondering: are you trying to flash with 890 because there was a failure rooting, or are you misunderstanding the steps?

    Or, to explain again,in order to root, all you need to do is to follow the steps for Dan Rosenberg's Motofail method at his site: Security Research by Dan Rosenberg

    (The Pete Souza one-click no longer works with the Droid 3 906 update, though the Motofail method works with both 890 and 906).

    Good luck!
  21. imnotmikal

    imnotmikal Well-Known Member Developer

    I am just reporting that I will no longer be supporting this thread. I left the D3 about 4 months ago. It finally broke last week and I am officially done with it.

    Good luck everyone.

    I will, however, still provide all the files and information needed for Wireless Tethering.
    Email me at inm@android.net if you need those.
  22. tk40

    tk40 New Member

    Hello Doogald,

    I tried flashing my new Droid 3 running 906 the same way the poster you just replied to did. It failed for me in the same step, I understand now why it failed, but now in order to start my phone I have to boot while holding both volume buttons so I can get into the Boot Mode Selection menu.

    How can I correct this problem so my phone will just boot up normally?

    On another note, I just used the Motofail method and it worked for me. How do I go about debloating my phone now? I'm not really interested in different roms, I just want to get rid of the extra crap that they forced on my phone.

    Thanks in advance!
  23. doogald

    doogald Guides Guide

    I would think that using the 1click to go back to stock and starting over is your best bet, though I have to say that this has never happened to me, so I'm not 100% sure.

    [6-21-2012] droid 3 xt862 .906 to .890 1_click_sbf .exe - xda-developers



    I can think of two things that you can look at:

    Droid 3: Apps That Are Safe To Remove Once Rooted - Android Forums at AndroidCentral.com (for this, I would use titanium backup pro to freeze the apps, just in case.)

    But, this may be easier: [Script] Safe bloat removal script (50+ apps) [UPDATED 9/1/2011] - xda-developers (this is actually what I used to debloat.)

    Good luck.
  24. tk40

    tk40 New Member

    Thank you Doogald for your help.

    After restoring to stock .890 can I safely do on OTA update to .906? Or is there a reason that 1 click puts you to .890? Not sure if its a custom .890?

    Is there a free app I can use to freeze or remove programs?
  25. doogald

    doogald Guides Guide

    Yes you can upgrade to 906. It brings you back to 890 because (I believe) nobody has the official files needed to make a 906 update.

    The Pete Souza script I linked above is completely free.
Loading...

Share This Page