Root


Last Updated:

  1. three4one

    three4one Member This Topic's Starter

    Joined:
    Apr 13, 2012
    Messages:
    21
    Likes Received:
    6
    I was able to root using Framaroot (second option).
    Phone info:
    boost mobile
    av 4.1.2
    sw 1.002sp
    hw 0102
    build jz054k

    Not able to figure out how to tether (if that is even possible with the boost phone)

    UPDATE:
    I was able to usb tether and bluetooth tether.

    To tether install Pdanet+ on the phone and PC. I had to also install easy tether on the pc to get the ADB usb driver.

    PC info:
    windows 7 home premium sp1
    64-bit op system
     

    Advertisement
    Slayer72 and Loota like this.
  2. AGLtech

    AGLtech Well-Known Member

    Joined:
    Jul 7, 2012
    Messages:
    387
    Likes Received:
    59
    Seemed like the framaroot worked but rootchecker says its not and busybox won't install.
     
    Slayer72 likes this.
  3. three4one

    three4one Member This Topic's Starter

    Joined:
    Apr 13, 2012
    Messages:
    21
    Likes Received:
    6
    I know, but Voodoo OTA root keeper shows su installed and device rooted/root permission granted. I was also able to install apps requiring root. It appears to be a sort-of root.

    UPDATE:
    I used Framaroot (second option) to unroot
    Then I re rooted the same way.
    I then installed Superuser SU and busybox.

    It all worked. Titanium backup, lucky patcher, and root checkers now work properly.

    Framaroot works.
     
    Slayer72 likes this.
  4. AGLtech

    AGLtech Well-Known Member

    Joined:
    Jul 7, 2012
    Messages:
    387
    Likes Received:
    59
    You can install apps that require root no matter what. If they work or not is how you know if there are su binaries in place.
     
    Slayer72 likes this.
  5. three4one

    three4one Member This Topic's Starter

    Joined:
    Apr 13, 2012
    Messages:
    21
    Likes Received:
    6
    Root checkers don't appear to work. However, OTA root keeper does and something called browser fixer fix (requires root) also works. Lucky patcher does not seem to work. Do you have other apps to test root?
     
  6. Jose1045

    Jose1045 New Member

    Joined:
    Aug 27, 2013
    Messages:
    1
    Likes Received:
    1
    I successfully rooted my Hydro Edge and Root Checker Pro + CPU Z say I have root access.
    I'm using wifi_tether_v3_3-pre2 aka wifi tether for root that only works with root.
     
    Slayer72 likes this.
  7. Loota

    Loota Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    739
    Likes Received:
    487
    How? Please provide details :)
     
  8. Loota

    Loota Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    739
    Likes Received:
    487
    I have obtained a functioning root workaround on this phone using framaroot as the op suggested using the following steps. But first a warning.

    This is not a proper root but it will work. It is risky because you will be enabling any application that asks for root, access to root without your specific say so as is usually the case. This means that any app that wants root gets it.. even viruses. I suggest you disable superuser (like in step 3) when you aren't using an app that requires root.


    Assuming you've installed framaroot and have it opened already.

    1. Select "install supersu" instead of superuser from the drop down box.
    2. Click on Gandalf and wait till it tells you to reboot.. then reboot.
    3. Open up supersu and go to settings and uncheck "enable superuser"
    4. Re-enable superuser by checking the same box again.
    5. Scroll down to "default access" and select "grant" AT YOUR OWN RISK.

    You now have a functioning root.

    You'll probably want to install busybox now using stericson's app on the play store so you can take full advantage of your root.
     
  9. Loota

    Loota Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    739
    Likes Received:
    487
    Before this workaround solution I had installed root through framaroot and found it not working and I believe the following may have something to do with it..


    Code (Text):
    1. Root Access is not properly configured or was not granted.
    2.  
    3. Super User Application Status:
    4. Superuser application - version 3.1.3 - is installed!
    5.  
    6. SuperSU application - is NOT installed.
    7.  
    8. System File Properties for Root Access:
    9. Standard Location
    10. Check Command: ls -l /system/bin/su:
    11. Result: lrwxrwxrwx root u0_a95 2013-08-30 22:20 su -> /system/xbin/su
    12. Analysis: File: su is a symbolic link pointing to another file: /system/xbin/su
    13.  
    14. Standard Location
    15. Check Command: ls -l /system/xbin/su:
    16. Result: -rwsr-sr-x root root 380532 2013-08-30 22:20 su
    17. Analysis: Setuid attribute is present and root user ownership is present. Root access is correctly configured for this file! Executing this file can grant root access!
    18.  
    19. Alternative Location
    20. Check Command: ls -l /sbin/su:
    21. Result: /sbin/su: Permission denied
    22. Analysis: File system permissions restricted and denied access.
    23.  
    24. Alternative Location
    25. Check Command: ls -l /system/xbin/sudo:
    26. Result: /system/xbin/sudo: No such file or directory
    27. Analysis: File /system/xbin/sudo does not exist.
    28.  
    29. Root User ID and Group ID Status:
    30. SU binary not found or not operating properly
    31.  
    32. System Environment PATH: /sbin /vendor/bin /system/sbin /system/bin /system/xbin
    33.  
    34. ADB Shell Default User:
    35. ADB shell setting for standard access, stored in default.prop, is configured as: shell (non root) user - ro.secure=1
    36.  
    37. Results provided on your C5215 device by Root Checker Pro version 1.3.4 from joeykrim in the Android Market - http://goo.gl/NcnHn
    I don't recall if my previous device had the same symbolic link in /system/bin but poot's root checker didn't seem to like it.

    By disabling and re-enabling superuser in supersu it gets rid of the su in /system/bin and supersu seems happier for it, though not happy enough to allow you to use prompts instead of just automatically granting root to everything.
     
    Slayer72 and AGLtech like this.
  10. nipplenose008

    nipplenose008 New Member

    Joined:
    Aug 17, 2013
    Messages:
    4
    Likes Received:
    0
    new phone
     
  11. nipplenose008

    nipplenose008 New Member

    Joined:
    Aug 17, 2013
    Messages:
    4
    Likes Received:
    0
  12. starxpilot

    starxpilot Well-Known Member

    Joined:
    Jul 24, 2011
    Messages:
    536
    Likes Received:
    61
    Painfully, this method worked, I used the Framaroot version 1.6.0, and after letting Busybox do it's thing, I was able to uninstall an application in the system using ES File Explorer, however, given it is a new phone, I am incredibly nervous on deleting things, in the event they might tie to the phone's main functions.

    I deleted the Scout.apk *Bonk*.

    So far, no problems (Phone Boots up just a second faster)

    I went ahead and froze the rest of the third-party applications as well as the Boost Mobile ones, the phone boots just a little faster, but now there's less clutter blocking my view.
     
    Slayer72 likes this.
  13. AGLtech

    AGLtech Well-Known Member

    Joined:
    Jul 7, 2012
    Messages:
    387
    Likes Received:
    59
    This was surely the problem, having xbin an bin both with su wont work. All rooted here. Thanks
     
    Slayer72 likes this.
  14. MisterParadox

    MisterParadox Well-Known Member

    Joined:
    May 22, 2012
    Messages:
    104
    Likes Received:
    51
    This did not work for me at all. I am researching a technique that will actually work. Putting the supersu app in the applications menu doesn't necessarily mean you are rooted folks. Will start a new thread when I get something working.
     
  15. Loota

    Loota Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    739
    Likes Received:
    487
    huh?

    Edit: supersu is placed in /system/app/ by framaroot which allows it to place the proper binary in the proper place if you use supersu to reinstall the binary as I suggested. If you follow my quoted instructions you will have root but its not properly done. Up until last week I did not have a functioning computer but now that I do perhaps we can find a better solution but I don't think there are any instructions in this thread that say "download supersu and enjoy root!"
     
  16. MisterParadox

    MisterParadox Well-Known Member

    Joined:
    May 22, 2012
    Messages:
    104
    Likes Received:
    51
    You seem to have some sort of issue regarding people posting on threads. I never quoted you. My response was to the original post. Maybe you could start your own thread rather than assuming every single response to a op that was not made by you is in reference to you. Cheers.
     
  17. Loota

    Loota Well-Known Member

    Joined:
    Feb 3, 2012
    Messages:
    739
    Likes Received:
    487
    I didn't assume you were responding to me.. I assumed you thought someone said put the supersu app on your phone and you'll be rooted. My own quotation was to point you to something that worked for me.

    Edit: That said, I apologize if I came off harsh.. I suppose I can be a little blunt if I can't correlate what someone is saying to the topic at hand. Please know its always my intention to be helpful :)
     

Share This Page

Loading...