Rooted desire, can't remove my Google account...


  1. Lebenja

    Lebenja Member

    Hello, I am new to this forum and to the Android world, and need help!
    There's several similar threads but I did not find my situation in any of them.

    I have an unbranbded HTC Desire with android 2.2 and software 2.33.161.2.
    I rooted the phone with Unrevoked 3, (checked with the app Root Check that confirms I have root access) but staid so far with the stock rom.

    Now I am trying to remove my Google account in order to wipe all data from the mobile (to give it to my gf), but when I try to remove the account through settings -> accounts&sync, I get the message that the account is required by some apps and that I should do a factory reset.
    So I go into SD & Phone storage -> Factory data reset and launch the reset. The phone starts the process, shuts down but then restarts into Recovery mode (clockworkmod recovery v2.5.0.7) and stays at the main menu of recovery mode... and nothing more happens
    From there I tried the commands "wipe data/factory reset" and after "reboot system now", the phone rebooted but all my "google" account and data are still there...

    So far I blocked all the account syncs, deleted the phone data manually, and changed my google password in order to block any future syncs but the account is still there as main account....

    I thought I would try to install some new ROM from the recovery menu, following the different tutorials available so that the phone would be wiped clean, but then I keep ending up with the "status 7 error" message described in many other threads and the install fails...
    And I do not have any "empty" backup that I could restore...

    Has anyone encountered this issue before? I hope I was clear enough...
    Any help is appreciated!

    Thanks

    Advertisement
    :
  2. SUroot

    SUroot Well-Known Member Developer

    download "terminal emulator" from the market.

    Open it and type:

    cat /proc/mtd

    Then press enter.

    If it says the erase size is 40,000, you rooted your desire wrong. Let me know and I will tell you what to do.
  3. sookster54

    sookster54 Well-Known Member

    Clearing the Google account without doing a full wipe is tricky and a pain in the ass to do, but it's doable, you have to wipe data and cache on email, gmail (also your alternative email app), gmail storage market and another one I forget in manage applications.
  4. SUroot

    SUroot Well-Known Member Developer

    The problem is he tried a factory reset from clockwork and it hasnt wiped.

    My feeling is he may have a PVT4 erase 40,000 device with an erase 20,000 compatible recovery. If this is the case, we need to address this first as this could be dangerous with backups and flashing in the future.

    If he has a 40,000, this would be why the data wipe failed.
  5. Lebenja

    Lebenja Member

    I downloaded Terminal Emulator, but can't launch it... it forces close
    So I downloaded Android Terminal Emulator and it seems to be launching
    I get the blue screen with opening line
    $ export PATH=/data/local/bin:$PATH
    $
    there I typed cat/proc/mtd and pressed enter
    and reply was:
    cat/proc/mtd: not found

    I'll try again later today, must run out now, but thanks for the help
  6. SUroot

    SUroot Well-Known Member Developer

    Theres a space between cat and /
  7. Lebenja

    Lebenja Member

    Oops...missed the space... and now it worked!
    so I'm getting 6 lines with mtd0 to mtd5 (misc, recovery, boot, system, cache, user data) and on each of them, the erase size is indeed 00040000. So it looks like I rooted my Desire wrong...
    What should I do?
    Thanks
  8. SUroot

    SUroot Well-Known Member Developer

    2 options.

    1) s-off and flash amonra recovery linked in the rooting guide in my Sig using fastboot commands or fastboot flasher

    2) re root with unrevoked following the rooting guide and selecting AmonRA in unrevoked.

    The 2nd option should work but not always. If it does you need to clear data on superuser app afterwards
  9. Lebenja

    Lebenja Member

    I tried with option nr 2, found an .img file of AmonRA, followed the rooting guide with Unrevoked and it worked!!!
    Now when booting in recovery mode I came directly to AmonRa recovery and I was able to wipe all data from the phone. I restarted it and it looked like brand new (which is OK so my gf can set it up as she wants)

    a BIG BIG THANKS for such quick and effective help!! very much appreciated, now I can enjoy Saturday eve! :)
  10. SUroot

    SUroot Well-Known Member Developer

    Did you use the 2.0.1 in the rooting guide?

    Glad its sorted
    Lebenja likes this.
  11. Lebenja

    Lebenja Member

    Yes, I used the file "recovery-RA-desire-v2.0.1.img"
  12. SUroot

    SUroot Well-Known Member Developer

Loading...

Share This Page